Shelly Binding

I’m getting this error since upgrading to OH3.4:
Handler ShellyRelayHandler tried updating the thing status although the handler was already disposed.

Does setting the log level to ERROR solve the issue or does readding all Shelly devices help?

Thx, good idea.
I did the upgrade with build in binding.

I had this too. After rebooting the openhab machine no errors in the log…

The error log doesn’t solve the problem, it only shows more detailled information.
In my case after deinstalling the binding, cleaning cache and reinstalling those messages disappered. Maybe I re-created the things too.

Removing seems not to work. Now my Shelly device says “REMOVING”, but nothing happens and it is still there.

It seems that I can only remove an online Shelly device. If it is offline I need to do a force remove.

No, REMOVING indicates that the biding serving the thing is not active. Just click Remove again and the thing gets hard deleted.

One info regarding the ShellyRelayHandler-problem. You have to completely reboot the server. Just restarting openhab is not enough.

I updated the DEV build to include support Shelly Plus Wall Dimmer US. Pro 3EM gets discovered too, but is WIP.


Thanks for the 3.4.2 release. Is there anything fixed within that release regarding correct roller shutter position control with Shelly 2.5?

Update: I tried to install it but in the console I get an error:

294 │ Installed │  80 │     │ openHAB Add-ons :: Bundles :: Shelly Binding Gen1+2
openhab> bundle:restart 294
Error executing command: Error restarting bundles:
        Unable to start bundle 294: Could not resolve module: org.openhab.binding.shelly [294]
  Unresolved requirement: Import-Package: org.eclipse.californium.core; version="[2.7.0,3.0.0)"


Check the notes, you need to

  • uninstall the version coming with the official dist (from the UI)
  • run “feature:install openhab-transport-coap” on the OH console
  • copy the jar into the addons folder
1 Like

Are always the same TRVs affected? or randomly?

Turn on the DEBUG log:

  • open OH console
  • “log:set DEBUG org.openhab.binding.shelly”

extract the proper sequence. This shows communication on the thing level. If you want to see complete API interaction you could also use TRACE.

Check the device UI to verify that the Outbound Web Socket is enabled and the URL points to you OH system. This should be done automatically when initializing the device by the binding. Turn on DEBUG log (see above) and check if the event is posted to the log when you wakeup the Plus HT.

Do you have a “raw” installation or are you running OH in a Docker container? The will be an inbound http/ws request to the port you are running OH (usually 8080).

Thanks for your reply, I have upgraded to OpenHAB 3.4.0 in the meantime, which did cause some other issues due to changes in the TRV handling, but I haven’t experienced any failed updates since.

To answer your question: It was randomly, between 2 and 5 out of the 17 TRVs didn’t change their profile, when changing the group state.

Hi Markus
The ourbound web socket is configured correct:

I also changed to “TLS no validation” for testing.

The debug log shows no message when I wakeup the device. But I found at least one message:
"discovery.ShellyDiscoveryParticipant] - ServiceInfo [ServiceInfoImpl@1556540618 name: ‘ShellyPlusHT-C049EF8AF6CC._http._tcp.local.’ address: ‘(null):80’ status: ‘DNS: Master01-xxxx.local. [Master01.xxxxx.local/10.0.yy.xx] state: probing 1 task: null’, has NO data, empty]

After some minutes I had some more message:
shellyplusht-c049ef8af6cc: Status update triggered thing initialization
shellyplusht-c049ef8af6cc: Start initializing for thing ShellyTE01, type shellyplusht, IP address 10.0.xx.yyy, Gen2: true, CoIoT: false
shellyplusht-c049ef8af6cc: Ignore API Timeout, retry later

hmm, maybe the binding tries to do an API call to get some device config, which will fail, because already went back to sleep mode. Please provide a TRACE log of this situation

Here the trace: (repeated every 15Min)

2023-01-10 08:27:41.684 [DEBUG] [y.internal.handler.ShellyBaseHandler] - shellyplusht-c049ef8af6cc: Status update triggered thing initialization
2023-01-10 08:27:41.684 [DEBUG] [y.internal.handler.ShellyBaseHandler] - shellyplusht-c049ef8af6cc: Start initializing for thing ShellyTE01, type shellyplusht, IP address 10.0.xx.yyy, Gen2: true, CoIoT: false
2023-01-10 08:27:41.684 [TRACE] [shelly.internal.api.ShellyHttpClient] - shellyplusht-c049ef8af6cc: HTTP GET for http://10.0.xx.yyy/shelly

I have updated yesterday from 3.4.0. to 3.4.1.
Where I can see the changelog from the Shelly addon?
I have had to recreate my TRV, otherwise it was not more display some values.
What else I need to look on it?