Shelly Binding

fyi PR 8396 has been merged and will become part of 2.5.9 release version

  • new channel device#deviceName
  • new channel relay#outputName
  • relay#autoOn and relay#autoOff are now accepting UBM values (Number:Time)

hello markus,

unfortunately since the update i also have the problem that the input channel does not work anymore.
i used to use the shelly 2.5 on detached mode and switched the hue-lamp (zigbee) on and off with the input status via the wall button.
now i can’t get the input status anymore? maybe you can help me? thx!

i have installed all updates (shelly and binding)

i also still have this problem with the latest DEV version from 10.9.2020

@markus7017 whould be great if you could have a look at this… thx

Are you on the latest DEV build?
What‘s exactly not working?
Please provide a DEBUG log

Latest DEV build - README - Installation - Firmware Index - Firmware Archive - API Doc

I need to check the code. Keep in mind: This value is aggregated by the binding on a status poll (usually once a minute) not delivered by the device.

I think I found it, check the updated build


Latest DEV build - README - Installation - Firmware Index - Firmware Archive - API Doc

Great to hear that you found it, just updated to your latest build, will give a feedback tomorrow…

hi markus,
no, i am on 2.5.8.
since the update i am not able to receive the relay input status. i don’t know, where the problem is.

please verify with latest DEV build

Latest DEV build - README - Installation - Firmware Index - Firmware Archive - API Doc

Hi

I have Shelly 2.5 with bistable switches. When I turn on the light with the switch, turn off with openhab and click again the switch, nothing happens. By the second click it works. I have the problem since last firmware update.

Thanks for you help.

This sounds like you should check the configured button mode in the Shelly App

You could also try the latest DEV build

Latest DEV build - README - Installation - Firmware Index - Firmware Archive - API Doc

1 Like

Oh, sorry. It was stet to “toggle switch” instead of “Edge switch”. Sorry for that.

all good - No bug is a good feedback :slight_smile:

just wanted to give feedback that the “device_accumulatedWTotal” on Shellly 3EM now works correct, no more spikes

Great Work! Thx

and PR [shelly] Bug Fixes for Sensor Action events and EM3’s accumulatedTotalKWH channel #8471
has already been merged :slight_smile: So it will be included in the 2.5.9 release version.


Latest DEV build - README - Installation - Firmware Index - Firmware Archive - API Doc

I will detect an double press between x-time with a shelly 1 to increase the AutoOff time. So this is no default function

ok, but what‘s the problem?

FYI
DEV version worked fine for me as well.
OpenHab version 2.5.8-1
Shelly Dimmer 2 Firmware 1.8.4

i can’t take short press because if the repeat on the second press is to short only on short press is triggerd

2020-09-15 19:12:17.578 [GroupItemStateChangedEvent] - gLiKeller changed from OFF to UNDEF through UG_Waschkueche_Licht
2020-09-15 19:12:17.582 [vent.ItemStateChangedEvent] - UG_Waschkueche_Licht changed from OFF to ON
2020-09-15 19:12:17.798 [vent.ItemStateChangedEvent] - Shellyplug01CurrentWatts changed from 0.6 W to 0.0 W
2020-09-15 19:12:18.072 [GroupItemStateChangedEvent] - gLiKeller changed from UNDEF to OFF through UG_Waschkueche_Licht
2020-09-15 19:12:18.076 [vent.ItemStateChangedEvent] - UG_Waschkueche_Licht changed from ON to OFF
2020-09-15 19:12:18.681 [vent.ChannelTriggeredEvent] - shelly:shelly1:8caab50558d3:relay#button triggered SHORT_PRESSED

But for me it’s better to trigger of a item change, because there i can extract the Item Name to combine the item Name of the AutoOff channel.
So the best way is if i have a Item who change the state on each push on a Tasterschalter

I sent you a PM