Signature problem with apt-get update

Tags: #<Tag:0x00007f616ecd0bf0> #<Tag:0x00007f616ecd0b28>

With the release of OH 1.8 I went to my trusty terminal and tried to do an update/upgrade but I’m getting a public key error.

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.bintray.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 379CE192D401AB61

W: Failed to fetch http://dl.bintray.com/openhab/apt-repo/dists/stable/Release

I tried to reinstall the keys using the command on the wiki:

wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -

I also reran:

echo "deb http://dl.bintray.com/openhab/apt-repo stable main" | sudo tee /etc/apt/sources.list.d/openhab.list

I still get the error.

Any ideas?

Known issue, I think it’s being addressed.

Thanks!

As an aside I debated whether to post my query on the 1.8 announcement thread or create a new post. I wasn’t sure which was the right choice so I started this new thread. Do you think it is more in keeping with the forum’s culture that I should have posted over there instead?

I know there are no real set rules on such things but feel, as a frequent poster, I should provide an example of the “preferred way” in my posts.

Thanks again. I’ll watch over on the other thread for news when it gets resolved.

I think it’s great to start a specific thread as you did, so this distinct subject is easier to find.

The following worked for me:

gpg --recv-keys 379CE192D401AB61
gpg --export 379CE192D401AB61 | apt-key add -
apt-get update

2 Likes

I tried this and failed, probably because I don’t know a lick about gpg.

When I ran gpg --recv-keys 379CE192D401AB61 if seemed to work:

gpg: requesting key D401AB61 from hkp server keys.gnupg.net
gpg: /home/rich/.gnupg/trustdb.gpg: trustdb created
gpg: key D401AB61: public key "Bintray (by JFrog) <bintray@bintray.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

but when I run the second line as me I get:

ERROR: This command can only be used by root.

When I try to sudo the command:

[sudo] password for rich: ERROR: This command can only be used by root.

gpg: WARNING: unsafe ownership on configuration file `/home/rich/.gnupg/gpg.conf'
gpg: [stdout]: write error: Broken pipe
gpg: iobuf_flush failed on close: file write error

If I step back, remove my .gnupg folder and try to run the first command with sudo I get:

gpg: directory `/home/rich/.gnupg' created
gpg: new configuration file `/home/rich/.gnupg/gpg.conf' created
gpg: WARNING: options in `/home/rich/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/home/rich/.gnupg/secring.gpg' created
gpg: keyring `/home/rich/.gnupg/pubring.gpg' created
gpg: no keyserver known (use option --keyserver)
gpg: keyserver receive failed: bad URI

I’m on an Ubuntu server with the root account locked and I’m not inclined to unlock it to solve this problem.

Update:

I tried to chown the contents of .gnupg to root and run the --export with sudo and is still says:

ERROR: This command can only be used by root.

So I think the solution above only works for those who can log in as root. Ubuntu users will have to wait.

Thanks!

worked for me; I had to run the first line twice
I used the user root to do this

Better don’t do this. Currently the repo is signed with the wrong key (it’s the bintray key).
We will fix that soon.

1 Like

The repo is fixed, it’s signed again with the openHAB key.

1 Like

Thanks! I can confirm it works for me now.

I too am having related problems trying to upgrade. Here is the error that I am getting.

W: GPG error: http://dl.bintray.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 075721F6A224060A

Has anything changed in the repo and its management since 1.7.2? (Like this mention of a bintray and openhab key?)

For a brief time the 1.8 packages were signed with the wrong key. It looks like you don’t even have the key installed right now. Try following the steps on the wiki again and see if that helps, particularly steps 2 and 3.

1 Like

Thanks @rlkoshak - I reinstalled the key and everything went smoothly… far better than I would have expected!

so can we get the fixed one please ? thank you

Where is the working one please? I am getting the same problem.
gpgkeys: HTTP fetch error 7: couldn’t connect: eof
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

http://docs.openhab.org/installation/linux.html

Hi all,

issue is back. How did you solve it?

E: The repository 'https://dl.bintray.com/openhab/apt-repo2 stable Release' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Thanks.

1 Like

Hi @sihui,

thaks for the quick reply. After processing the steps mentioned the error I get via apt is unchanged.
Is it possible that extension takes longes until it is reflected in the repos?

I’ve used another repo:

This seems to work.