Simple remote control press confusion


I’m using openHAB 3.3.0 on a Windows 10 machine. I’ve got an Aeotec Gen5+, a wall plug, and a MR40Z remote control switch, that has 4 buttons. And for a guy that doesn’t like it when computers think they’re smarter than me, I’m really feeling less than smart tonight.

I’m really after something simple. If I press a button, I’d like it to send an ON command to the wall plug. If I press another button, I’d like to send an OFF command.

But the MR40Z seems to be smarter than me, and while I’ve looked at some other examples (like the Wallmote one), I can’t seem to figure out when the item state changes.

Here’s what it looks like from the semantic model:

My rule design looks like this (and is based on the topic posted here: Openhab 3 Aeotec Wallmote Zwave button to control other devices - Best practice

I’ve tried variations on the scene value, including nothing (so just item being updated), to 1, to ON, to DOWN.

And the script simply doesn’t matter because I don’t think it’s executing. Right now, it looks like this:

events.sendCommand('WallPlugSwitch17129_Switch', '1');

I’m really new to the OH community, but I don’t think I’m trying to do anything particularly difficult. But it sure seems to have me confused.

Anyone feel like helping a guy out?


Looks to me like the rule you’re using isn’t the problem; it’s that your MR40Z isn’t talking to OH yet. A quick look at the Z-Wave database that’s used by the Z-Wave binding shows:


Which means that your device is in the database, but only if you are on a version more recent than 2022-09-11. You say you’re still using 3.3 so your version of the binding doesn’t have the information for your device. You can verify this by looking at the thing details for the device. If the binding actually recognizes the device then you should have a human readable label in the information section like this:

If it just says something like 0924:D001 then the your device cannot be found by that version of the binding and no sensible communication between the device and OH will be possible.

If this is the case then you will have two choices: 1) upgrade OH to a more recent version (the most recent 3.4 milestone is quite reliable and will have the binding version you need), 2) download the latest version of binding and use that with your currently installed version (there are lots of threads here that give you detailed instructions for that).

I worked through this in a different thread (Minoston S2 Remote Control Switch MR40Z), and used the bundle:update command, and it’s been recognized.

I actually have something somewhat humorous going on, in that when I toggle the WallPlugSwitch17129_Switch manually, the log shows the state of the scene changes too.

2022-12-05 19:49:33.702 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'WallPlugSwitch17129_Switch' predicted to become ON
2022-12-05 19:49:33.714 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'WallPlugSwitch17129_Switch' changed from OFF to ON
2022-12-05 19:49:33.816 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'KitchenSwitchMR40ZNode6_SceneNumber_1' changed from 0 to 1

Excellent, then, the next thing to check is that it’s been fully initialized. Your device is a battery operated device and sometimes(frequently?) they don’t finish the pairing procedure during the first inclusion and you have to wake them up many times to finish the procedure.

Check that your device shows all the options at the bottom of the thing page like this:

Alternatively, navigate to the folder in your configuration directory that has the zwave xml files [your config dir]\userdata\zwave. Your device is Node 6 so for complete inclusion you will need to have a file named something like network_7f420b1a__node_6.xml

Yep, I had both of those too. I haven’t done anything to change this XML file however.
network_dfdab922__node_6.xml (11.2 KB)

Ok, good. (Don’t change the file!)

Then there’s no zwave related reason why your device shouldn’t be sending values to OH.

What logs do you see when you push one of the buttons on the device?

None! :frowning:

I see the button light on the remote switch, but that’s it.

Are you sure you have linked the KitchenSwitchMR40ZNode6_SceneNumber_1 device to the correct channel and that this item is the correct type (likely a Number Item)?

That, TBH, I’m not completely certain of.


Through trial and error, I wonder if this could be part of the issue? There are two things linked here.

Talking this through with you was very helpful. There’s definitely something wrong with Scene 1. I created a Scene 2, and I’m getting the proper log events and managed to turn the switch on!

2022-12-05 21:00:59.257 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'WallPlugSwitch17129_Switch' received command ON
2022-12-05 21:00:59.257 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'WallPlugSwitch17129_Switch' predicted to become ON
2022-12-05 21:00:59.295 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'WallPlugSwitch17129_Switch' changed from OFF to ON
2022-12-05 21:00:59.388 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Switch' changed from OFF to ON
2022-12-05 21:00:59.389 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'KitchenSwitchMR40ZNode6_SceneNumber_1' changed from 2.0 to 1
2022-12-05 21:01:01.465 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'WallPlug17129_Electricmetervolts' changed from 0 to 100.39
2022-12-05 21:01:04.180 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'WallPlug17129_Electricmetervolts' changed from 100.39 to 121.84
2022-12-05 21:01:05.807 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'KitchenSwitchMR40ZNode6_SceneNumber' changed from 2.0 to 1.0

Yes, this is a problem. You would normally want an Item to represent only one channel, one device.

(There are advanced reasons to bend that rule of thumb which is why multiple links are allowed - you don’t need to be going there)

1 Like