Socket.IO Error: not authorized

Hey guys,

This is what I’m getting: 2016-10-13 19:04:24.488 [ERROR] [o.myopenhab.internal.MyOpenHABClient] - Socket.IO error: not authorized

I saw a few other forum posts about this error but in their case it seemed to be uuid/secret related. I got the uuid/secret from the files in the /var/lib/openhab2/uuid and /var/lib/openhab2/myopenhab folders and pasted them into my my.openhab account. I double checked and they look like they match and I didn’t miss any characters or anything.

A little background on my setup: I first installed OpenHAB in April (on a raspberry pi 2) then around July or August myOpenHAB stopped working. The IP changed, the serial port for Z-Wave probably changed, and I didn’t mess with it for a while. Anyway, recently I upgraded to OpenHAB2. I fixed the IP issues and got all my Z-Wave stuff working. Now I’m trying to get myOpenHAB working again. I read some other forum post about updating java so I installed a new version (as well as running apt-get update and apt-get upgrade). Here’s what my java -version says:

java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ Client VM (build 25.101-b13, mixed mode)

Any help would be appreciated, let me know if you need any more information!

Edit: I ran tail -f /var/log/openhab2/openhab.log -f /var/log/openhab2/events.log | grep myopenhab
Here’s what I got from that:

2016-10-13 20:00:01.905 [ERROR] [o.myopenhab.internal.MyOpenHABClient] - Socket.IO error: io.socket.engineio.client.EngineIOException: websocket error
2016-10-13 20:00:01.920 [INFO ] [o.myopenhab.internal.MyOpenHABClient] - Disconnected from my.openHAB service (UUID = 4ae2933a-fe41-4187-9d17-f464b2578455, base URL = http://localhost:8080)
2016-10-13 20:00:17.629 [ERROR] [o.myopenhab.internal.MyOpenHABClient] - Socket.IO error: not authorized

Edit2: I should add that the filenames for the new java are different than the blogpost here at in this link:
I downloaded the 32bit ARM version of 101 and i’m still getting “Offline” on the myOpenHAB site. It says You are using openHAB 1.x. To remotely access your openHAB’s web interface go to which is obviously wrong because i’m not in 1.x anymore, but it makes sense it doesn’t know yet because I still can’t connect to the site.

i have the same problem, even after updating to the latest version of java, it has me running in little tight circles. Even tried to enable debug logging, but no further information is forthcomming.

surely someone out there must have had a similar problem?

I am trying to get myopenhab cloud service working and I am getting the same error in my log. It says:

2016-12-19 20:10:04.658 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2016-12-19 20:10:05.583 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: not authorized

I have confirmed that my uuid and secret are correct.

does anyone know why this is occurring?

I figured it out by reading this post myopenHAB relaces my.openHAB

There is a new secret file it’s in /var/lib/openhab2/openhabcloud
on an ubuntu 14.04 apt-get installation.

You can’t just use the secret that you were using for my.openHAB it won’t work.