[SOLVED] 3 Gang In-wall Switch GR-B3-3 Not fully discovered by the binding

Hi Guys,

I have 3 Gang In-wall Switch GR-B3-3 switches that are shown as “Unknown Device” in Habmin.
However in ~/openhab2/userdata/zwave directory I can see nodes’ xml files as well as DB records for them in http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/686.

Could someone share if he encounter the same behavior or if a solution already exists.

Appreciate your support

Did you check that the manufacturer, deviceId, and deviceType in the node XML matches what’s in the database? It’s possible that your device is reporting something different than what’s in the database.

0x152 is correct
0x500 looks different. In the DB References (Type:Id) is 0A00:0004

Any suggestions?

Please confirm that your Type is 0x500 and Id is 0x5? If so, I’ll update the database for this device.

In order for you to pick up the change:

  • my db change needs to be approved by @chris
  • the change will be included in the next build of the zwave binding
  • you will need to upgrade to the latest zwave binding (easy if you are running a snapshot build)

Ok. I added that Type:Id to the database.

Thank you very much! I’ll provide a feedback once I manage to test it.

Hi Mark,

Seems that the device doesn’t get recognized by adding the new Type:Id 0500:0005

      <property name="vendor">UFairy G.R. Tech</property>
      <property name="modelId">GR-B3-3</property>
      <property name="manufacturerId">0152</property>
      <property name="manufacturerRef">0A00:0004,0500:0005</property>
      <property name="dbReference">686</property>

2017-12-08 14:22:36.977 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 5: Device discovery could not resolve to a thingType! 0152:0500:0005::1.69

Could you please advice if I have to add something different in the xml …


Hi Mark,

I have exactly the same problem with another device.


The database shows

References (Type:Id) 3102:0202

However mine are 3121:1302

Any chance you can help?


The db change I made for this device has not made it into a zwave build yet.

I just updated the database.

Keep in mind that:

  • my db change needs to be approved by @chris, after which
  • the change will be included in the next build of the zwave binding
  • you will need to upgrade to the latest zwave binding (easy if you are running a snapshot build)

Thank you for the prompt responce.

Just to clarify what I did:

I edited

fastjar -uf org.openhab.binding.zwave-2.1.0.jar ESH-INF/thing/ufairy_grb33_0_0.xml

by changing ufairy_grb33_0_0.xml

<property name="manufacturerRef">0A00:0004,0500:0005</property>

This is actually working for tkb_tz06_0_0.xml so my guess was that the same simple change will do the job :slight_smile:


Much Appreciated

I’ll try and do a database update tomorrow morning (UK time).


@bradhab @d_valchev Looks like the database updates were merged this morning. The updates should be included in the next OH snapshot build.

M ESH-INF/thing/mcohome_mhs312_0_0.xml (2)
M ESH-INF/thing/ufairy_grb33_0_0.xml (2)

I think it should be available now as I also did a rebuild…


Following your update, switched my openhabian install from 2.1 stable to lastest snapshot using sudo openhabian-config

Zwave binding has updated and my device MH-S312 working perfectly.

Much appreciated Mark and Chris

1 Like

Thank you both @chris and @mhilbush, really appreciate your prompt response.

I’d also like to confirm that my GR-B3-3 switches are recognized by the binding.

Just a small add from my side: initially the device is recognized correctly and can be controlled from OH, but its status wasn’t reported to OH when I’m switching the load from the device switches (S1, S2, S3).

Anyway I did add the below lines to ufairy_grb33_0_0.xml and now everything behaves as expected.

      <property name="defaultAssociations">3</property>
      <parameter-group name="association">
        <label>Association Groups</label>
      <parameter name="group_1" type="text" groupName="association">
        <label>1: K1</label>
      <parameter name="group_2" type="text" groupName="association">
        <label>2: K2</label>
      <parameter name="group_3" type="text" groupName="association">
        <label>3: K3</label>


If you want these changes to persist in the device definition when you install a newer release of the zwave binding, they need to be added to the device database at www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list.

I just added them to the database. I’m not sure that got got the Maximum Nodes correct because I don’t have a manual for this device. Therefore, I left Max Associations at 1.

Duh, stupid me, I edited the wrong device. :frowning:

@chris The associations I added on this device need to be rejected.

Rejected - as in deleted?

I think I just approved this one but I can reverse before updating on Github…