[SOLVED] A URL must be configured for calendar

Tags: #<Tag:0x00007fc90db960a8>

Anyone an Idea? The Calendar is a nextcloud calender, but I don’t think that’S related.

Log:

2017-12-18 22:41:30.498 [WARN ] [.io.caldav.internal.CalDavLoaderImpl] - A URL must be configured for calendar ‘’
2017-12-18 22:41:30.499 [ERROR] [org.apache.felix.configadmin ] - [org.osgi.service.cm.ManagedService, org.openhab.io.caldav.CalDavLoader, id=251, bundle=234/mvn:org.openhab.io/org.openhab.io.caldav/1.11.0]: Updating property CalDAV IO of configuration org.openhab.caldavio caused a problem: A URL must be configured for calendar ‘’
org.osgi.service.cm.ConfigurationException: CalDAV IO : A URL must be configured for calendar ‘’
at org.openhab.io.caldav.internal.CalDavLoaderImpl.updated(CalDavLoaderImpl.java:225) [234:org.openhab.io.caldav:1.11.0]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updated(ManagedServiceTracker.java:189) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:152) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:85) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1479) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1435) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.UpdateThread.run0(UpdateThread.java:141) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:109) [7:org.apache.felix.configadmin:1.8.16]
at java.lang.Thread.run(Thread.java:748) [?:?]

caldavCommand.cfg:

caldavCommand:readCalendars=hauskalender

caldavio.cfg:

caldavio:hauskalender:url=https://xxx.de/remote.php/dav/calendars/cherzog/xxx/
caldavio:hauskalender:username=haus
caldavio:hauskalender:password=password
caldavio:hauskalender:reloadInterval=15
caldavio:timeZone=Europe/Berlin

I started with actual Debian-Testing. Same message with Unstable and Testing.

This would appear to indicate your configuration has a calendar with no name.

Possibly shutting down and clearing the caches would eliminate this.

Sorry. Forgot to mention: I already cleared the cache (after every reinstall) this way:

Maybe the following line is relevant:

2017-12-19 13:12:04.210 [ERROR] [aldav_command.internal.CalDavBinding] - item registry is not set

This is probably another indication that your configuration is bad.

You could try enabling debug logging fro caldavio and caldav-command to get more information from the log files.

Log

2017-12-19 14:58:52.778 [DEBUG] [b.io.caldav.internal.CalDavActivator] - CalDav Calendar IO has been started.
2017-12-19 14:58:52.779 [DEBUG] [org.openhab.io.caldav ] - BundleEvent STARTED - org.openhab.io.caldav
2017-12-19 14:58:52.806 [DEBUG] [org.openhab.io.caldav ] - ServiceEvent REGISTERED - {org.osgi.service.cm.ManagedService, org.openhab.io.caldav.CalDavLoader}={service.pid=org.openhab.caldavio, component.name=org.openhab.io.
caldav.caldavloader, component.id=24, service.id=129, service.bundleid=234, service.scope=bundle} - org.openhab.io.caldav
2017-12-19 14:58:52.807 [DEBUG] [.io.caldav.internal.CalDavLoaderImpl] - Update was called for CalDAV IO.
2017-12-19 14:58:52.810 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: :url
2017-12-19 14:58:52.813 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: calKinderzimmer:password
2017-12-19 14:58:52.818 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: calKinderzimmer:reloadInterval
2017-12-19 14:58:52.818 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: calKinderzimmer:url
2017-12-19 14:58:52.819 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: calKinderzimmer:username
2017-12-19 14:58:52.819 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: hauskalender:password
2017-12-19 14:58:52.820 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: hauskalender:reloadInterval
2017-12-19 14:58:52.820 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: hauskalender:url
2017-12-19 14:58:52.820 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: hauskalender:username
2017-12-19 14:58:52.825 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: timeZone
2017-12-19 14:58:52.828 [DEBUG] [.io.caldav.internal.CalDavLoaderImpl] - Overriding default timezone Europe/Berlin with Europe/Berlin
2017-12-19 14:58:52.829 [WARN ] [.io.caldav.internal.CalDavLoaderImpl] - A URL must be configured for calendar ''
2017-12-19 14:58:52.834 [ERROR] [org.apache.felix.configadmin ] - [org.osgi.service.cm.ManagedService, org.openhab.io.caldav.CalDavLoader, id=129, bundle=234/mvn:org.openhab.io/org.openhab.io.caldav/1.11.0]: Updating property CalD
AV IO of configuration org.openhab.caldavio caused a problem: A URL must be configured for calendar ''
org.osgi.service.cm.ConfigurationException: CalDAV IO : A URL must be configured for calendar ''
at org.openhab.io.caldav.internal.CalDavLoaderImpl.updated(CalDavLoaderImpl.java:225) [234:org.openhab.io.caldav:1.11.0]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updated(ManagedServiceTracker.java:189) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:152) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:85) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1479) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1435) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.UpdateThread.run0(UpdateThread.java:141) [7:org.apache.felix.configadmin:1.8.16]
at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:109) [7:org.apache.felix.configadmin:1.8.16]
at java.lang.Thread.run(Thread.java:748) [?:?]

So, there are really old entries. But where do they come from?

Delete the contents of /var/lib/openhab2/cache and /var/lib/openhab2/tmp. For manual installations these folders are in your OH home folder under userdata. DO NOT DELETE THE FOLDERS THEMSELVES, JUST THE CONTENTS.

Deleting the content of the both directories isn’t enough?

Thank you.

Christian

(Sorry, I’m working with OH since 10 days …)

I saved my config-files and persistance, made a apt purge ..., reinstall and restore the files…

Now everything works fine.

Can anybody give me a link or something to read what to do in such a case in the future?

(I thought I’ve done everything before I annoy you. Thank you very much.)