[SOLVED] Adding Technisat Z-Wave Devices

Hey, I’m all new to this and I need a little help to start. I got myself the Z-Wave TechniSat Aufrüstpaket Energie which contains devices that are not listed in cd-jacksons DB (getting the “the device is not in the database” error in PaperUI). I’m pretty sure they are all just re-branded from other Companies.

Here’s what I’ve found out so far:

  • Heizkörperthermostat 2 - the thermostat is probably a re-brand of Eurotronics Spirit

  • Türkontakt 2 - door contact detector is probably based on Everspring HMS02 - At least Türkontakt 1 looks similar.

  • Zwischenstecker 3 - on / off wallplug is probably the Zipato ZIP-PAN 16

What’s the best practice here? Yesterday I already added the thermostat based on the Eurotronics Spirit to the database. I’m not sure it will work, because I don’t know if the device type / id stayed the same. How can I figure those details out, when holding a new device in my hand? Anyway, I created a pull request (PR #5916) with the new added device.

In his database guide, cd-jackson asks for being flagged when it comes to problems like this. I hope it’s you @chris

PS: As a newby I could only add 2 links. So I had to remove links on door contact and wallplug and to the PR. Get back to me if you need those.



or post your xml files from your /userdata/zwave folders.


Thanks. Would do that, but there is no add button. I have an account and I’m logged in.

I’m still at work and will post the xml files later on.

This is probably because you need permissions updated. Please let me know your username and I will update this tonight.

Many thanks. My username is “Seuthberg”.

Here are my files from userdata/zwave: https://ufile.io/vtmpv5qd (can’t attach)

I’ve updated your access. I’m not sure what node it is that needs adding, but if you have any problems, just let us know.

All of your nodes are not disvovered correctly:


If those are battery operated devices you need to wake them up with a special button sequence (check your manual on how to do that)

1 Like

This is actually quite strange. I didn’t look at the files yesterday as I didn’t know what one needed to be added, but I registered that two of them were quite large.

I’ve just looked at the node 3 file - this seems to indicate that the discovery was complete - or at least information that is discovered after the device type is provided in the file. So, I would have expected the manufacturer information to have been discovered. Node 5 is the same.

Waking the device up as suggested by @sihui won’t now help - you will need to reinitialise the device and then wake it up - there is an option in the device configuration to do this reinitialisation.

If that still results in the manufacturer data being wrong, then I’ll need to see a debug log to understand why this isn’t correct.

1 Like

you will need to reinitialise the device and then wake it up - there is an option in the device configuration to do this reinitialisation.

I guess you mean in the HABmin UI? Can’t really find the option:

Additionally: My devices have IDs 3, 4 and 9. I re-flashed my Pi and set up OpenHab again to have a fresh start. There is currently no file for those in the zwave folder:

Is there a way to force the writing of those files?

Logs attached.

openhab.log (44.6 KB) events.log (19.0 KB)

Yes - you need to reinitialise the device - once the reinitialisation is complete it will be rewritten. You can’t force it to rewrite the file if it doesn’t have the data - hence it only does it once the initialisation is done.

Could you explain what you mean by reinitialisation of the devices? Reset device and include again?

Also I couldn’t find those option in the HABmin interface you mentioned earlier.

Thank you for your patience.

No - there is an option called something like “reinitialise device” in the thing menu. It’s in both HABmin, in the dropdown menu in the top right, and in PaperUI in the config parameters.

If it’s not showing, then this is because the device is already initialising and it can’t be restarted. As the device is a battery device, it needs to be woken up to complete the initialisation - possibly multiple times.

Ok, this is becoming kinda frustrating. I’ve woken up the thermostats like 25 times and the option is still not listed. I have ordered the Aotec stick, since it was recommended by a friend, and will try it with this one again when it’ll arrive (probably Wednesday).

If this doesn’t work as well I will return the Technisat devices and buy some proven ones.

Your controller is one that is designed for the Z/IP system so it won’t work with OH at the moment.

Aeotec stick arrived. Devices are now properly identified. Thank you all.

Ok, that’s a shame. Can you provide an updated log please so I can see what’s happening now. Your old controller was definitely an issue and I’d hoped it would be solved by using the Aotec :frowning: .

Whoops, sorry. Please see my edited post. They are now properly identified.

1 Like

:laughing: thanks.

Could you give further info on that? How are the chances to include the other stick into openHAB for futur users?

Z/IP requires a major rewrite of the binding to support. It’s likely required soon, but it will be a lot of work. ZWA have stated that all future systems must use their ZIP layer which is another piece of software that sits between the stick and the application. It’s problematic not only as it requires a major rewrite to all existing ZWave software, but also as it then needs this middleware layer to be added which is a problem for OH as it becomes hardware dependant.

1 Like