[SOLVED] Broken Google Assistant?


it’s a couple of days that Google Assistant give error on smart home command related to openhab.

It was working fine since months.

myopenhab portal indicates home server as online, and opening basicUI from there is working perfectly.

OpenHAB app on the phone with remote server is working properly as well.

The only broken service is Google Home Assistant integration.

I’ve already rebooted the home server (Rpi3) with no success.

Then I’ve un-linked openhab from Google Assitant smart devices and tried to link it again.

Here comes the strange thing: I cannot link it again. Google Assistant redirects correctly to openhab login, then to the page where OAuth2 needs confirmation, print “account linked” on the screen but suddenly appears a generic error on Google Assistant.

Final result is that OpenHAB is not linked at all. If I try again same result.

Anyone had the same issue?

Is maybe something temporary?



I was looking for exactly about this now, I also unlink my account with google and now I can not link it anymore. I also performed the same procedures with my RP3 and my .items files and I had no success, let’s wait and see if we have any problems with google.

I’m having the exact same issue!

Everything was working fine, until on today’s google logs I got the following message:


Sorry I cound’t reach openHAB

Anyone else having similar issues

Runing openhabian 2.3 up to date and working until this morning

I have since unlinked and attempted to relink the account but am running into the following message from the google home app:

Couldn’t update the setting. Check your connection

I’m seconds away from grabbing my backup image and tossing it online to see if that’s the fix, but since kvgeta is having a similar issue, is it service based?

Had the same issue this evening. Not at home so don’t know if it is still continuing

Same issue here. Assistant says that Openhab box is not available.
Works fine with Alexa.

Same issue for me. I tried remove the connection and re-add it. It doesn´t work.

See Official Google Assistant Integration for openHAB

Just checked.

I was able to link again the OpenHAB with Google Assistant.

Everything works perfect!

Thank you!