[SOLVED] Can NOT Get Alexa Working on OH2 (Down to last hair to be pulled out of head!)

I am offically down to my last hair to be pulled out! I have been a 1.x user for a while and did a fresh install on a new Raspberry Pi (OpenHabian) recently. My house only has about 7 Zwave switches, 4 Hue’s, 2 Nests and a few other items so starting over was the easiest path for me.

I have OH2 running and everything seems to work from the web (started with a limited number of items to keep simple)

  • I setup Myopenhab Servce
  • Added the Private and UUID
  • I added OpenHab in Alexa App (Android) and signed in
  • When I scan for devices with Alexa all I see are the HUE items
  • I removed ALL itelms except ONE to see if Alexa can see that - NOPE!
  • I have tagged it “Lighting”

Here is the ONE item:

Dimmer KitchenIsland "Island" <light> ["Lighting"] {channel="zwave:device:15a5de49c6a:node5:switch_dimmer" }

When I log into Myopenhab It shows ONLINE and I see “KitchenIsland” under Items and all changes in event log so thats working.

I removed and reinstalled the Alexa App and still NOTHING found other than HUE lights after discovery…



What if you try the tag at the end after your binding info?

Double check if you have the Alexa Application authorized in your myopenhab.org Accounts/Application section:

YES it is - triple checked…

Remove the Channel (never could get it work) from your definition. Use HABMIN to link the item to the Thing’s channel. I have posted about this before, I’ll go look for my examples.

I have tried it as simple as this

Dimmer KitchenIsland "Island" ["Lighting"] {channel="zwave:device:15a5de49c6a:node5:switch_dimmer" }


Dimmer KitchenIsland "Island" {channel="zwave:device:15a5de49c6a:node5:switch_dimmer"} [ "Lighting" ]

When I do it this order I lose the “TAG = LIGHTING” in the ITEMS details so I reverted back

Thanks - Will try that in a few minutes!


  1. I have pulled power on Hue
  2. I disabled NEST
  3. I Have “Forgotten” ALL devices / Groups on Alexa (NOTHING in there now)
  4. I have changed my ITEMS file to this ONE line:
Dimmer KitchenIsland "Island" [ "Lighting" ] {zwave="5:command=switch_dimmer"}

Not sure if that is correct and I wasnt sure how to link per your recommendation:

Use HABMIN to link the item to the Thing’s channel.

EDIT: I think I got this part, the linking : In THINGS - under Channel “Brightness” I chose LINK and the ITEM. That seemed to work but still NOTHING in Alexa Scan
(I removed the ITEMS file altogether since I am using the GUI

Now Alexa SHOWS No Items and when I scan it again shows NO items… ugh!!

Remove the channel definition from your item. Get rid of everything in the curley braces. Define your item as such.

Dimmer KitchenIsland "Island" [ "Lighting" ]

Then go into HABMIN and link that ITEM to the Zwave 5 Thing.

In HABMIN, expand Configuration, and click on Things. Highlight your ZWave 5 Thing in the middle pane. On the right scroll down to Channels and click on it. then use the top left blue icon to link the KitchenIsland item you defined in text to the Switch Channel.

Now tell Alexa to Discover my Devices.

Thanks for that - did EXACTLY as you mentioned (perfect point by piont) but still NOTHING shows in Alexa

Since this is THE main feature I want I am thinking about doing a complete wipe and reinstall of OH2. Do you think that is a bad idea at this point? I don’t really have anything configured, its just not working in the most basic sense so I am running out of ideas fast and I don’t want to waster everyone’s time! :rage:

What do you mean nothing “shows” in Alexa? After Alexa does the discover process, it should announce how many devices it discovered. Did you get any devices found? Did you turn on the Enable Device Pairing in Paper UI in the Hue Bridge config? Configuration -> Services -> Hue Emulation (Configure)?

Once I removed the NEST and powered down my Hue Hub I have NO DEVICES discovered (Prior to that I use to get my 2 NEST and 6 Hue Bulbs)

To be clear - I thought Hue Emulation was NOT required anymore since Alexa was supoprted directly - is this wrong??? Is this what I am missing? I did NOT see anything about Hue Emulation on the instructions for setting up the new Alexa native skill

Oh, sorry, I made an assumption that you were using the Hue Bridge. I don’t have Alexa running with the Skill. Well, I do have the custom skill method working. Make sure you’re in the right profile. My wife and each have Amazon profiles. You may have the same. Tell Alexa to switch profiles if you have added the Skill in one or the other.

Ahhh OK soory I assumed the Hue Emulation was depreciated since this officla skill came about.

I dont think I have any profiles setup but I will definitely check that out. I added NEST and HUE in Alexa and its discovered everything perfectly - I added OpenHab, logged in and I see it in my Alexa app as enabled and as Authoirzed app in MyOpenHab so I ASSUME all is good there.

I see many people working perfectly right out of the box, so SOMETHING must be blocking it - Im going to turn on router logs as my last hope (maybe router blocking something) but otherwise I think a new install might be in order.


Did a fresh reinstall and worked out of the box - :fearful:

OH WELL - 10 days of my life I will never get backl … Can only look forward … On to bigger and better now with my OH2!



For all who did not find any device with Alexa (via Official Alexa Smart Home Skill), I have maybe a solution! See here: Link

Hope this helps!

Edit: updated new information! (21 July)