[Solved] Cannot connect to OpenHAB dashboard on local network

Tags: #<Tag:0x00007fc8fa859560>

I upgraded my OpenHAB to v2.5.0-1 (Release Build) yesterday night and now am unable to connect to OpenHAB dashboard when am on my local network. Although i can connect to it remotely through https://www.myopenhab.org/ (Android app connects to remote properly even though am on local) and also through reverse proxy setup.

None of the devices in home can access the OpenHAB dashboard when trying to access locally. Is there something to do with subnetmask ? FYI, the IP of my Raspberry pie is same as before and it did not change. It seems to be very weird that remote connections work but not the local connections.

If in case, below is my ngnix config file.

Logs:

Let’s do this properly…

Welcome to the openHAB Community :heart:

Now we can start with your problem :stuck_out_tongue:

In the future consider providing as many logs about your system as possible.
openHAB.log yada yada

This would indicate to me that openHAB is indeed running and working, if you can control everything via. myopenHAB.
This would also indicate that the web-server did not start or work correctly.

So please provide some logs :slight_smile:

Hi @BrutalBirdie , i have updated the post with google drive link for the logs. As i cant attach the files here presently.
Thanks.

Thanks I am going threw it, I will edit this post with my findings.

First

2019-12-20 00:42:09.656 [ERROR] [ui.internal.items.ItemUIRegistryImpl] - transformation throws exception [transformation=org.eclipse.smarthome.transform.map.internal.MapTransformationService@1c1227b, value=NIGHT]
org.eclipse.smarthome.core.transform.TransformationException: An error occurred while opening file.

Caused by: java.io.FileNotFoundException: /etc/openhab2/transform/astro.map (No such file or directory)

File /etc/openhab2/transform/astro.map seems missing.
This error is spamming quite a lot.

PS: Looks like you are ahead of my time :smiley:

I think this is a point where you restarted openHAB, right?

2019-12-20 12:04:55.911 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI
2019-12-20 12:05:02.671 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2019-12-20 12:05:02.708 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = , base URL = http://localhost:8080)
2019-12-20 12:05:02.948 [INFO ] [assic.internal.servlet.WebAppServlet] - Stopped Classic UI
2019-12-20 12:05:02.976 [INFO ] [b.core.service.AbstractActiveService] - Expire Refresh Service has been shut down
2019-12-20 12:05:03.013 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Stopped HABmin servlet
2019-12-20 12:05:04.086 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Stopped Paper UI
2019-12-20 12:05:04.134 [INFO ] [panel.internal.HABPanelDashboardTile] - Stopped HABPanel
2019-12-20 12:05:04.215 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard
2019-12-20 12:05:50.192 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2019-12-20 12:05:50.303 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to 'Asia/Kolkata'.
2019-12-20 12:05:50.317 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to '17.4154514,78.5848738'.
2019-12-20 12:05:50.324 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to 'en_IN'.
2019-12-20 12:05:54.318 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = , base URL = http://localhost:8080)
2019-12-20 12:06:00.409 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'basic.items'
2019-12-20 12:06:00.715 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'astro.items'
2019-12-20 12:06:04.741 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2019-12-20 12:06:05.402 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'default.sitemap'
2019-12-20 12:06:05.944 [INFO ] [el.core.internal.ModelRepositoryImpl] - Validation issues found in configuration model 'basic.things', using it anyway:
Provide a thing type ID and a thing ID in this format:
 <thingTypeId> <thingId>
Provide a thing type ID and a thing ID in this format:
 <thingTypeId> <thingId>
Provide a thing type ID and a thing ID in this format:
 <thingTypeId> <thingId>
Provide a thing type ID and a thing ID in this format:
 <thingTypeId> <thingId>

Your basic.things file has erros.

019-12-20 12:06:05.957 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'basic.things'
2019-12-20 12:06:06.229 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'astro.things'
2019-12-20 12:06:07.369 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:sun:local
2019-12-20 12:06:07.519 [INFO ] [thome.binding.astro.internal.job.Job] - Scheduled Astro event-jobs for thing astro:moon:local
2019-12-20 12:06:07.541 [INFO ] [ding.astro.handler.AstroThingHandler] - Scheduled Positional job astro:moon:local every 300 seconds
2019-12-20 12:06:07.647 [WARN ] [mon.registry.AbstractManagedProvider] - Could not update element with key astro:sun:local in ManagedThingProvider, because it does not exists.
2019-12-20 12:06:07.651 [WARN ] [mon.registry.AbstractManagedProvider] - Could not update element with key astro:moon:local in ManagedThingProvider, because it does not exists.
2019-12-20 12:06:08.493 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at http://192.168.31.53:8080
2019-12-20 12:06:08.498 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at https://192.168.31.53:8443
2019-12-20 12:06:09.851 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2019-12-20 12:06:09.986 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2019-12-20 12:06:10.343 [WARN ] [ore.common.registry.AbstractRegistry] - Cannot add "BridgeImpl" with key "mqtt:systemBroker:embedded-mqtt-broker". It exists already from provider "ManagedThingProvider"! Failed to add a second with the same UID from provider "GenericThingProvider"!
2019-12-20 12:06:11.352 [WARN ] [r.internal.EmbeddedBrokerServiceImpl] - Embedded broker offline - Reason unknown
2019-12-20 12:06:11.504 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to '127.0.0.1' with clientid embedded-mqtt-broker and file store '/var/lib/openhab2/mqtt/127.0.0.1'
2019-12-20 12:06:11.599 [ERROR] [el.item.internal.GenericItemProvider] - Binding configuration of type 'expire' of item 'Livingroom_TV_Power' could not be parsed correctly.
org.eclipse.smarthome.model.item.BindingConfigParseException: The string '0' does not represent a valid state for item Livingroom_TV_Power
2019-12-20 12:06:08.493 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at http://192.168.31.53:8080
2019-12-20 12:06:08.498 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at https://192.168.31.53:8443
2019-12-20 12:06:09.851 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2019-12-20 12:06:09.986 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin

Web Server started.

2019-12-20 12:06:10.343 [WARN ] [ore.common.registry.AbstractRegistry] - Cannot add "BridgeImpl" with key "mqtt:systemBroker:embedded-mqtt-broker". It exists already from provider "ManagedThingProvider"! Failed to add a second with the same UID from provider "GenericThingProvider"!
2019-12-20 12:06:11.352 [WARN ] [r.internal.EmbeddedBrokerServiceImpl] - Embedded broker offline - Reason unknown

This seems off, do you use an external mqtt broker and an embedded one? :thinking:

2019-12-20 12:06:11.504 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to '127.0.0.1' with clientid embedded-mqtt-broker and file store '/var/lib/openhab2/mqtt/127.0.0.1'
2019-12-20 12:06:11.599 [ERROR] [el.item.internal.GenericItemProvider] - Binding configuration of type 'expire' of item 'Livingroom_TV_Power' could not be parsed correctly.
org.eclipse.smarthome.model.item.BindingConfigParseException: The string '0' does not represent a valid state for item Livingroom_TV_Power

Wrong state, you should investigate this.

TL;DR

You openHAB is starting and stopping quite a lot. (¿Bootloop?)
I would advice looking into the errors.
Did you try clearing the cache?

1 Like

Bad addon entries cause the addons to reload every minute. A common culprit is restdocs.

@BrutalBirdie, I rectified the issues and errors you pointed out from logs. Now i don’t have those nasty errors / warnings all over :smiley: Good that i have learned new things in the process of rectifying them.
I have only one MQTT broker which is embedded broker. I even uninstalled and reinstalled all add-ons. I followed the “Clear the cache” technique using openhab-cli and still have the issue.
BTW, openHAB is not rebooting itself. I made it to reboot few times to see if the issue resolved. :smiley:

I still see the below error in log even though i installed the Rest API docs from Paper UI manually, And this error message occurs at frequent intervals in logs. Don’t know if it has to do something with my actual problem.

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-restdocs’

@Bruce_Osborne, do you mean manual entries ? I don’t do any manual entries. I got the addons installed from PaperUI only. But as you said is it a problem due to restdocs ? see my #6 post.

The restdocs moved. The addons,cfg and addons.config files store PaperUI installed addons too. You will see restdocs listed undermisc. As stated in the Release Notes, it got moved to ui.

The addons loader is reloading all addons once a minute, trying to load the invalid item.

Ok that makes sence.
I had a config initialization error when upgrading… so ill go have to crunch some docs later on to see what changed. Thanks for that info.

When I upgraded my main system from M5 there was an Ephemeris error on first startup and my config files did not load properly.
Restarting OH resolved the issues.

Huh since the update my internal proxy cant load the 127.0.0.1 address anymore .

This is what i use in apache

ProxyPass / http://127.0.0.1:8080/
ProxyPassReverse / http://127.0.0.1:8080/
RequestHeader set X-Forwarded-Proto “https” env=HTTPS

AuthType Basic
AuthName “OpenHab2 Restricted”
AuthUserFile /etc/apache2/.htpasswd
Require valid-user

I doesn’t look to be apache related seeing my grafana still works with this proxtforw.

Any ideas what changed to influence this? Its hard to pinpoint in the logs.

My nginx reverse proxy works fine.
What OH version did you upgrade from?

EDIT: Release Notes are here.

Release openHAB 2.5.0 · openhab/openhab-distro · GitHub

@Bruce_Osborne, i upgraded from 2.4, It was never an issue on v2.4

@devops-unitsu thank god i got some one who has same issue :D. Have been scratching my head from morning. But still could not find a solution to it. Don’t know how i was able access everything when i type in my static ip address from external network or mobile operator network. But local access don’t work :frowning:

Same upgraded from 2.4 to 2.5 and it broke… It now point to 127.0.0.1 in the web browser instead of locking onto the domain name. No error logs in Apache or openhab…
Because the error is that it doesn’t stay locked inside the proxy so it just that i get my browser looking on my local 127.0.0… address…

ngnix test command was giving me a warning about “lower address bits are meaningless” so i changed From
allow 192.168.31.1/24

To
allow 192.168.31.0/24

and restarted the ngnix. Warning disappeared but still problem persists. Just thinking if i need to completely remove ngnix and check.

Damn, I just rebooted my router and everything started working normally. Now I can access locally and externally too. why didn’t I do this before :worried:

Generic internet provider…

“Did you try to restart the router?”

Well :smiley: it’s good that it’s working now