[SOLVED] Chart generation failed: null

I have OH installed on Synology. Previous version (2.1) was ok, but today I upgraded to 2.2. I was able to install all the bindings etc., but I can not see the graphs. Any of them. It was fine on 2.1 version.

[WARN ] [thome.ui.internal.chart.ChartServlet] - Chart generation failed: null

I’ve checked the permissions on conf/html and is 777.

Persistence: mysql.
I can see the data in the database, so the connection to db works.

Number P_e2 “Hladilnik [%.1f mA]” (tok) { knx=“9.021:1/3/2” }

Text item=P_e2 {
Frame {
Text item=P_e2
Switch item=P_e_Chart_Period label=“Obdobje grafa” mappings=[0=“Ura”, 1=“Dan”, 2=“Teden”, 3=“Mesec”]
Chart item=P_e2 period=h refresh=600 visibility=[P_e_Chart_Period==0, P_e_Chart_Period==“NULL”]
Chart item=P_e2 period=D refresh=3600 visibility=[P_e_Chart_Period==1]
Chart item=P_e2 period=W refresh=3600 visibility=[P_e_Chart_Period==2]
Chart item=P_e2 period=M refresh=3600 visibility=[P_e_Chart_Period==3]

What am I missing?

default persistence is set?

Thank you for your reply.

Yes, default persistence is set to mysql.
Even if I add service=“mysql” to the Chart… line, it’s the same result.

Typ with

Chart item=P_e2 period=h refresh=600 visibility=[P_e_Chart_Period==0, P_e_Chart_Period==null]

Is item P_e_Chart_Period the typ Number?


Number P_e_Chart_Period “Obdobje grafa”

Same error even without quotes and/or allcaps

Then I don’t think it’s a problem with item and sitemap but rather with the database.

1 Like

I have droped all the tables from OpenHab database. It gets filled automatically afterwards, so I guess INPUT works.

Did you restart openHAB yet?

Many times

I have exactly the same problem. Any help would be appreciated! (Also on an Synology btw)

@Kees_Schouten Can you tell me which version of OpenHab and Java are you using? I can’t confirm it yet, but I think this started when I’ve updated Java - my older version of OpenHab doesn’t work as well now.


Java version : 1.8.0-151
OpenHab version :

Update! It works I’ve update my java to:

Version: 1.8.0_162

To check your java version on synology:

Package manager -> search for “java” -> click on “Open” -> see dialog with version.
At first it didn’t worked but when I restarted my synology server it suddenly worked!

I had the same java version, but openHAB v2.2. Didn’t wan’t to install the pre-release version.

Well, I’ve first updated openHAB to 2.3 and it still didn’t work, but after an upgrade of Java from 151 to 161 - SUCCESS!

So, thank you for your help!

Hello all,

I had the same issue with graphs not showing on an OpenHAB installation on a Synology NAS with the error message in openhab.log “Chart generation failed: null”.

Thanks to this post, I updated my java version (which was 1.8.0-151 before and is 1.8.0-171 now),
and after a restart of the OpenHAB package, it works fine now. :smiley:

Thanks for this!

Kind Regards,

One year later, same issue?
I have a DS918+ where I run OpenHAB in a docker container just fine.

Now I also want to run OpenHAB on another location where I have a DS214+ which doesn’t support docker and therefore I have installed the synology package.

I copied config files from DS918 to DS214 (and adapted where necessary) and while it’s basically working with the synology package I do not get Charts rendered in the Basic UI.

Since this is a year later, java version is now at 1.8.0_212 already.

Is there a way to debug this on the diskstation?

What persistence service are you using?
What do the logs show when you try to render a chart?


2019-09-04 10:46:31.689 [WARN ] [thome.ui.internal.chart.ChartServlet] - Chart generation failed: null

If your rrd4j database holds data (you can check that using the REST API) it could be the Problem reported here.