[SOLVED] Danalock V3 - Z-Wave

not sure if I understood the video well, but it is about the app they decompiled?!

is the same app used on v2 and v3 or are there different ones?

If you are really want to know more - you may want to read the slides:

In sum : everything is hackable - but from a point of view of a lockpicker - it is “overkill” to go the technical way and not just to use a drilling machine.
just my 2 cents…

1 Like

ok. did found some time today.
did install the october-version - installed it via bundle:… started a scan - but
[WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

But: i did execute a firmware update on the lock. maybe this is the issue know?

openhab> bundle:list | grep ZWave                                                                                                                                                              
15:48:03 229 │ Active   │  80 │     │ ZWave Binding

I will try later with some more details…

oh, I hate that 7FFFFFF message … was fighting w it few nights :smiley:
in my case the problem was:
using wrong binding (not the 10-24 dev version from Chris link;
and not discovering/including device through HABmin interface (e.g. in case if including to the controller externally and then adding controller to raspberry would not work due to security staff).

(and I also have latest fw on the lock … well, the version that was available 17d ago )

I´m a FHEM user - new to OpenHab 2 AND Z-Wave.
I installed Obenhabian and Z-Wave Me Stick. Found Thing “Danalock” but status is “unknown”.
What do I have to update where to get it connected working?

When will the lock find its way to the official OpenHAB2 Version? I don´t want to spend my time debugging nightlies oder special dev versions, as this is an integral part of my families smart home. Not meant to be rude, btw!


Nico, first thing - make sure you are using this Z-Wave binding:

This was my recipe for getting it working
Download the jar from very first post, first line: “The latest version of the test binding … is here”.
Exclude the existing Danalock from the stick.
Uninstall existing ZWave binding.
Copy over this jar to your usr/share/openhab2/addons directory
restart openhab (just to keep things clean)
Start discovery of the Lock from HABmin interface (not from the stick) - by clicking
When Danalock thing discovered- add the thing. Assign item to channel, live with it :slight_smile:
fingers crossed!:slight_smile:

Perfect info. Will try and report back.

Looks promising - in case somebody else needs the info here is how it seems to work:

  1. Delete all Zwave Things from Habmin.
  2. Uninstall the Zwave binding from Habmin. - You will NOT reinstall it.
  3. Stop OH2
  4. Copy the JAR file to your /usr/share/openhab2/addons folder.
  5. Start OH2.
  6. log into Karaf ie… ssh openhab@localhost -p 8101 password is habopen
  7. Start the zwave binding with: bundle:start org.openhab.binding.zwave
  8. If get an error, you need to install the serial binding first: feature:install openhab-transport-serial
  9. Now got back to Habmin, and Readd a Zwave Controller. Do NOT re-install the 2.0 Zwave Binding.
  10. Set your USB port and rescan for devices.

I got my danalock v3 working thanks to this post.
One note is that I had to exclude and include all my zwave devices to make it to work after the new zwave binding.

Yes - you need to use the version from the other thread.

Not really - you need to start the binding. You might be lucky and just be able to drop it into the addons folder and it might start, but equally, the commands should be available in the Karaf console…

Probably after Christmas - it needs to be done after the 2.2 release as it is a breaking change, and I will be on holiday for a while until Christmas…

Hi all,
i finaly managed to find some time; With the how to from Nico (thanks btw) i was at least able to find the lock. But - my fibaro and my danalock shows as ‘Unknown Device’ or as 'The device initialisation is not complete.'
Any suggestions (i am actually using 2.1 stable)?


If anyone feels like updating the docs on GH to improve information on this, please feel free :slight_smile: .

Thank you sir! I got my DanaLock v3 included to my Razberry2 z-wave module!

I might be wrong but from what ive read during last hours of googling for clues on how to get the Z-wave test binding to work is that it won’t work without performing this manual inclusion ( feature:install openhab-transport-serial ) in the Openhab-console (karaf).
Btw. This is only necessary for bindings running from the shared addons folder and not for UI installed bindings!

I’ve talked with the German Danalock support: The issue with the open password has been solved and they recommend to use the new app “Danalock Deutschland” (so called in Germany) or “Danalock Premium” (so called in other european countries). The security of the V3 model has been improved as well (e.g. it uses a higher encryption). So the results of this Def Con presentation don’t refer to the Danalock V3 and the current app versions.

1 Like

I’ve updated my snapshot openhab to the latest snapshot, but when adding Danalock V3-BTZE I’ve got this in the logs. Do I need to remove all Z-Wave devices including the controller?

As it’s #1221 it should have the security layer included, but maybe some specific steps, not covered in updating docs, are required.

15:33:44.537 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: setupNetworkKey useSchemeZero=false
15:33:44.582 [WARN ] [otocol.commandclass.ZWaveCommandClass] - NODE 17: Unsupported command class COMMAND_CLASS_SECURITY_2
15:33:44.583 [WARN ] [otocol.commandclass.ZWaveCommandClass] - NODE 17: Unsupported command class COMMAND_CLASS_TRANSPORT_SERVICE
15:33:44.589 [INFO ] [ig.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:099cd287:node17' to inbox.
15:33:44.589 [INFO ] [smarthome.event.InboxAddedEvent      ] - Discovery Resultwith UID 'zwave:device:099cd287:node17' has been added.
15:33:44.591 [INFO ] [smarthome.event.BindingEvent         ] - org.openhab.binding.zwave.event.BindingEvent@153c1bc
15:33:44.591 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: setupNetworkKey useSchemeZero=true
15:33:44.593 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
15:33:44.595 [WARN ] [erialmessage.IdentifyNodeMessageClass] - Got IdentifyNodeMessage without request, ignoring. Last message was SendData.
15:33:56.658 [INFO ] [ecurityCommandClassWithInitialization] - NODE 17: SettingNetwork Key to real key after SECURITY_NETWORK_KEY_SET
15:33:56.659 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 17: setupNetworkKey useSchemeZero=false
15:34:18.613 [INFO ] [smarthome.event.InboxRemovedEvent    ] - Discovery Resultwith UID 'zwave:device:099cd287:node17' has been removed.
15:34:18.625 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:099cd287:node17' changed from UNINITIALIZED to INITIALIZING
15:34:18.626 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:099cd287:node17' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controlleris offline
15:34:18.628 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:099cd287:node17' changed from OFFLINE (BRIDGE_OFFLINE):Controller is offline to ONLINE
15:34:18.633 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:099cd287:node17' has been updated.
15:34:18.634 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:099cd287:node17' has been updated.

It looks like you’re using the master branch which doesn’t support security - please try the development version -:

Thanks for the swift reply. So the version with security isn’t still even in the snapshot version?

Yes - you need to use the version referenced above at this time.

I was able to get it working. But I had to make some minor changes because of a number of Z-Wave items in my installation to reduce manual work. It’s also a bit detailed. It’s Windows installation.

  1. Screenshot all Z-Wave items with corresponding Node numbers
  2. Delete all Zwave Things using PaperUI (PaperUI preserves items under the deleted thing)
  3. Uninstall the Zwave binding using an OH2 shell with bundle:list getting the number of the Z-Wave bundle, then bundle:stop NUMBER and finally bundle:uninstall NUMBER. I’ve must do this because HABmin nor PaperUI didn’t uninstall it after clicking on uninstall.
  4. Stop OH2
  5. Check if the z-wave bundle isn’t listed in addons.cfg to be installed after start
  6. Copy the JAR file to /openhab2/addons folder.
  7. Start OH2.
  8. The binding was automatically installed
  9. Check if right version of Z-Wave is installed via shell command bundle:list I’m running snapshot 2.2. and z-wave was 2.3. If you have snapshot 2.3 I have no idea how to check the right version.
  10. Open PaperUI and search for new things, add them - PaperUI conveniently asks for Thing name before adding it
  11. When you preserved exact naming of things, the channels will be connected automatically
  12. When you’re done you can go to HABmin, go to things, you should see your z-wave devices adding and configuring it, it but it took some time and looked like errors
  13. If you had the lock added before you need to exclude it from the Z-Wave network
  14. Then you need to do inclusion within HABmin only
  15. Start Z-Wave inclusion by pressing the button with Magnifier and +
  16. Press the button once on Danalock V3
  17. The HABmin should found the lock
  18. Add it. As it’s battery powered it can take some time to recognize it