[SOLVED] Empty charts & wrong time in request log

Hi there,

I have some issues with my charts which are empty at the beginning and need about half a day to show anything. Looking into the request logs I discovered that the time is of by 12h compared to the openhab.log file.
Date has the correct time and date in the mysql data base. I suspect that the GET method is querying the wrong time and so the charts are empty at first.

<ip>:8080/chart?items=HumidLR&period=h&service=mysql

request.log:

[20/Sep/2015:10:44:45 +0000] "GET /chart?items=HeatPump&period=h HTTP/1.1" 200 6753 

openhab.log

22:58:00.531 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS

Date and time are correct on my pi

$ date
Sun Sep 20 23:03:10 NZST 2015

Oh boy. Turns out my clock from my pi was messed up. UTC was a day ahead of my NZ timezone which messed up everything.
Fixed it by shutting down /etc/init.d/ntp stop, then setting the time with raspi-config and then resetting the clock with date -s “3 Sep 2015 20:14:00”
Restarted /etc/init.d/ntp start and everything was good and I got data straight to my charts.

1 Like