[SOLVED] Error message "dhcpd.service: control process exited, code=exited status 6"

  • RaspberryPi3B+
  • openHABian v1.4.1
  • error message “failed to start dhcpd on all interfaces”

I installed openhabian on the raspberrypi. I installed with ethernet. Then I switched over to wlan with the openhabian-config. When rebooting I saw the message “failed to start dhcpd on all interfaces; See systemctl status dhcpcd.service for details”.

When using the command “systemctl status dhcpcd.service” I get the message “dhcpd.service: control process exited, code=exited status 6”

The wifi connections works so far. For setting up the wifi, I just used openhabian-config. What does the error message mean and how do I get rid of it?

Try cleaning the cache and rebooting.

sudo systemctl stop openhab

sudo openhab-cli clean-cache

sudo reboot

1 Like

when I type in
sudo systemctl stop openhab
it says
Failed to stop openhab.service: Unit openhab.service not loaded.

Is the command correct?

sudo systemctl stop openhab2

Forgot the 2 on the end of openhab.:upside_down_face:

1 Like

Have done the commands and rebooted. But exactly the same error message. What can I do now?

Same thing I am, search the forum and github for an issue b/c I’m not sure why your having this issue.

If nothing else can be found I’ll start up my test server (RPI also) and see if I can replicate the issue.

@VioletAnt did you try :

sudo service dnsmasq restart

It says
Failed to restart dnsmasq.service: Unit dnsmasq.service not found

Looking at the Rasp forums you may need to configure the country code in wpa_supplicant.conf. I think you can also so that in the openhabian-config tool but not 100% sure.

EDIT: In System setting, where you setup wifi with the config tool, set the location and time also.

Per the doc’s:

Wi-Fi based Setup Notes

If you own a RPi3, a RPi0W, a Pine A64, or a compatible Wi-Fi dongle you can set up and use openHABian purely via Wi-Fi. For the setup on Wi-Fi, you’ll need to make your SSID and password known to the system before the first boot. Additionally to the setup instructions given above, the following steps are needed:

Flash the system image to your micro SD card as described, do not remove the SD card yet
Access the first SD card partition from the file explorer of your choice (e.g. Windows file explorer)
Open the file openhabian.conf in a text editor
Uncomment and fill in wifi_ssid="My Wi-Fi SSID" and wifi_psk="password123"
Save, Unmount, Insert, Boot

The documentation may be outdated as it’s odd to have the wifi option in the config tool so I’ll keep searching.

I didnt install with wifi in the first place, because after I prepared the config files on microsd card for wifi installation (like you quoted the documentation before), I got some error because it couldn’t establish a wifi connection. I have some special characters in my wifi password, so I was thinking that is the reason. After installing sucessfully over ethernet I used the configuration tool to change to wifi (correct timezone and also correct location, although I didnt change the system locales). Wifi works. But somehow I get this error message. I am still not sure what that error means actually.

Ah, you just want to use the wifi, not the wifi as a router, so you can ignore the error.:wink:

Ok. Can you explain me so that I understand it, what this error is and in which cases I will have problems because of it? :wink:

Other than the error message about dhcpd, is everything else working as expected?

I am just starting, so far I installed Mqtt and InfluxDB+Grafana. But didnt use anything of it so far.
Ok just now I disabled the wifi by removing password and SSID and still get the error message.So it seems the error is not dependend on the wifi device, but comes also when using only ethernet?

I think you will need to disable it via the config tool but do you plan to use the Wi-Fi or Ethernet connection?

See this link as I’m not the best when it comes to explaining things.:smile:


Yes disabled it over config tool. But same problem. I plan to use Wifi.

See the link posted above.:wink:

For future use, if needed:

To disable WiFi and/or Bluetooth on the Pi 3, add the following two lines to the end of the ‘/boot/config.txt’ file:


then use command:

sudo systemctl disable hciuart

and reboot.

Also you can find details in the ‘/boot/overlays/README’ file.

1 Like

I just formatted/erased the sdcard/system, and tried to install it with wifi. I put in the boot config file the ssid and the password (I changed in my router the password to a password without special characters, I have a fritzbox7430 with wpa+wp2 enabled). Also I set the locase in the boot config file.

When trying to install openhabian with wifi I get the follwoing error message:

**Starting the openHabian initial setup.
  Storing configuration... OK
  Changing default username and password.... SKIPPED
  Setting up Wi-Fi connection... OK
  Ensuring network connectivity... FAILED

  I was not able to connect to the configured Wi-Fi.
  Please try again with your correct SSID and password. Also check your signal quality.           
  Available Wi-Fi networks:
  wlan0     Interface doesn't support scanning: Network is down

  Initial setup exiting with an error!**

So what is going on here. Why can’t it connect to the network? The router is 3 meters away of the raspberryPi. I already changed SSID and password. Any ideas?