[SOLVED] Example to get motion data from Fibaro FGMS-001 (version 3.2)

Dear all,

I just got the device and included it in openHAB 2.4 M7. Using “Simple Mode”, the system created the things and items, and I see temperature and battery status in PaperUI. However, there seems to be no reaction for motions: The sensor does its nice green blinking when it detects a motion in front of the sensor, but the display in the PaperUI does not change.

I am also a bit helpless which type of item has to be assigned to which channel to get a proper reading. I am also confused by the sheer number of channels that seem to be related to motion (binary_sensor, motion_alarm, general_alarm…) and I am not shure which would give me the information. One of them should do something like switching from OFF to ON for like 30 seconds once there is a motion in front of the sensor, right?

So could please someone who got the device working post some code for the item definiton, maybe to see a switch or variable changing in BasicUI or so?

Note, I simply added the thing in PaperUI. In case I have to work on the thing definition manually (as it seemed to be necessary in the past, as I learned in the forum), please let me know.

Thanks a lot,
Tobias

https://www.openhab.org/addons/bindings/zwave/thing.html?manufacturer=fibaro&file=fgms001_3_2.html

The alarm_motion channel should work with an itemtype Switch.

That can be adjusted by using the configuration parameters.

As you are using Simple Mode this is not necessary, you don’t have any flat text files.

Bad idea for zwave, it is a lot easier to use the autodiscovery function.

If you view the Thing in Paper UI, you will see the the Item type supported by the Channels. From there, you can also copy the Channel config to use in an Items file.

This is what I did yesterday. However, in PaperUI in the “Control” section, nothing changed on motion detections…

Put all available channels (see link above) in different items and check which one responds. Also you can watch your events.log to find out which one responds.

I checked the log file and filtered for “zwave”. Some of the lines I found:

2018-12-10 06:59:26.412 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_sensor_binary-zwave:device:512:node2:sensor_binary' has been added.
2018-12-10 06:59:26.422 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_sensor_temperature-zwave:device:512:node2:sensor_temperature' has been added.
2018-12-10 06:59:26.434 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_sensor_seismicintensity-zwave:device:512:node2:sensor_seismicintensity' has been added.
2018-12-10 06:59:26.447 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_sensor_luminance-zwave:device:512:node2:sensor_luminance' has been added.
2018-12-10 06:59:26.453 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_alarm_motion-zwave:device:512:node2:alarm_motion' has been added.
2018-12-10 06:59:26.457 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_alarm_tamper-zwave:device:512:node2:alarm_tamper' has been added.
2018-12-10 06:59:26.462 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_battery_level-zwave:device:512:node2:battery-level' has been added.
2018-12-10 06:59:26.466 [.ItemChannelLinkAddedEvent] - Link 'zwave_device_512_node2_alarm_general-zwave:device:512:node2:alarm_general' has been added.
...
2018-12-10 08:59:49.053 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:512:node2' has been updated.
2018-12-10 08:59:49.092 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_binary changed from NULL to OFF
2018-12-10 08:59:49.145 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_temperature changed from NULL to 21 °C
2018-12-10 08:59:49.185 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_seismicintensity changed from NULL to 0
2018-12-10 08:59:49.232 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_luminance changed from NULL to 1
2018-12-10 08:59:49.281 [vent.ItemStateChangedEvent] - zwave_device_512_node2_battery_level changed from NULL to 100
2018-12-10 08:59:49.326 [vent.ItemStateChangedEvent] - zwave_device_512_node2_alarm_general changed from NULL to OFF
...
2018-12-10 11:00:20.746 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_temperature changed from 21 °C to 20.5 °C
2018-12-10 11:00:20.945 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_luminance changed from 1 to 15
...
2018-12-10 19:02:06.861 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:512:node2' has been updated.
2018-12-10 19:02:06.986 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_temperature changed from 20.6 °C to 20.7 °C
2018-12-10 19:02:07.068 [vent.ItemStateChangedEvent] - zwave_device_512_node2_sensor_luminance changed from 8 to 15
...
2018-12-10 21:02:34.002 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:512:node2' has been updated.

I find only temperature and luminance entries. Note, there were people moving in front of the sensor, and the sensor also signalled motion detection by its green blinking LED everytime someone passed by…

But there seems to be no transmission of the motion alarm.

Any hint?

Can you provide a debug log? From the events log above it looks like only the sensor alarm is being received, but it’s hard to tell only from this data.

I just post some debug output from tonight: I came home around 23:50h, switched on the light and moved in front of the motion sensor. Still, this does not change my item values.

Please check my attached log file…Debug Z-Wave Tonight.txt (73.0 KB)

Thanks!

This debug log is showing only the responses to the polls after the device wakes up.

I don’t see anything in the log that would suggest that the device is reporting motion. Are you sure the Lifeline association is set to your controller?

Here’s a portion of the log from the log viewer.

OK, so maybe we got a point: I have no idea what a lifeline association is. I discovered the device using PaperUI and I defined the items.

Switch Binary_Motion_Hallway "Bewegung Flur [%s]" <Door> (Hallway) { channel="zwave:device:512:node2:sensor_binary" }
//Number:Temperature Temperature_Hallway "Temperatur Flur [%s]" (Hallway) <Temperature> { channel="zwave:device:512:node2:sensor_temperature" }
Number Temperature_Hallway "Temperatur Flur [%s]"  <Temperature> (Hallway) { channel="zwave:device:512:node2:sensor_temperature" }
Number Seismic_Hallway "Erschütterung Flur [%s]"  <Humidity> (Hallway) { channel="zwave:device:512:node2:sensor_seismicintensity" }
Number Luminance_Hallway "Helligkeit Flur [%s]" (Hallway) { channel="zwave:device:512:node2:sensor_luminance" }
Switch Motion_Alarm_Hallway "Bewegungsalarm Flur [%s]" <Door> (Hallway)  { channel="zwave:device:512:node2:alarm_motion" }
Switch Tamper_Alarm_Hallway "Stoßalarm Flur [%s]" (Hallway) { channel="zwave:device:512:node2:alarm_tamper" }
Number Battery_Alarm_Hallway "Batterieladung Flur [%s]" (Hallway) { channel="zwave:device:512:node2:battery-level" }
Switch General_Alarm_Hallway "Alarm Flur [%s]" <Door> (Hallway) { channel="zwave:device:512:node2:alarm_general" }

Did I miss something?

Update:
I found something in the settings of the device. I found some “Association Groups”. Group 1, called “Lifeline”, was empty. There is a dropdown menu, and I found “Controller” and set this value.

I also set the other Assiciation Groups “Motion” - which was also empty - to “Controller”, but there was no change in behaviour…

Log file attached…Debug Z-Wave Morning.txt (53.7 KB)

Since this is a battery powered device, it will need to wakeup to be configured. You can do this manually. Logs while setting the association and wakeup would be helpful.

I meanwhile receive values. Indeed I had so set the association groups to “controller” and I had to wake up the device by pressing a button inside the sensor.

Still, I am missing the seismic sensor, but there is another thread on this. Thanks so far! :slight_smile:

Is there a chance to add the lifeline while adding item from inbox or to set it via .things file?

With the 2.4 release or 2.5 snapshot binding the lifeline association group should be set automatically to your controller. Otherwise HABmin is the preferred way to configure zwave devices.

I included with paper ui 2.5.0 build 20190123, no lifetime was set. Try to set in configuration (while wake up device) didn’t fit. Tried 5 times. Looks like bug in openhab 2.4.0 or in Zwave binding 2.5.0

Or maybe because of firmware 3.3 of motion sensor?

I ll install habmin then and try that way.

Sensor does support secure mode, but in configuration it is shown as non secure (secure no is the database entry in Zwave database)

It didn’t fit with habmin, maybe because I set all Device to secure and ind Database Motion is marked as secure No?

No, it’s just an informational flag.

No, this is covered through the database.

If you included this device securely and it was successful, it should show a green check mark in HABmin properties at “Security”.

There is a bug in HABmin where the association group is empty even if it is set correctly.

As you did not state what your actual problem is; what type of issue are you having? If you have an issue, what does your openhab.log tell you? Did you set the zwave binding to DEBUG to see in detail what is going on?

It’s shown green in habmin and PaperUI from first moment. But showing Secure no. I m not able to proof if yes or no is correct. In PaperUI and habmin showing Secure No could be from Database or state of device. I don’t know, which value is shows there. And in both I am not able to edit field secure.

Problem is: I don’t get any value of device. Alle Channels are null. No Alarm, no temperature, nothing. Device green, channels null. In Eventlog I’m not able to find any entry with this node, no ZWAVE errors in openhab.log.

And Controller says it’s a direct Neighbour, Field-Check at device shows Green: Good Connection

Very Strange

Okay, let’s go through the basic steps:

First, you need a green checkmark for the Thing:
grafik

Second, you need to see manufacturer id, thing type and device id in HABmin attributes:

If you did include the device securely, you should see a green checkmark at “Using security”. Note that you don’t HAVE to include this device securely! It is just an option.

Third, set your lifeline association group to your controller:
grafik
then hit save.
After that wake the device up (you need to push the button inside the device housing), wait a minute, wake it up again. You need to do this until the pending mark disappears.

Now don’t touch anything for a while. The FGMS is a battery operated device and sleeps most of the time. It will send its values only occasionally (this can be changed in the device configuration settings, but will probably reduce battery life). One exception: motion should be triggered immediately if you have linked the correct channel to your item.

Note that my FGMS is an older version so it does not exactly match your device.