[SOLVED] Frontail not starting after fresh install - OpenHabian

I just installed openhabian on a Raspberry PI 3 using image file downloaded from OpenHab site.

Frontail service is not loading, I always get following status msg:

[15:14:02] openhabian@openhab:~$ systemctl status frontail.service
● frontail.service - Frontail openHAB instance, reachable at http://openhab:9001
   Loaded: loaded (/etc/systemd/system/frontail.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2019-08-24 15:09:21 -03; 4min 47s ago
     Docs: https://github.com/mthenw/frontail
  Process: 577 ExecStart=/usr/local/bin/frontail --ui-highlight --ui-highlight-preset /usr/lib/node_modules/frontail/preset/openhab.json -t openhab -l
 Main PID: 577 (code=exited, status=203/EXEC)

Aug 24 15:09:21 openhab systemd[1]: frontail.service: Service RestartSec=100ms expired, scheduling restart.
Aug 24 15:09:21 openhab systemd[1]: frontail.service: Scheduled restart job, restart counter is at 5.
Aug 24 15:09:21 openhab systemd[1]: Stopped Frontail openHAB instance, reachable at http://openhab:9001.
Aug 24 15:09:21 openhab systemd[1]: frontail.service: Start request repeated too quickly.
Aug 24 15:09:21 openhab systemd[1]: frontail.service: Failed with result 'exit-code'.
Aug 24 15:09:21 openhab systemd[1]: Failed to start Frontail openHAB instance, reachable at http://openhab:9001.

I tried to update WorkingDirectory=/usr/lib/node_modules/frontail/ in /etc/systemd/system/frontail.service as proposed at GitHub, but no effect.

Any clue what is happening?



1 Like

It looks like there is a workaround listed here.

1 Like

I have the same problem as @nambuco with a fresh installation of openHABian 1.5 on my Raspberry Pi 4. The suggested solution on GitHub (changing the working directory) didn’t help me either.

try ln -sfn /usr/bin/frontail /usr/local/bin/frontail


Thanks @mstormi! I also found the fix at https://github.com/openhab/openhabian/commit/b52bd84a0be2f9abc48e1ce1533579c30e181635.

Thanks @mstormi, that solved the problem !!!

this appears to be a new issue, needing a new thread. Do not crap on somebody else’s solved thread.

No I don’t think so, this is on topic, isn’t it ?
BTW the proper fix is here: https://github.com/openhab/openhabian/pull/688

1 Like

A problem was solved 3 months ago.
Somebody with a similar problem where the original solution did not work is new, I think.

Hey all, sorry to bring this up again but I had a similar issue with my installation.
May be interesting if all the above des not help.
After some digging I found the problem: I had a ARMv7 version of node on my Pi Zero (ARMv6). I think is is due to me doing the first install on a RPi3 (ARMv7) for speeds sake and then switching the SD card to the Zero for minimal power consumption.
You can check easily if you got that problem with issuing node --version on your Pi.
If you get Illegal Instruction, you’re affected. And it affects all node services, like Node-RED etc.

To fix this, you need to install a compatible version of node. This can be done with two commands as root:
wget https://nodejs.org/dist/latest-v10.x/node-v10.20.0-linux-armv6l.tar.xz
tar -C /usr --strip-components 1 -xJf node-v10.20.0-linux-armv6l.tar.xz
This will download an ARMv6 compatible node version and install it above the existing node. Check again with node --version if it worked.

Some additional info:

The Pi Zero is not supported hardware to riun OpenHAB.

Doubt that… Where did you take that information from?
Official docs even mention the Pi Zero (W) in the WiFi setup notes. And it works quite nicely once started up (takes ~15min). I’m running it in a boat as low-power alternative to its big brothers.

I see that .
It is a documentation error because openHAB is not officially supported on the Pi 0w

Recommendations for a “headless” hardware setup:

  • Raspberry Pi 2 or better, compare your existing device here if you are unsure.
  • SD card (16GB or more to support wear-leveling)
  • Steady power supply
  • Ethernet connection
  • No connected display or keyboard needed

from https://www.openhab.org/docs/installation/rasppi.html

RPi0W isn’t “supported” because there is no official statement anywhere saying it is.
To support a system means many things, one of them is to constantly test any major changes against any “supported” HW and that’s what we (maintainers) cannot spend the effort on that it takes.
A RPi0W is an edge case because it has just 512MB. That means we cannot run memory intensive stuff like ZRAM or Grafana. That doesn’t mean it doesn’t work if you only run stock openHAB.
But it means that if you run into trouble you are essentially on your own. Mind you that you are anyway because you chose to deviate from the install procedure (and see? it’s there for a reason …).
We’re still discussing if we will support RPi0W in the future.
The (preliminary !) future version of the README to state what openHABian supports is here.

1 Like