[SOLVED] Getting "500 Error"

if I want to edit my topics, it says “500 Error”.

What am I doing wrong?
What can I change?

Still having the same error, am I the only person here who gets this?
Edit 2:
Now I really want to update something in my topic, because I found a big problem in what I published there. Now I could fix it, but this error keeps coming…

Thanks for your help!

Maybe you can check what request fails using your built-in browser debugging tools (press F12)?
You’ll be able to see all requests and when they fail (500 error) they’ll be marked in a red font.
If you click on the requests you’ll be able to see the details like hosts/paths it’s requesting.
Providing some extra information about the request that fails using the debugging tools will help troubleshooting it.

See also tutorials like:

Thanks for your answer.
Screenshot added!

Thanks for the details!

When do you get this issue? When you edit your first post in LogViewer Android App for openHAB?

It looks like some kind of issue in the Discourse forum backend or database and very similar to 500 Error when editing an existing post.

Perhaps @Kai can see if there is an error in the Discourse server log?

I get it when I click “Save Edit”, so basically in the same situation where the others get the same error, but retrying doesn’t solve the problem for me…

I have other reports about HTTP 500 and there is a critical Discourse fix available - I will install it tomorrow morning (when there is less traffic than now in the evening). Let’s see, maybe it resolves such issues!


Installed. Let us know, if your issues persist.

I’m sorry, no, still getting the error.
The strange thing is that I only get the error if I want to edit this specific topcis, the other ones are ok.

I’d then suggest to live with it and hope that it doesn’t occur on any other topic in future.

Should I open a new topic for my app (for feedback, changes, …)

It would solve your problem :slight_smile: .

@Kai @wborn

I figured out the part of my topic which triggered the error:
It was only and alone the tag “androidapp”.

I have no idea why especially this tag but I tried changing every single part of my topic and this is the only thing that worked for me.
I also tried to delete just this tag, publish the edit and then adding it again, but then the error occurs, if I want to save the edit where I add the tag again, so replacing it worked well!

Thanks for your help!!!

1 Like

Excellent, glad to hear that you solved it!

1 Like