[SOLVED] Google assistant can not add OpenHAB anymore

Tags: #<Tag:0x00007f6173cfd1a0>

my config was working perfectly
i added a new device which i needed to sync with google assistant but it gave me a verbal error

i decided to remove openhab and add openhab again(to get all the devices which i tagged again)

problem is i can not get it to work anymore.
cloud connector is online (can acces openhab cloud on my pc)
openhab app is working on ios(can acces everything both remote and local)

the thing is when i try to add openhab in google assistant i normally get the oath2 screen, well not anymore

it instantly says Openhab is connected and after a while it states "something went wrong, please try again.

i tried removing all the tags from openhab to see if that causes problems but the problem stays the same.
emptied cache safari on my iphone, still the same problem.

how can i force google assistant to bring up the oath2 screen from openhab?

1 Like

within the google home app, have you got any discovered openhab item left?
if so:
click on settings>
click on the room in which the item is>
click on the item>
click on “disconnect openhab”

i do not have any items left
there is a sonos speaker but i am pretty sure it is connected directly from sonos to google

found anotoher option
within the google home app

click on the account icon (bottom right)
under google assistant click on “other settings”
choose the assistant tab
click on “smart home”
even if you have no connected devices in the list, click on the 3 dots on the top right
click on manage accounts
you should be able to disconnect openhab now

it really is convoluted

that is what i normally do
thow away coupled account and then add it again.

problem is i can not add it(because of the error) and i can not throw it away because it is not in the list of coupled devices, only the sonos is (which i threw away but that did not help)
i even threw away all the rooms so there is nothing left.
i just can not add it anymore and i do not get the oauth2 screen anymore. it is like google changed something and they do not want openhab to be added anymore or the openhab plugin changed
i did not change a thing in my setup.

Ha i put my iphone in flight mode. it does exactly the same so it looks like the problem is in google home/assistant and the Openhab plugin which is supplied to google. either google changed something or Openhab did.
i noticed dome openhab changes 2 months ago and i think these are responsible

it is not even actively looking to openhab(how can he do this without a network connection)

i tried something else.
since openhab is not the problem if figured it must be google

If i login with another google gmail account everything works perfectly

so how can it be that one account fails and another works

can google disable things on an account level or is the problem with myopenhab which blocks my google accont so it does not get forwared to the oauth2 screen

I’d say that is a google home bug that doesn’t forward the request to myopenhab within your account (some “registered” flag within their code might not have been reset)

One last thing you could try out on OH side to shake things up a bit, is delete your myopenhab account and recreate it.
I’m not sure if it would work smoothly, nor that it woudl ahve any effect whatsoever, but, well, it can’t get much worse than what you are describing.

yes that might be worth a try.

i can also leave the account and create a new one to see if it helps

tested it. not working

deleted myopenhab account
recreated it(cloud was offline)
deleted cloud connector and installed it againb(back online)

with my account is states account coupled and then something went wrong.

then i used the google account from my son.

first i get the oauth2 screen and after that the coupled screen and after that all the the devices.

so it looks like google assistant is not redirected to the oauth2 screen but instantly bypasses it(without the correct credentials) then it mentions something went wrong(because it has no authorised connection to openhab)

1 Like

:frowning:
I found a 2 years long thread of people using samsung smartthings hub having your issue…
It’s definitely a GoogleHome issue.

That thread led me to this


which led me here
https://developers.google.com/identity/protocols/OAuth2WebServer#tokenrevoke
ending up here:
https://security.google.com/settings/security/permissions

see if any of this helps you…

i think you might be right but it is really a shame that google did not fix this problem since it seems widely spread.

so far no luck.

i think the fastest way to solve this is delete my current google account and create a brand new one with fake info.

thanks for your help Dario, really appreciated

Ha UPDATE.
IT IS WORKING AGAIN

i was searching for the page to delete my account. scrolled to the bottom
i noticed an entry LINKED ACCOUNTS
opened it and instantly noticed openhab
deleted it and the problem is gone.
so the problem is not giving google access to apps but it seems Google was linked to openhab

so this at the bottom of the security page called LINKED ACCOUNTS

again thanks for your help.
i had revoked google access to everything but this sneaky menuy was hidden in plain site

2 Likes

This did the trick. You’re a hero!

I was too early. I could remove the Google account from myOpenHAB and the OpenHAB from my Linked accounts in Google. But I cannot get the Google Assistant working anymore. I always get two screens. The first says OpenHab is linked and the second one is there was an error “Something went wrong. Try again.”.

When I look into Google the OpenHAB account is linked again and in myOpenHAB the Google Assistant is linked as well.

So what can I do to start debugging this or has anyone had the same experience?

i would login google and delete the linked account
after that login openhab cloud, go to applications and delete every google assistant entry

logout of google and openhab and try again to add openhab to google assistant on your phone.

if all fails you can always make a new account with google and try that one.

I deleted all google entries at
https://myopenhab.org/applications

and all openhab entries in
https://myaccount.google.com/accountlinking

Then I tried to link openhab with google assistant again. It didnt work but in both lists are the expected correct new entries again.
:frowning_face:

I have the same problem with the mi home service, so I dont think it’s a problem with myopenhab.

I just had the same problem. Although this topic is marked “SOLVED”, it doesn’t seem to have a replicable solution (more coincidence or luck). So please find here my fifty cents:

I made an observation with the openhab integration of google assistant. It seems to be “picky” regarding the consistency of the “.items” files.

A single items file with the following content works …
Dimmer LoungeWestTable_LightDimmer "Lounge Table Lights" {ga="Light"}
Dimmer LoungeEastWall_LightDimmer "Lounge Wall Lights" {ga="Light"}

… but not the following one
Dimmer LoungeWestTable_LightDimmer "Lounge Table Lights" {ga="Light"}
Dimmer LoungeEastWall_LightDimmer {ga="Light"}

The missing “Lounge Wall Lights” leads to crash the google assistant update process.

Your second item does not have an label. I believe a label is mandatory! It doesnt make sense without.

Not according the documentation.

Hmm… Odd, I dont see how Google is suppose to know what to call each devices then…
But anyway, all my items are equal… They should behave the same, but dont :slight_smile: