[SOLVED] Google Assistant "Couldn't update the settings. Check your connection"


Im running OH 2.4 on a RPi 3 B+. I installed the OpenHab Cloud service and am trying to connect my Samsung S8 via google assistant to openhab. Everytime I try to connect I’m getting the error message “Couldn’t update the settings. Check your connection”. I tried about 50 times, the suggestet solutions in this forum and on the web didnt help.

The only item (for testing) exposed is

Switch Webpcswitch "Web PC" <switch> (Alle_Computer_ausschalten, Alle_Computer_einschalten, Master_Switch) [ "Switchable" ]

There is no binding config for this item, it is controlled via a rule. I also tried to expose no item, with the same error message.

I also found a tool in the forum which checks if the exposed item is ok. According to this my item is ok for google assistant.

Please help!

Solved it after 20 hours of trying. You have to add a label to ALL OF YOUR ITEMS, also those not exposed to google! Maybe the docs should be changed…

1 Like

Do you mean label or tag?

Only tags are required for google. And you only need to tag the items that you want to control over GA.
There is no need to expose the items in the openHAB cloud. This is only required for using 3rd party apps such as IFTTT

I really mean label, not tag. Without adding a label to all items (even the not tagged or not exposed items) i got the error message “Couldn’t update the settings. Check your connection” and google assistant wasnt connected

You saved my life

I was trying for a week to get Google Assistant working to no avail until i read your post! Added labels to ALL my items and behold: it works!

If only they mentioned this in the documentation…

Thank you, thank you!

I’m glad that worked for you guys, but tagging every item in OH shouldn’t be necessary and is definitely not required. I only have 4-5 items tagged for Google Assistant, and I’ve never had a problem with discovery. This must be some different issue that is being conveniently solved by tagging all of your items.

I’m curious as to what will happen if you untag some items and refresh your devices in Google Home, but after you’ve just gotten them working, I don’t want to suggest that you monkey with it. :wink:

I’ve not changed anything else then adding the labels. I’ll try tomorrow to see what happens if i remove some but until i added them google home would say it couldn’t connect to openhab and i had to check my connection… There was nothing in the logs except for ‘openhabcloud connected…’

For the reference: its labels you need to add, not tags.

Come to think of it, i still have some items that aren’t labelled because I’ve created them in the paper ui. So it appears to be affected only by the items in the .items files.

Ah, I’m caught up now. So you weren’t talking about tagging items to expose them to Google and Alexa, but labelling them so that Google and Alexa know what to call them (and can find them).

That’s interesting. I suspect that I’ve given all of my items labels, just because I always do when I create them. So I (and others) might just be meeting this condition out of practice.

I’ll try removing some labels at random to see if I get the same results. If that is the case, then I agree that the Google Assistant page (and Alexa?) needs a line to say that much.

@Celaeno1, I just saw your post about solving Alexa discovery issues by fixing items that don’t have labels in /rest/items.

Can you confirm whether or not labels are needed for every single OH item in order for discover to work, even if they aren’t tagged for Alexa or Google Assistant? If so, the docs need to be edited as that’s not clear (they just say that tagged items need labels).

Sorry if I missed seeing it in the other discussion. I saw someone ask this question, but didn’t see a direct answer.


AFAIK only tagged items need labels. Labels have to be unique. They will be your “devices” in Alexa APP.

Hmm. I wonder if applying labels to all of their items somehow fixed the issues you identified/solved.


Maybe “Google Assistant” handle this different to Alexa? I don’t know, sorry.

Same here, I have removed “ga” and add labels to all items except groups. Now working