[SOLVED] Google Home Goes 'Offline' and audio sink doesn't work

I’ve recently added Google Home to my setup. Initially I tested it in a standalone environment to understand the best way to use it - things, items, sitemaps etc etc. This worked perfectly and allowed me to use it as an audio sink to say phrases and alerts.

Once I added it to my production environment, things started to behave differently. I’ve added it in the same way and it shows up in PaperUI as expected. The ‘control’ & ‘volume’ channels populate and link correctly based on the pre-defined items. I can control the volume via the slider in the PaperUI - and I hear it ‘pip’-ing as the volume changes. The PaperUI thing lists it as green ‘online’.

Once I trigger a test rule to say a pre-defined phrase, I hear the chirp of it getting ready to speak and then nothing else happens. The status of the device in the PaperUI things section turns grey and says ‘offline’.

Volume can still be changed via the PaperUI control menu and it still ‘pips’.

If I keep firing a rule to say a phrase the status will change to “Status: OFFLINE - COMMUNICATION_ERROR Unable to load media”.

If I then change the volume level via the PaperUI the status will revert to a simple ‘offline’ and the following appears in the logs.

20:50:44.337 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'Lounge_GoogleHome_Volume' received command 18
20:50:44.355 [INFO ] [marthome.event.ItemStateChangedEvent] - Lounge_GoogleHome_Volume changed from 29 to 18
20:50:44.563 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'chromecast:chromecast:xxxxxxxxxxxxxxxxxxxxxxxxxx' changed from OFFLINE (COMMUNICATION_ERROR): Unable to load media to ONLINE
20:50:44.628 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'Lounge_GoogleHome_Volume' received command 23
20:50:44.648 [INFO ] [marthome.event.ItemStateChangedEvent] - Lounge_GoogleHome_Volume changed from 18 to 23
20:50:44.938 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'Lounge_GoogleHome_Volume' received command 30
20:50:44.956 [INFO ] [marthome.event.ItemStateChangedEvent] - Lounge_GoogleHome_Volume changed from 23 to 30

The PaperUI doesn’t change the status to ‘online’ though!

PaperUI -> Config -> Audio is all setup to use GoogleHome
PaperUI -> Config -> Voice is all setup to use VoiceRSS Text-to-Speech
Location and language are set correctly (‘en’ & ‘GB’).

I’m using ‘VoiceRSS Text-to-Speech’, but I’ve also tried the Mary-TTS as well with the same results. Plugging in the normal speaker gets the expected results when setup using the ‘System Speaker (with mp3 support)’.

The karaf logs give the following message"

20:34:58.331 [ERROR] [core.voice.internal.VoiceManagerImpl] - Error saying 'Hello this is a test': Unable to find a voice for language en

Using karaf to trigger a simple say also doesn’t work - the Google Home chimes and then nothing. The logs then show:
20:56:33.976 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘chromecast:chromecast:xxxxxxxxxxxxxxxxxxx’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Unable to load media

Has anyone else had this or similar situation with a Google Home? Any chromecast device? Any suggestions how to get the Google Home working as an audio sink?

I’m using a Chromecast audio and some sonos devices. All are working well in respect of the say command.
Reading the error, it sounds as if you didn’t select a voice, but that is ruled out by the say command working on the system speaker. No clue!

Hey Jürgen

Quick questions - do you have multiple chromecast devices or just 1? Is it powered/connected 24/7 or is it off when not in use?

I have a ‘normal’ A/V chromecast on the system, but although that is listed on OH2, it’s not actually powered on, so it’s permanently offline.

I’m wondering if there could be a conflict/confusion between the online Home and the offline chromecast.

To be fair I’m grasping at straws here.


1 Like

I have only a single Chromecast and it has to be powered all the time to make it work correctly.
I was trying to work with a powered OFF device in conjunction with a rule that triggers when the device reports ONLINE again. The problem is that it didn’t turn OFFLINE.

I might remove the chromecast and see if that makes any difference. I doubt it, but as I said, grasping at straws here.

I’ve been wrestling with exactly the same problem. If I switch my audio default sink to Sonos in PaperUI it works perfectly, i.e., an English voice from VoiceRSS says the appropriate text, as executed from a Rule. If I use Google Home as my default sink I get the ‘pip’ and nothing else. The volume control works properly from PaperUI so my connection to Google Home is configured properly. All the same issues as described by Nick.

There seems to be a problem with the binding.

Mark - do you just have the one chromecast device setup in OH or is there a Home and others?

I’m wondering if this problem/behaviour is also covered by this GitHub issue

Just one chromecast device, Google Home.

OK, that sinks my theory about chromecast clashes.

UPDATE: I removed the other chromecast that is not used/powered and re-started OH2. Running my test rules that says a random phrase returned the following errors in the karaf logs.

20:22:34.898 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'RandomResponse' received command ON
20:22:34.924 [INFO ] [marthome.event.ItemStateChangedEvent] - RandomResponse changed from OFF to ON
20:22:34.938 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent.
20:22:37.412 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'RandomResponse' received command OFF
20:22:37.417 [INFO ] [marthome.event.ItemStateChangedEvent] - RandomResponse changed from ON to OFF
20:22:38.429 [INFO ] [marthome.event.ItemStateChangedEvent] - Lounge_GoogleHome_Player changed from PLAY to PAUSE
20:22:38.436 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent.
20:22:39.108 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'chromecast:chromecast:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Unable to load media

And it still chirps and then does nothing.

I’m having the same issue. Was there a resolution to it, yet?


I’ve also paired my OH RPi3 with the Google Home via BlueTooth, but getting audio out that way was even more frustrating.

Eventually I went back to using a powered speaker via line out.

MIght pay to log your issues with GitHub (see this post above Google Home Goes 'Offline' and audio sink doesn't work)

I had the same problem while trying to stream mp3 files to my Google Home.
The log was showing:

chromecast:chromecast:xxxxxxxxxxxxxxxxxxx' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Unable to load media

My fault was to enter in PaperUI in the configuration of the Chromecast binding just the 'IP-Address:Port' as Callback URL.

I had to change it to ‘http://IP-Address:Port’.

Perhaps this helps someone.

1 Like


I tried that via PaperUI changed the IPAddress from to, but it didn’t make any difference. Port is a separate entry in my PaperUI.

Thanks though, any ideas are welcome at this point!


Hi all,

do you have an update on this?
getting the exact same Errors:

2017-11-09 11:58:09.454 [hingStatusInfoChangedEvent] - 'chromecast:audio:googlehome' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Unable to load media

if I use smarthome:audio play chromecast:audio:googlehome barking.mp3

I’m using my Google home as a chromecast like this:



chromecast:audio:googlehome [ ipAddress=""]

Nothing new. Still get same errors. Resorted to USB powered speakers via line out.

that’s my way to go also. Why is everything wireless nowadays and then you have to go back to good ole wires… :laughing:


I just want to use the Home as it means 1 less thing cluttering up the lounge! WAF much higher then!

1 Like

Same problem here
Someone manage to solve this issue?

Exactly the same issue here: chromecast:chromecast:xxxxxxxxxxxxxxxxxxx’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Unable to load media

I’ve several Google Home minis, one Google Home and some Chromecast devices. But everywhere the same issue. Does anyone have an idea, what I could try now?