[SOLVED] HABPanel on OH2 - cannot select items for widgets


I started to check out HABPanel and see it popping up for configuration. I also created successfully the first board and can add widgets.
However I cannot see any items on the dropdown menu when editing my first widgets.
The documentation mentiones, that it should be possible.
Ist there something I might have missed?
Thanks in advance.

can you try with desktop Chrome and hit F12 to check if there’s anything going wrong in the Console or Network tab (look for red-colored stuff)?

Hi @ysc
Thanks for your help.
I will give it a try tonight.
Does it need to be Chrome? How about iPad, Firefox or IE ?

Chrome has the best developer tools IMO, what I’m asking is the output from the JS console and the result of the network calls to try to figure out what’s wrong for you.

Thanks. I am more comfortable with firefox and F12 did the job here as well.
However, when opening the popup by choosing “edit” I just get:
and a list of all the icons.
Nothing else.
And the dropdown menu is empty.

Damn it.
All my items are defined in my home.items file in /etc/openhab2/items.
So I just recognized that those cannot be seen in Paper UI in configuration -> items.
Does this mean HABPanel cannot see / select them as well??

However, when I use HABmin I can see all my items…

That is strange as the majority of my items are in item files and I can see them all in HABpanel. Not sure what the problem will be.

Thanks, @MikeD
So, that’s not the problem… hmmm
Maybe someone else has another idea…

When I go to items in Paper UI I get:
Error: 500 Internal Server Error

Firefox analysis brings up:
(no element found)

Does someone have an idea why Paper UI does not find the items declared in my home.items file?

Is there any option to link the widgets to the items by using a config file?
Because I cannot type in the items name manually using the habpanel UI

It won’t work at all until you resolve your error 500 issue. Try going to /rest/items directly using your browser and check the exception message, it might give you a clue.

Thanks, I just tried it and called
Just got:


    "error": {
        "message": "A != java.lang.String",
        "http-code": 500,
        "exception": {
            "class": "java.util.IllegalFormatConversionException",
            "message": "A != java.lang.String",
            "localized-message": "A != java.lang.String"


Actually it doesn’t give me a clue… :scream:
It does work with things though and shows all my things:


I had the same issue - I was using %d in a map transformation, after changing it to %s it seems to work.
See this post.


Only when using %d with map?
I have some %d, but only without map transformation…

@ThomasH, @ysc, @MikeD
Just found it in another MAP location:
I used:
DateTime Weather_Forecast_Day_1 “[MAP(week.map):%1$tA]” …
Removing this entry solved the issue and I can select the items in HABPanel.
Thanks for all your suggestions for investigation!

Just to be sure:
item-declarations in openHAB2 throw error-exception, if the item’s value is handled as integer?

so, items like these are the cause of the problems?

Dimmer Light_EG_WoZi_LG1 		"Fernseher [%d %%]"
Number Lueftung_Fan_Level   		"Stufe [%d]"

the error message when trying to open http://openhab2:8080/rest/items is

{error: {message: "d != java.lang.String", http-code: 500,…}}
	error: {message: "d != java.lang.String", http-code: 500,…}
		exception:{class: "java.util.IllegalFormatConversionException", message: "d != java.lang.String",…}
			localized-message:"d != java.lang.String"
			message:"d != java.lang.String"
	message:"d != java.lang.String"

I am not sure, because you obviously don’t use a transform (MAP) statement in your item - which was the root cause for me regarding the initial problem.
Do you have other items using MAP and %d ?

1 Like

yes, got a few like those:

Number ekey_door_action		"Letzte Aktion [MAP(ekey_action.map):%d]"		<lock>	(EG_Windfang)	{ekey="action"}

I guess it’s safe to move those to %s, because in the map theres no calculation of any kind.

after changing these, everything works fine. Is this a known bug or a feature? :wink: