[SOLVED] Heatit z-trm2 anyone tried it in OH2?

The new Heatit z-trm2 is finally out Spec sheet

What’s the state of the OH database for this?

I doubt it’s in the database. If no-one is currently using it, then it almost certainly won’t be since the database requires information derived directly from the device in order to create the entry.

When you have one, it can be added to the database.

On my way out to the store now. :slight_smile:
How to go about adding it?

See this link - you’ll need an account if you don’t have one, and I’ll need to update your access so you can edit. Just let me know when you have the account and I can update access no problem.


Turned out I had an account from a year back.
Username OMR. Check access level please.

So, procedure will be to include the new device and following Database Guide for adding from the xml file?

You already have edit access, so you’re good to go :slight_smile: .

Correct. Include the device, it should create the XML. Upload this to the database which will create the new entry, and then upload the manual, image, and populate all the other “stuff” like parameters, associations, and the overview data…

If you have any questions, just ask and I’ll try and help.

This is the full doc that came with the z-trm2. Not avaiable on the WEB yet.

@chris, how do I enter this parameter correctly in the database?

What you have in the database looks good, just tick “Allow free entry” so that other values could be used too.

1 Like

I agree with @5iver - what you have looks fine…

However, I don’t know that I understand the docs. It seems to say a value of 0 to 30 sets a temperature, but a value of 1, 2 and 3 have special values, so there’s an overlap.

I think I read this that really, a value of 0 is do nothing, 1, 2, and 3 are the special modes, and then 4 to 30 sets the hysteresis. But this doesn’t really tie up with the docs…

I think it’s not possible to set a hysteresis of 0.3, since this really means mode 3 - my reading of this is the minimum you can therefore set, is 0.4?

I fixed the error with the thingId. From a quick look, it looks good - let me know when you’re done and I’ll do a binding update (probably will be tomorrow).

Yes, it is either as you describe or one should OR in bit 0:1 with the mode for each setting.

I’m done :slight_smile:

I don’t think you can OR bit 0:1 - otherwise you would only be allowed to set specific numbers…

0 = off
1 = mode 1
2 = mode 2
3 = mode 3
4 = 0.4 deg?
5 = mode 1, but what temperature, 0.4 deg still?
6 = mode 2, temp?
7 = mode 3, temp?
8 = 0.8 deg?

Thanks. If I get a chance, I might try and do the update tonight…

I’ve added this to the binding and will kick off a rebuild in a few minutes. It should be available in 30 minutes or so (all going well with the build of course :wink: )…

1 Like

Nice. Will try it this evening.

Looks like the build completed ok, so hopefully it should work with the latest snapshot…

I’m using the development binding. (not using any security).
Is this equal to the snapshot now?

Ah, no, it’s not. Sorry, I didn’t realise that. Unfortunately I may not be able to update that version until tomorrow night now as I’m away from home and not sure I can access everything I need remotely.

I’ve managed to connect back via my VPN and have updated the development binding…