Z-TRM2fx device database update

zwave
Tags: #<Tag:0x00007f0142dbc8e8>

(Christoffer Hirth Aune) #1

I just installed a couple of new thermostats from Thermofloor “HeatIt Z-TRM2fx”. These show up as the (older) Z-TRM2, as they share manufacturer “019B” and type/id “0003:0202”. The FW version on mine is 3.4.

The configuration database seems to differ somewhat to the older model but I am not sure at which FW that change happened. As far as I understand, the following document shows the up-to-date parameter set:

Specifically I wanted the display to show “measured temp” instead of “setpoint”. I then had to set parameter 14 to 1 although the current database shows parameter 14 as something completely else.

Anyone else tried these new devices or have more info on this?

The thread for the original Z-TRM2 device is found here: [SOLVED] Heatit z-trm2 anyone tried it in OH2?


(SiHui) #2

Either update the database itself
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide
or if there are any problems post your /userdata/zwave xml file.


(Christoffer Hirth Aune) #3

Thanks sihui for the reply.
I should have mentioned that I already opened an issue on cd-jackson.com, but @chris wanted me to move it to the community, probably to avoid breaking the database for those using the original Z-TRM2.

I assume that @OMR may have some input on what FW version, etc. the original is using.

The device is working just fine, but the config-database needs an update, and I believe one of the temperature channels (sensor_temperature4) is not in use. (Maybe more?)


(SiHui) #4

We still need to see your xml file.


(Christoffer Hirth Aune) #5

Of course. I have uploaded it here: https://drive.google.com/open?id=1OnAR1BEC4cz1Z3mql2N4pIggr-IY1dYb


(Ole Morten Rønning) #6

Sure, I bought 10 of the ZTRM2 in one purchase and they all have these attributes:

I remember they briefly had a v2.9 that were withdrawn, and there was a 2.11 mentioned here.
Note that the Z-TRM2 has OTA FW update only. (The USB cable used on earlier devices cannot be used.)

If the new Z-TRM2fx is using the same Type/ID with a totally different parameter set, is that an error on their part, or is it OK to differentiate on the FW version only? (my experience is lacking here)

All I know is that a database update must not break compatibility with the Z-TRM2 with FW 2.6, 2.9 & 2.11.

How they will handle the replacement Z-TRM2 due in Q1-2 2019 remains to be seen, but if their re-use of Type/ID was wrong, we should contact them so they don’t make the same mistake twice. (trice)


(Chris Jackson) #7

If I look at the entries we have in the database, we have the following -:

Name IDs Version
TF016 0001:0001,0003:0201 < 1.7
TF016 0001:0001,0003:0201 1.8 to 1.91
TF016 0001:0001,0003:0201 > 1.92
Z-TRM2 0003:0202 > 2.6

So based on this, @toffyrn your device is being detected correctly. If there is now a newer version than 2.6, then we need a new database entry (I’m assuming that the current entry for 2.6 is correct for 2.6, so please check this first, but I guess that 3.4 is new).

Question time…

  1. Is 3.4 new? (I guess so)
  2. If so, when did the parameters change? (I guess at 3.4, and I assume there is no eg. 2.8 or 3.2).

If so, we need to set the maximum version for this entry to 3.3, and create a new version for 3.4, copy over the current parameters as a starting point, and change the ones that are different :slight_smile:


(Ole Morten Rønning) #8

I agree with all your guessing @chris.
What is your thought about them (rush) releasing a floor-sensor only version (fx) with a different parameter set?
Had it been cleaner with a new ID?
And what about the ‘real’ Z-TRM2 replacement due in Q1-2/19? If they don’t change the ID we end up in an even messier situation.


(Chris Jackson) #9

It doesn’t matter too much if they keep the same IDs. The database uses IDs and firmware versions to differentiate different devices. Personally, I’m happy if they keep the same IDs and just change the versions (I think this is what Aeotec do as well). It is cleaner (IMHO) as if you have a device with ID 1234:5678, and you update the firmware, then the ID should stay the same.

Now if the devices are physically different models, then yes, they should have different IDs in my opinion.

So long as there is no overlap if IDs and firmware versions though, it’s ok. We see with the list above that the TRM2 has a different set of IDs, so it seems that is what they are doing.


(Christoffer Hirth Aune) #10

The Z-TRM2fx running 3.4 is fairly new, was launched early December if I recall correctly; doubt they have multiple fw-versions for that already… I therefore second your opinion on just setting the max. version to 3.3 and create a new for >=3.4. Let me know if you like med to attempt editing the db. :slight_smile:


(Christoffer Hirth Aune) #11

Thinking about it, it looks like Thermofloor is using FW 1.* for the first model (TF016), 2.* for the second model (Z-TRM2), and 3.* for the newest (Z-TRM2fx). It probably does not matter though as long as no device with FW 3.3 is released…


(Chris Jackson) #12

I’ve created the new device -:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/980

It has a bunch of errors and it would be great if you can sort this out -:

  • Upload the manual and image
  • Check all parameters are correct (they won’t be as I copied them from the 2.x version). If you want to delete any, give it a label of DELETE.
  • Update the name / overview / inclusion / exclusion information
  • Generally make it look nice :slight_smile:

Thanks.


(Christoffer Hirth Aune) #13

Thanks Chris. Looks like I need edit rights to be able to change this. My username is “toffyrn”.


(Chris Jackson) #14

Sorry - I thought we’d done that… Anyway, you should be all set now…


(Christoffer Hirth Aune) #15

I have started on updating the device tonight, but will have to continue tomorrow.

One strange thing @chris: When I uploaded manual and images to the new device (980), somehow they got uploaded to the old device copied from (854). On the second try they were uploaded to the correct device. Unsure if this is only my view, or if these attachments actually ended up to 854. I had both devices open in separate tabs, may be a bug?

Anyways, thanks for the effort put into making device database simple to edit. :+1:


(Chris Jackson) #16

This sort of thing can happen if you have multiple windows open, then the site can get confused…


(Christoffer Hirth Aune) #17

Device documentation has two sections for associations:

  • “Association Groups (Multi Channel support)” - “When using Heatit Z-TRM2fx in a Multi Channel environment:”, and
  • “Association Groups (when no Multi Channel support)” - “When used in a system with no Multi Channel support:”

Anyone knows the difference, and which applies? It looks like “no multichannel” was used for the original device. Is this controller-specific, or?


(Chris Jackson) #18

Hmm - this is where ZWave gets messy as the protocol has changed a lot over the past few years :frowning: . I will try and have a look at this today.


(Willem van Asperen) #19

just adding a :+1: here! Thanks. I got mine somewhat working with this config: https://www.hjemmeautomasjon.no/forums/topic/3500-home-assistant-og-heatit-trm2-termostat/?do=findComment&comment=49014 but that seems to be for just the TRM2 – not the fix :slight_smile:


(Christoffer Hirth Aune) #20

Nice to hear @wasperen. The simplest solution for me, in order to show measured temp on display, was to set Param 14 to 1 although it is (incorrectly) displayed as “room sensor calibration”. Otherwise mine are working great.

I was hoping to contribute to the device database, but got confused regarding multichannel. Awaiting answer from @chris in order to get that correct. Hopefully I learn something along the way :blush: