[SOLVED] HomeKit Integration - Pairing Problems (iOS 10 - iOS 14)

Hi Guys,

i installed with Paper UI:
Add-ons/Misc/HomeKit Integration 2.1.0

and this is my configuration:

on my iPhone (Home.app) i can see “OpenHAB” as device, but pairing isnt possible.

can someone tell me why ? - the OH-homekit readme says:

Your first step will be to create the homekit.cfg in your conf/services folder

i do not have a homekit.cfg file in my services folder !? do i need to create it ?
this confuses me a bit :confused: where are my settings from PaperUI stored ?

also i created a test-item, and rebooted the raspberry

Switch HK_Stehlampe
"HomeKit Stehlampe" <light> (LR,gLight)
[ "Lighting" ]
		{ mqtt=">[broker:/Sonoff_1/GPIO/12:command:ON:1],
            <[broker:/Sonoff_1/GPIO/12:state:OFF:0]" }

Do i need to install HomeBridge, too ?

Thank you!


It’s unclear to me if this is a 1.x version binding or a native 2.x version binding. But the docs are pretty clear, as you quoted yourself:

“Your first step will be to create the homekit.cfg in your conf/services folder”

In internal cache files and databases and such. It depends on what the config is. Many bindings including ALL the 1.x version bindings are configured through .cfg files in the services folder.

I don’t know but I do know that if you haven’t created and populated the homekit.cfg it won’t work, so start there.

thanks rlkoshak

i created the homekit.cfg file with the same settings like above in the PaperUI:


i tried reinstalling the HomeKit Integration
now the “OpenHab” is gone on the iPhone, nothing shows up yet…

the openHab log says:

Also i tried what beowulfe said here:

the “OpenHAB” on the iphone isnt showing up at the moment :frowning:

I’ll be off no further help. The best I could find is the following

You should not need to create the homekit.cfg file, at least I never have on OH2. I’m not sure why the documentation says that since everything in the file is a duplicate of what you configure through the Paper UI.

That said, I’ve found Homekit to be a fickle beast. It has always been a fight for me to get it to pair successfully. You might take a look at this thread. Specifically the part about clearing pairings and allow unauthenticated. I wouldn’t think that you would need to clear the pairings given a first time installation, but maybe the failed attempts fowl something up.


This solved my problem! now it works! - thank you!! @PointandClick <3

How i got there for noobs like me: :wink:

  1. Check if “HomeKit Integration” is installed ( PaperUI -> Services -> HomeKit Integration )
    and type in the same config as in post 1 ( change network interface to your raspb. ip )
  2. Open Terminal an ssh to your raspberry ssh openhabian@192.168.X.X
  3. Type in: “ssh -p 8101 openhab@localhost” (pw: habopen)
  4. Type in: “smarthome:homekit clearPairings” - Enter
  5. Type in: “smarthome:homekit allowUnauthenticated true” - Enter
  6. Check your iPhone :wink:


PS: i have no “homekit.cfg” ( i deleted the created one from above )

Now Home.app & Siri works :smiley:

Good Luck :wink:


Today i updated to iOS 11 and my OpenHAB is gone in Homekit :frowning:

Anyone out there using successfully iOS 11 and HomeKit Integration ???


ios 11 and homekit works like a charm here :wink:

please explain me, how u got it to work - thanks!

I didn’t do anything really… worked in ios 10 and the update did not break it. And as far as I can see the only difference between your and my config is that I don’t have that standard PIN in there…
Sorry not much of a help

have you updated ALL your Devices to iOS 11 ? AppleTV and all iPads/iPhones ?
and whats your code ? :slight_smile:


Thats what i get in the console after “smarthome:homekit clearPairings

2017-09-20 11:59:22.995 [WARN ] [homekit.internal.HomekitAuthInfoImpl] - Could not find existing MAC in org.eclipse.smarthome.storage.json.JsonStorage. Generating new MAC. This will require re-pairing of iOS devices.

i changed the Code in PaperUI to:

and it seems to work! - i can see the OpenHAB in Home.app again - but pairing isnt working, but i think i will get it to work - lets see :slight_smile:

Well there is one wallmounted iPad 2 that runs on iOS 9, but that doesn’t even support homekit, so yes they are all on iOS 11 (my girlfriends devices are still on iOS 10 though but she is only in the family share, and it works even though she is not at home, so that should not influence it)
The code is 062-25-954 but why would it change smth?
and you sure are aware of this right?:

HomeKit allows only a single pairing to be established with the bridge. This pairing is normally shared across devices via iCloud. If you need to establish a new pairing, you’ll need to clear the existing pairings. To do this, you can issue the command smarthome:homekit clearPairings from the OSGi console.


Thanks @Nicolas

i changed the code and now its working again - much love! <3


1 Like

Other than changing the code/PIN, what did you do. I have also HomeKit problems in openhab. Since I changed the PIN I can see openhab in home.app again, but I cannot pair it. How did you manage to pair it?

restart openhab/raspberry and try again
and have a look at your openhab-log :wink:

good luck

Thx. I somehow thought i did that already. But now it works.

I struggled with Openhab/HomeKit integration for a long time on a Raspberry Pi. I switched from a Pi to a Linux based computer and HomeKit magically started working. The config files were basically identical. I think something in the RPi’s networking stack makes it a poor choice for Apple’s proprietary networking requirements.


I’m a newcomer to this forum, and I am trying to connect a dozen of Particle Photons around my new home to OpenHAB and further on to Homekit, so that I can use Siri.

My OH server runs on a MacbookAir.

The first part works fine:

  • Currently I have 4 switches, by which I can start 8 (ON/OFF) Particle functions from the OpenHAB dashboard.
  • The external url via myopenhab.org works fine also.

Yesterday, I managed to pair with Homekit on my iPhone, but only the last one of my 4 switches appeared. It worked well!
But I found the reason of the other 3 switches not showing in Homekit was that the label “Switchable” was only added to the last item in the file “Fidel.items”. So, I added this label to all 4.
After that, Homekit did not want to show the first 3 switches, whatever I tried…

Then, I decided to remove OpenHAB from Homekit and start again.
But after 4 hours sweating, :tired_face: trying all tips I could find, OpenHAB does not show up anymore in Homekit…

I also tried to clear all pairings:

openhab> smarthome:homekit clearPairings
Cleared homekit pairings

openhab> smarthome:homekit allowUnauthenticated true
Enabled unauthenticated homekit access

I also tried with different Pin codes: 031-45-154 and 31-45-155

The weirdest thing I remarked now is that whatever I put in “Network Interface” is immediately changed to a kind of “fallback” IP address !!!
My OH server’s IP address is: (local) or https://myopenhab.org:443 (external)

See screenshot below:

Thanks on beforehand for any tips which bring back HomeKit…

Actually, I saw the same on @RiotMode 's screenshot:

this exact thing just happened to me as well, looking for a solution.

looks like the issue was related to: /var/lib/openhab/jsondb/homekit.json , check this file