[SOLVED] Initial setup exiting with an error

“initial setup exiting with an error” is the error I’m getting on initial installation. I’ve done the download 10 times in an attempt to ensure that the download file is without error.

Pi 2 B+ with 32Gig micro SD

Because you did not tell WHAT you’ve downloaded, start by reading:

http://docs.openhab.org/installation/linux.html or


2017-04-10_09:59:14_UTC [openHABian] Starting the openHABian initial setup. This
might take a few minutes.
2017-04-10_09:59:14_UTC [openHABian] If you see this message more than once, som
ething went wrong!
2017-04-10_09:59:14_UTC [openHABian] Storing configuration… OK
2017-04-10_09:59:14_UTC [openHABian] Changing default username and password… O
2017-04-10_09:59:17_UTC [openHABian] Setting up Wifi connection… OK
2017-04-10_09:59:17_UTC [openHABian] Ensuring network connectivity… OK
2017-04-10_09:59:25_UTC [openHABian] Waiting for dpkg/apt to get ready… OK
2017-08-28_02:24:54_UTC [openHABian] Updating repositories and upgrading install
ed packages… FAILED
2017-08-28_02:31:15_UTC [openHABian] Initial setup exiting with an error.

What did you use to burn the image on the SD?

Tried both, Win32DiskImager and Etcher … Etcher does not unmount successfully. Can get into openhabian-config. Think my server might be blocking the installation. Tried VNC but don’t know if it starts up when attempting first boot setup …

Is there any solution for this problem?? I have exactly the same problem. I checked everything several times, what can be a reason of such situation?

I got this fixed!

after logging in and getting the failed warnings in the log, I just ran

sudo /boot/first_boot.sh

and allowed it to finish.

2018-10-24_19:23:57_AST [openHABian] Installing Zulu Embedded OpenJDK… FAILED (keyserver)
2018-10-24_19:24:40_AST [openHABian] Initial setup exiting with an error!

I just could see a connection in my openwrt several times to

and some other weird ones.
what is openhabian calling there?

mine failed at the same place. the pi just goes black I tried to watch with my tv through the hdmi cable. i waited several hours but nothing happens. if i unplug the pi and plug it back in it tries to boot up but askes for my username and password. not sure what to do after that

I have changed power supply and everything went smooth.