[SOLVED] Issues after update to version 2.4.0


I have updated the system at the beginning of this week and have a a few issues.
The PaperUI is giving after a error Jersey not ready jet.
The sitemap is ofter disconnected but restores after a few seconds.
Also the HabPanel is often unresponsive, when I start the Habpanel, ik can take up to over 5 seconds before I can do something.
I must say, That I had in version 2.3.0 already had a problem that the Karafs ofter would restart when opening the HabPanel.
I was hoping this was resolved in 2.4.0.
For the habpanel I’m using a theme based on the Matrix theme.

I’m running the OpenHAB on a RPI3 with the automated installation.
The load of the RPI has increased also with the new version, from average 6% to average 12%.

I have no idea where to look or to troubleshoot this.
Or are there more who is are having these kind of problems with this version.


In general sometimes the cache can play up after upgrading. Cleaning the cache should solve issues. Are you familiar how to do that?

Also are you running on a SD-card? I don’t know if this might be related, but SD-cards can corrupt and cause unexpected problems. So if you do have an SD-card it might be an idea to see if using another SD-card makes a difference.

1 Like

Hello Hilbrand,

I’m running the system on a SD-Card.
The card is pretty big and a lot of free space and now just a year old.
I can’t imagine it could show already a defect, but keep it in mind.

I have now idea how to cleanup the cache, do you have some instructions how to do this?



Wearing out is not the only way a file system on an SD card can become corrupted. In fact, it is probably one of the less common ways that they fail. The most common cause is if the RPi loses power while it is writing. A tl;dr is when an SD card is written to, it copies a whole chunk of storage to a new location and there may be any number of parts of files in that chunk. When the RPi loses power it loses all the parts of all the files in that chunk. Those can include important files like config files, executables, kernel modules, etc.

Often we will blame the SD card wearing out here on the forum because we don’t know enough to tell the difference and it will save the end user time in the case where the SD card is worn out so we recommend replacing the card. If you are pretty certain that your card hasn’t worn out then it still might be corrupted and you just need to rebuild the card.

I’d need to see errors you are seeing in the logs though to know if this is indeed your problem.

I looked today into clearing the cache.
It was done with a easy command in the cli openhab-cli clean-cache.

After this the system is responing a lot better so seems to be solved.

Thank you.