[SOLVED] LogitechHarmony Hub Binding not responding anymore

Hi Folks,

After adding a device to my harmony configuration (with android harmony app) the app decided to automatically update the firmware of my harmonyhub device.

After that the binding immediately stopped working. I tried removing and re-adding but with no success ;(
I even tried to manually setup a device with a .thing file, but this isn’t working too…

I think Logitech changed something in the behavior the hub receives commands, because the logitech android-app is still working and responding fine.

The thing is recognized in PaperUI but with no channels available

Maybe I’m not the only one experiencing this problem??!?
I think the autor of the harmony binding is the only one to help us out so far…

cheers

Dan

Ahh by the way… the state of the thing says:

Status: OFFLINE - COMMUNICATION_ERROR Could not connect: Failed communicating with Harmony Hub

SORRY FOLKS I OVERLOOKED THAT THERE IS A DOWNGRADING SOLUTION read in another thread that this is a good workaround…

Thanks anyway

Yes here is the other thread if someone is looking for it:

Add me to the collection! Just checked firmware and its the same one and no workie any more. I will keep an eye out for when there is a fix or work around. The Harmony is a key piece of my home theater system.

Logitech has removed the “API” … which was apparently not official

Take a look here. Inofficial how-to-downgrade …

Logitech now has a beta firm ware that reenables the API a promises non beta version in january

https://community.logitech.com/s/question/0D55A00008D4bZ4SAJ/harmony-hub-firmware-update-fixes-vulnerabilities

1 Like

For any of you who can’t see the “XMPP Supported Firmware Update”
I had to Repair the Harmony Windows Softare via Windows Programs & Settings. Otherwise the XMPP sofware was not availlable for me, but this did the trick… hope this helps others who get stuck at this point.

cheers Dan

Ahh and by the way: Have a nice christmas!

For those who find themselves in the same trouble after the latest update -> Logitec implemented a setting, so we can keep the XMPP Support with the newest firmware. See https://community.logitech.com/s/question/0D55A00008OsX3CSAV for more info.

This is great news! XMPP can now be enabled via phone app:
Harmony setup -> Add/Edit Devices -> Remote&Hub -> Enable XMPP
All is working fine now.

Since 2 days my hub is not responding to openhab anymore… checked that XMPP is enabled in settings, changed the IP given by DHCP, resetted the Hub.

Then in Openhab tried to add new Hub after removing the old entry and reinstalling the binding …tried this several times plus restarting the openhab service!
No access to my Hub anymore.

My Hub is online and I can control it via the android harmony app
Don’t know what to do next?!??! Anyone else having issues with harmony hub again??

Forgot to mention that the hub is found in PaperUI via autodetect… but its shown as OFFLINE - COMMUNICATION ERROR and also finds no Harmony Devices because of the communication error.

Edit: Also tried to disable and reenable the XMPP option for several times now - no change…

@Dan

Which firmware version do you have? 4.15.250?
Which binding version?

karaf console:

   bundle:list |Grep Harmony

openhab> bundle:list |Grep Harmony
296 x Active x 80 x 2.5.0.201902041209 x HarmonyHub Binding
297 x Installed x 80 x 2.5.0.201901082136 x HarmonyHub Binding

Maybe thats the problem, hm?

Can’t find the FW version with the harmony app… maybe I’m blind

will walk downstairs to my windows-pc with harmony software installed…

Settings --> Info --> Versions --> Hub-Software

And please uninstall one of the 2 harmony bindings.

 bundle:uninstall 297

I too have this issue since 1-2 days now… As far as I can tell noting had changed on my end. I had installed the “special” Harmony FW that they finally offered after the debacle a few months ago and it’s been running fine since then.

I’ve attempted to remove/re-install the Harmony binding w/o success. I can ping the hub. hub works as expected with the phone app and/or Remote

Harmony Hub SW: 4.15.250
APP Ver: 5.6
Build 14

OH2 log entry:
2019-02-20 16:58:32.204 [hingStatusInfoChangedEvent] - ‘harmonyhub:hub:Batcavelivingroom’ changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Could not connect: Failed communicating with Harmony Hub

OK had to scroll down :dumb

4.15.250

will now uninstall… done

@NOTORIOUS_VR

Which binding version do you have?

Did you enable XMPP in Harmony Hub APP?

The Standard binding:

binding-harmonyhub - 2.4.0

I have no enabled anything in the Harmony APP. I don’t even use the APP (except to make changes which is never).

I don’t see any XMPP option in the app, can you be more specific?

296 x Active   x  80 x 2.5.0.201902041209     x HarmonyHub Binding

XMPP is enabled

@NOTORIOUS_VR

phone app:
Harmony setup -> Add/Edit Devices -> Remote&Hub -> Enable XMPP

Yes Found it… Enabled it… now I seem to have at least something happening in the Logs, something about no authentication?

2019-02-20 17:13:37.812 [WARN ] [oftware.smack.AbstractXMPPConnection] - Connection HarmonyXMPPTCPConnection[not-authenticated] (15) closed with error

	at org.xmlpull.mxp1.MXParser.parseEpilog(MXParser.java:1588) ~[270:org.openhab.binding.harmonyhub:2.4.0]

	at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1393) ~[270:org.openhab.binding.harmonyhub:2.4.0]

	at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093) ~[270:org.openhab.binding.harmonyhub:2.4.0]

	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1228) [270:org.openhab.binding.harmonyhub:2.4.0]

	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:980) [270:org.openhab.binding.harmonyhub:2.4.0]

	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:996) [270:org.openhab.binding.harmonyhub:2.4.0]