[SOLVED] Lost communication with owserver after switching via Openhab stage of DS2405 or DS2408 items

Hi There,

I run following software:
Ubuntu 18.04.1 LTS
Openhab 2.4
Onewire binding: 2.4
owserver 3.1p5

After starting Openhab, statuses of all onewire items are presented and updated in Openhab (Paper UI/HABPanel) properly.

But when I’m tring to change stage of any DS2408 or DS2405 output following lines occur in Events Log:
2019-01-06 16:22:24.674 [nt.ItemStatePredictedEvent] - ITEM predicted to become ON
2019-01-06 16:22:24.692 [vent.ItemStateChangedEvent] - ITEM changed from OFF to ON

Status of ITEM in Openhab is changed but in owserver keep unchanged.
From that moment there are no updates in Openhab of any onewire items.

But the owserver itself is working properly and I can change stages of DS2405/DS2408 for example via owhttpd and I can read from DS18B20 current temperature.

During Openhab shutdown process following messages occur in log file.

2019-01-06 16:28:33.974 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler OwserverBridgeHandler tried updating the thing status although the handler was already disposed.

It’s look like that number of warning messages is proportional to number of updates that should be transfer from owserver instance to Openhab.

Restart of Openhap solves problem until next write to onewire items.

Additionally there is very long time (usually more then 10s) of changing MODE or CHANNEL LOGIC parameters and not all the time changing of CHANNEL LOGIC parameter gives expected result.

Any ideas how can I solve the problem?

Which version are you using? It seems like an already fixed problem.

Please try this version.

Ubuntu 18.04.1 LTS
Openhab 2.4
Onewire binding: 2.4.0
owserver 3.1p5

Could you provide another link as this one is not valid?

Just select “Latest OneWire Master build”.

Nothing is there. Please find screenshot.
Maybe issue with permission?

Really interesting. The link pointed to “org.eclipse.smarthome.binding.onewire-MASTER.jar” which resolved for me to “https://janessa.me/esh/org.eclipse.smarthome.binding.onewire-MASTER.jar”. I’m not sure why you miss the “/esh” part. I have made more explicit links now.

Issue solved. Thank you

Hi Jan,

I’ve had the same problem.
Is ist correct to put the file in /usr/share/openhab2/addons ?
But how to install ist? It seems that it was loaded automatically on startup.
And how to figure out the used version?

And another question is how to debug or trace it?
I’ve tried
Log:set TRACE org.openhab.binding.onewire
But I couldn’t get more output in the event log.


For installation, please follow the instructions here.
You can do bundle:list | grep -i onewire to get the version.
The correct name for logging is org.eclipse.smarthome.binding.onewire.