[SOLVED] MessageBodyWriter not found

So I’m continuously watching my logs and since some days (I think since installing Habmin via PaperUI) I’m getting these Errors:
Uninstalled Habmin but I still get those errors.

2018-11-18 13:32:20.609 [vent.ChannelTriggeredEvent] - logreader:reader:8******5:newErrorEvent triggered 2018-11-18 13:32:20.482 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent.

2018-11-18 13:32:20.618 [vent.ItemStateChangedEvent] - lR_leE changed from 2018-11-18 13:32:08.942 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent. to 2018-11-18 13:32:20.482 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent.

I would really provide more infos but I really don’t know where this Error is coming from and why.
Does someone have a clue?
Help is really appreciated!

What version of OH are you using? I guess it’s 2.3 or older as I think this issue was fixed in a more recent version of ESH.

Do a search on the forum and you’ll find a number of discussions about this -:

Allright, thanks!
I’m updating atm.
Looks like the Problem is gone!

I have the same error

MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent

I have installed OpenHAB 2.5.0 Build #1502 yesterday.

Today this is the first time I see this error.

I don’t have HABadmin installed.

The issue is related to ESH, and not HABmin. It should be fixed in the later ESH versions, but there may be multiple places where this can happen. I would suggest to raise an issue in the ESH issue list, but that’s probably not going to go anywhere now…

Can it be related to the change done for the move? Or is this not rolled out yet?

I’m asking as I get this message like every 5 minutes or so now. I never saw that before;
So something must be broken since the I installed the previous 2.5 install and yesterday

No - there are no changes yet.

Did you guys find a solution? It happens with me when I have my openhab upgraded to openHAB 2.5.6-2 (Release Build)

I’m having the same issue.
Are you from Brazil?

Hey Paulo,

Yes, I`m from Paraná state.

Legal.
Bom saber.
Não sei se pode ficar falando em português aqui.
So I have this issue when a send any command from my android phone habpanel app.
Have you solve it?

Not so far, still doing some investigating… I will update my openhab tomorrow and then see if it may solve our issue.

I think it has nothing to do with OH. It is an Android and iOs app problem.
It doesn’t seem like an error msg or a big problem. It looks more like a warning.
Opening Habpanel in a browser does not show the same message in the log file.