[SOLVED] Mqtt Binding will not work after update to 2.4

I made a apt-get update, now I have oH 2.4 running on my raspberry (this was not planned :wink: )

First the zwave parts are not working, I have removed and add them new, now they are working again.

But I can’t find the reason why the mqtt will not work.
The binding was not installed after the update, I install it.
I check the mqtt.cfg, this was the “old” one and has correct entries (same as before update).

On the Raspberry the MQTT signals are received from my switches etc (mosquito_sub …) as before , but oH will not “use” them. Also the mqtt-signals send from oH will not sended out (NOT vissible with mosquito:sub …).

What do I overlook? Must I add something else I forgot ?

Hint: Before the update I execute an “openhab-cli clean-cache” (oH stopped before, can this cause this issue now?)

Thx for help,
I’m shure this a “stupid” thing/error … because before mqtt works perfect and I use it everywhere !

(apt-get install mosquito mosquito-client show, that most actual version is already installed)
(mqtt.cfg hast also correct ownership (openhab:openhab, 664)

This was documented here and mentioned in the release notes for OH 2.4 as a breaking change.

Which version did you install? There is now a 2.4 version of the MQTT binding which is completely different from the old 1.x version. Unfortunately, depending on your settings, the upgrade replaced the old MQTT 1 binding with the new MQTT 2 binding because the MQTT 1 binding is now legacy.


If you want to stay with the MQTT 1 binding for now, you need to make sure you have enabled “Show legacy 1.x version bindings” and install it.

Thanks Rich,

thats what installed on the Raspberry:

libmosquitto1/stable,now 1.4.10-3+deb9u2 armhf [installed,automatic]
mosquitto/stable,now 1.4.10-3+deb9u2 armhf [installed]
mosquitto-clients/stable,now 1.4.10-3+deb9u2 armhf [installed]

And after enabling the show-legacy-bindings, I see in the Paper-UI=>add-ons, that now I have both installed; the binding-mqtt1 - 1.13.0 and the 2.4.0 (and I’m sure before enabling the legacy-binding-option I had not seen any MQTT Binding: This was the reason to install the provided one (and I see only 2.4.0))

Strange for me that I now see MQTT versions 1.13.0 and 2.4.0 in the Add-ons.

Actuall I think i will use the version as before, I install it 3 month ago (with oH 2.3: Was it than 1.1.3 or already 2.4 ?)

Next steps: De-install 2.4, and than the already existed 1.1.3 will work?

Both can remain installed side by side. Leave the 2.4 one installed and at your leisure start to migrate to using the 2.4 binding.

I de-install the 2.4 binding, and immediately the MQTT messages arrives (without doing anything else!).

I think I will wait with the update7usage from 2.4.

Thanks again for help!