[SOLVED] Multisensor Aeon PST02-A motion detection not working correctly with OH2


I am running into 2 issues trying to get the sensor to send Motion Detection data. Illuminance, temperature works fine, btw.

OH2 Version:2.1 with Habmin
Z-wave Binding Version: 2.1

Issue numer one: seems to be an issue with Configuration Parameter Operation Mode, it is defaulted to 0, when trying to set it to 60 (that is what I had set in z-wave 1.8 SNAPSHOT binding with openhab1) it returns ERROR 400 - bad request. Setting it to preset value of 10 also returns this error, and the value reverts to 0. A short term workaround I did was to configure the sensor in openhab1 with the 1.8 SNAPSHOT binding, and then boot up OH2. The sensor started to work correctly and detect motion and change state. However, once the wake-up happened, the config from OH2 z-wave binding 2.1 got loaded up and as the result the Operation mode got reset to 0 and the motion detection stopped working again.

Does anyone know how to force the Operation Mode to a value other than 0?

Issue number 2: After the discovery, several channels showed up including the Door/Window Sensor of type Contact (but i am not using this channel) and the Motion Sensor channel with type Switch (which I believe should have been a Contact - that is how I had it set manually in OH1). When creating an Item link for the Motion Sensor channel, the only type could be selected was “Switch”. After linking, I could go in into the item and change it from switch to contact, but the Channel type of the Motion Sensor remained as Switch, while the link changed to contact. Sorry if it is a bit confusing. :slight_smile:

So basically, is there a way to force the Motion Sensor channel to be a Contact, not a Switch type?

Any ideas? Thank you,

  • Tom

Well, you need to use the type that the binding wants for a certain channel - OH2 is different from OH1 in that the binding doesn’t know anything about how you define your items.

However, for the PST-02A in the database the Door/Window is defined as a sensor_door channel, which is defined for use as a contact -:

So, I would have expected this to work :confused:

It definately works. Have you tried setting the custom parameters to 20?

From reading the manual that would disable door/window (Bit 2), disable illumination (Bit 4), disable temperature (Bit 5) and set temp to Celsius (Bit 3).
I don’t think that is what you want …

I am after the motion detection sensor, not the door one :slight_smile:

  • Tom
<!-- Binary Sensor -->
    <channel-type id="sensor_binary">
        <label>Binary Sensor</label>
        <description>Indicates if a sensor has triggered
        <state readOnly="true">
                <option value="ON">Triggered</option>
                <option value="OFF">Untriggered</option>

or try

<!-- Motion Alarm Channel -->
<channel-type id="alarm_motion">
    <label>Motion alarm</label>
    <description>Indicates if a motion alarm is triggered
    <state readOnly="true">
            <option value="OFF">Ok</option>
            <option value="ON">Alarm</option>

Sihui, Spaceman_Spiff,

The issue is that right now I cannot set the values to anything with OH2, except the default 0. When I try anything else I get the server 400 error. However when I use OH1, I can set it to whatever values I need and then it works, even when I switch to OH2, but only until a wake-up after which the OH2 resets the value to 0 again. Normally, when working correcly, during daytime when I wave a hand in front of the sensor I get 2 notificaitons: one about motion and one about illumination. But then the value gets reset to 0, only the illumination notification gets send.


Motion sensors are indeed switches - as defined in ESH. You can’t change this.


OK, thank you, I will try to figure it out once I get the Operation Mode sorted out.

I would check the dip switches if they are not set to Test Mode and that the tamper key on the back is not released (= always in test mode).

From what I read in the manual, to be able to set config parameter 5 you need to have the dips in Customer mode (both off)

Right SiHui , in fact I do have them in the customer mode - have I have been playing with the sensor for over a year now with OH1 - never any issues until now…

Thanks for your efforts. :slight_smile:

From what I see in the database config parameter 5 is free entry, so it should :grinning: work.

Last idea: did you reinitialize the device? Delete the thing, delete the xml, start discovery and then wake up the device manually, you should see recreating the node.xml file.

Good idea, I will reinitialize and see what happens. :slight_smile: Thanks!

I have tried initializing the sensor 4 times. Every time, the OH2 habmin still does not let me change the Operation mode (even to the preset value of 10) - displaying the Error 400 - bad request. What is interesting I have noticed the customer functions shows twice, and I also cannot change those settings either.

That looks like PaperUI, although it should provide the same functionality, I would try HABmin when dealing with zwave devices.

1 Like

Thanks a ton Sihui, going the HABmin route (silly me for calling paperui habmin) worked like a charm. I had no idea paperui is not recommended for z-wave. The issue is solved.

1 Like

Which Firmware are you using?

I currently have 4 sensors, but only one (Firmware 1.24 ) works as expected, the other (Firmware 1.16 Hauppauge) don’t show motion changes. When motion happens, they update temp and luminance… But motion is not working.

I still don’t understand the custom function fully… Do I have to translate the Decimal number to Binary and enter the decimal no. into the field? And is the last no, always overwriting all other no. in custom function field?
Im asking because the custom function 20 never worked out of the box and after several tries on other custom function numbers it seems to work partly (no motion) with the 20 now. (I use habmin)

All settings are same between 4 sensors, only difference I could find is my firmware.
Customer function is set to 20 at all sensors and motion, Door contact is working at same time.

I used item file and also here everything is same…

20 is 0x14 which means binary report and super sensitive mode.