[solved] My.openhab, looks online saying offline

Hi everyone,

we have a strange situation with no idea what to do.

After registration on my.openhab.org I checked the function.

After moving the binding out of the addons directory

“/usr/share/openhab/addons# mv org.openhab.io.myopenhab-1.7.0.jar …”

2015-12-01 11:55:47.669 [INFO ] [.myopenhab.internal.MyOHClient] - Shutting down my.openHAB service connection
2015-12-01 11:55:47.773 [INFO ] [.myopenhab.internal.MyOHClient] - Disconnected from my.openHAB service (UUID = 00f0ba16-3bfe-421b-a76e-0a9ddd5057a9, base URL = http://localhost:8080)

As expected. Fine!

And after undo “/usr/share/openhab/addons# mv …/org.openhab.io.myopenhab-1.7.0.jar .”

2015-12-01 11:56:02.951 [INFO ] [.myopenhab.internal.MyOHClient] - Connected to my.openHAB service (UUID = 00f0ba16-3bfe-421b-a76e-0a9ddd5057a9, base URL = http://localhost:8080)

As expected, too! Okay, I think “Everything is fine!”

But on my.openhab.org it is saying offline. What the matter? The connectivity is given.

How to debug this? I googled the half day, an found many interessting threads. But nothing pushed me one step further with this task.


When i try to get the OpenHAB from external in my browser everything look fine, too.
I get a user|passwort htaccess-dialog. So the NAT is working.

Anything i forgot?

I am having the same problem.


Now we have this problem twice, within one day.
@Kai @teichsta Sorry for disturbing you, but is there anywhere a troubleShooting guide?
How is it possible to test single elements of this function.

kind regard

The right guy to ping here for help is @belovictor!

1 Like

Hi @belovictor,

do you have any advice for @tnemrap and me?
It’s actually confusion. All looks fine but the result ist bad.


1 Like

Hi @belovictor.

Is it possible to get my.openhab to work, or is there any other alternatives to integrate with IFTTT?



I would suggest first to switch to new my.openHAB bundle from 1.8 snapshot:
It uses a much better socket.io library then the 1.7 one and then it will be clear what’s happening.

Best regards,
Victor Belov


Can I run the 1.8 My OpenHAB addon with 1.7.1 Runtime or do I also need to Update the runtime.


You can use it on the 1.7.1 runtime!

Have tried with 1.8.

Here is my log

22:35:35.322 [DEBUG] [.m.i.MyOpenHABServiceActivator:28 ] - MyOpenHAB service has been started.
22:35:35.333 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:300 ] - setEventPublisher
22:35:35.335 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:135 ] - my.openHAB service activated
22:35:35.340 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:118 ] - config is null
22:35:35.345 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:176 ] - UUID file found at ‘/usr/share/openhab/webapps/static/uuid’ with content ‘removed’
22:35:35.350 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:228 ] - Secret file already exists at ‘/usr/share/openhab/webapps/static/secret’ with content ‘removed’
22:35:35.353 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:120 ] - UUID = removed, secret = removed
22:35:35.398 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:176 ] - UUID file found at ‘/usr/share/openhab/webapps/static/uuid’ with content ‘removed’
22:35:35.403 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:228 ] - Secret file already exists at ‘/usr/share/openhab/webapps/static/secret’ with content ‘removed’
22:35:35.409 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:162 ] - Version file found at ‘/usr/share/openhab/webapps/static/version’ with content ‘1.7.1’
22:35:35.567 [DEBUG] [.myopenhab.internal.MyOHClient:138 ] - Manager.EVENT_TRANSPORT
22:35:35.951 [DEBUG] [.myopenhab.internal.MyOHClient:143 ] - Transport.EVENT_REQUEST_HEADERS
22:35:37.575 [DEBUG] [.myopenhab.internal.MyOHClient:138 ] - Manager.EVENT_TRANSPORT
22:35:37.593 [DEBUG] [.myopenhab.internal.MyOHClient:143 ] - Transport.EVENT_REQUEST_HEADERS
22:35:37.875 [DEBUG] [.myopenhab.internal.MyOHClient:143 ] - Transport.EVENT_REQUEST_HEADERS
22:35:38.182 [DEBUG] [.myopenhab.internal.MyOHClient:157 ] - Socket.IO connected
22:35:38.187 [INFO ] [.myopenhab.internal.MyOHClient:224 ] - Connected to my.openHAB service (UUID = removed, local base URL = http://localhost:8080)
22:35:38.235 [DEBUG] [.myopenhab.internal.MyOHClient:143 ] - Transport.EVENT_REQUEST_HEADERS
22:35:46.419 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(EvasPhone), state = ON
22:35:51.071 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Buttons), state = Undefined
22:35:51.216 [DEBUG] [riptExtensionClassNameProvider:63 ] - Script actions have changed: HTTPActionService, AudioActionService, TransformationActionService, PingActionService, ExecActionService, MyOpenHABServiceImpl,
22:35:56.804 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Weather_Chart), state = Undefined
22:36:00.802 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Weather_Temperature), state = -0.8000000000000000444089209850062616169452667236328125
22:36:00.920 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Weather_Humidity), state = 70
22:36:00.992 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Weather_Temp_Max), state = -0.8000000000000000444089209850062616169452667236328125
22:36:01.157 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Weather_LastUpdate), state = 2015-12-07T22:36:01
22:36:01.861 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Weather_Chart), state = -0.8000000000000000444089209850062616169452667236328125
22:36:01.975 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Weather_Temp_Min), state = -0.8000000000000000444089209850062616169452667236328125
22:36:02.052 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:282 ] - store(Buttons), state = ON
And so on

I still get Offline


Hi @bee_GmbH

Have you solved the problem?


@tnemrap No, we also updatet the binding, but there is no change in hte behavior.
I anyone here with working my.openhab?

We have a second openHAB al test-Lab. The test-Lab ist the same config, like the live-system, but is online with 1.7.0 … Strange. We will now compare an give feedback!

We are online. The solution is as simple as it is.
Our Live-System is a clone of the lab. So even the secret an UUID was the same.
data went to our my.openhab.org-Lab Account. DOOOH!

I will try to regenerate my UUID and secret and change my account.



Now it works.

@bee_GmbH do you change the topic to SOLVED.


1 Like

Yeah! Fine.