[SOLVED] My.openHAB service not starting

Hello,
my.openHAB persistence and remote access used to work but now I have no access.
This is the start sequence.

2016-08-28 22:14:10.706 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.3).
2016-08-28 22:14:32.681 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-08-28 22:14:33.532 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-08-28 22:14:33.625 [INFO ] [.io.transport.mqtt.MqttService] - MQTT Service initialization completed.
2016-08-28 22:14:33.640 [INFO ] [o.i.t.m.i.MqttBrokerConnection] - Starting MQTT broker connection 'mybroker'
2016-08-28 22:14:37.502 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'mysql.persist'
2016-08-28 22:14:40.786 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'myopenhab.persist'
2016-08-28 22:14:41.758 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'weather.items'
2016-08-28 22:14:42.769 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'heating.items'
2016-08-28 22:14:43.901 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'main.items'
2016-08-28 22:15:07.327 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'main.sitemap'
2016-08-28 22:15:17.506 [INFO ] [penhab.io.rest.RESTApplication] - Started REST API at /rest
2016-08-28 22:15:23.940 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/openhab.app
2016-08-28 22:15:31.032 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'main.rules'
2016-08-28 22:15:37.016 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Available engines:
2016-08-28 22:15:37.187 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Oracle Nashorn
2016-08-28 22:15:37.196 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - jython
2016-08-28 22:15:37.227 [INFO ] [o.c.j.i.e.scriptmanager.Script] - Loading Script ruleslighting.py
2016-08-28 22:16:11.360 [INFO ] [o.c.j.i.e.scriptmanager.Script] - EngineName: jython
2016-08-28 22:16:20.617 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Engine found for File: ruleslighting.py
2016-08-28 22:16:20.750 [INFO ] [o.c.j.i.e.scriptmanager.Script] - Loading Script rulesmedia.py
2016-08-28 22:16:20.783 [INFO ] [o.c.j.i.e.scriptmanager.Script] - EngineName: jython
2016-08-28 22:16:22.687 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Engine found for File: rulesmedia.py
2016-08-28 22:16:22.722 [INFO ] [o.c.j.i.e.scriptmanager.Script] - Loading Script rulesprayertimes.py
2016-08-28 22:16:22.740 [INFO ] [o.c.j.i.e.scriptmanager.Script] - EngineName: jython
2016-08-28 22:16:26.436 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Engine found for File: rulesprayertimes.py
2016-08-28 22:16:26.571 [INFO ] [o.c.j.i.e.scriptmanager.Script] - Loading Script rulesheating.py
2016-08-28 22:16:26.590 [INFO ] [o.c.j.i.e.scriptmanager.Script] - EngineName: jython
2016-08-28 22:17:21.093 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Engine found for File: rulesheating.py
2016-08-28 22:17:21.157 [INFO ] [o.c.j.i.e.scriptmanager.Script] - Loading Script rulesmain.py
2016-08-28 22:17:21.176 [INFO ] [o.c.j.i.e.scriptmanager.Script] - EngineName: jython
2016-08-28 22:17:21.644 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Engine found for File: rulesmain.py
2016-08-28 22:17:21.685 [INFO ] [o.c.j.i.e.scriptmanager.Script] - Loading Script rulesmisc.py
2016-08-28 22:17:21.701 [INFO ] [o.c.j.i.e.scriptmanager.Script] - EngineName: jython
2016-08-28 22:17:22.057 [INFO ] [o.o.c.j.i.e.s.ScriptManager   ] - Engine found for File: rulesmisc.py
2016-08-28 22:17:23.012 [WARN ] [.o.c.p.e.PersistenceExtensions] - There is no queryable persistence service registered with the name 'mysql'
2016-08-28 22:17:26.339 [INFO ] [.b.a.internal.bus.AstroBinding] - AstroConfig[latitude=XX.XXXXXX,longitude=-XX.XXXXXX,interval=60,systemTimezone=Europe/London (GMT +0100),daylightSavings=true]
2016-08-28 22:17:29.469 [INFO ] [.b.a.internal.job.JobScheduler] - Scheduled a daily job at midnight for astro calculation
2016-08-28 22:17:32.413 [ERROR] [b.m.internal.MqttitudeConsumer] - Unable to calculate relative location for PresenceSadaf_PhoneMqtt as there is no lat/lon configured for 'home'
2016-08-28 22:17:37.505 [INFO ] [o.o.b.w.i.common.WeatherConfig] - ProviderConfig[providerName=FORECASTIO,apiKey=XXXXXXXXXXXXXXXXXXX]
2016-08-28 22:17:37.540 [INFO ] [o.o.b.w.i.common.WeatherConfig] - LocationConfig[providerName=FORECASTIO,language=en,updateInterval=15,latitude=XX.XXXXXX,longitude=-XX.XXXXXX,woeid=<null>,locationId=home,name=Home]
2016-08-28 22:17:40.729 [INFO ] [.o.b.w.i.s.WeatherJobScheduler] - Starting and scheduling weatherJob-home with interval of 15 minutes
2016-08-28 22:17:58.977 [INFO ] [.service.AbstractActiveService] - Nest Refresh Service has been started

I have checked the UUID and secret.
After reading into the my.openHAB docs I found references to some configuration needed in the openhab.cfg file but there is no section for my.openHAB in the file.

I am using the Oracle java on a rasperry pi.

I am looking for some pointer on where the problem may come from.

PS

I have run on debug and this is the tail end.

23:03:08.982 [DEBUG] [o.i.r.i.resources.ItemResource:205  ] - Received HTTP POST request at 'items/LivingRoom_WallLights' with value 'OFF'.
23:03:08.995 [DEBUG] [.mqtt.internal.MqttItemBinding:44   ] - Publishing command OFF to /LivingRoom/WallLights
23:03:09.018 [DEBUG] [o.i.t.m.i.MqttBrokerConnection:437  ] - Publishing message 15 to topic '/LivingRoom/WallLights'
23:03:11.337 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
23:03:11.358 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS
23:03:14.089 [DEBUG] [o.i.r.i.resources.ItemResource:205  ] - Received HTTP POST request at 'items/LivingRoom_WallLights' with value 'ON'.
23:03:14.103 [DEBUG] [.mqtt.internal.MqttItemBinding:44   ] - Publishing command ON to /LivingRoom/WallLights
23:03:14.137 [DEBUG] [o.i.t.m.i.MqttBrokerConnection:437  ] - Publishing message 16 to topic '/LivingRoom/WallLights'
23:03:14.606 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:281  ] - store(LivingRoom_WallLights), state = ON
23:03:14.624 [DEBUG] [.myopenhab.internal.MyOHClient:477  ] - No connection, Item update is not sent
23:03:14.823 [DEBUG] [.p.m.i.MysqlPersistenceService:412  ] - mySQL: Stored item 'LivingRoom_WallLights' as 'ON'[ON] in SQL database at Sun Aug 28 23:03:14 BST 2016.
23:03:14.833 [DEBUG] [.p.m.i.MysqlPersistenceService:414  ] - mySQL: query: INSERT INTO Item19 (TIME, VALUE) VALUES(NOW(),?) ON DUPLICATE KEY UPDATE VALUE=?;
23:03:16.587 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
23:03:16.604 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS
23:03:21.824 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
23:03:21.850 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS
23:03:27.032 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
23:03:27.053 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS
23:03:32.283 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
23:03:32.307 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS
23:03:37.563 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
23:03:37.579 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS
23:03:43.113 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
23:03:43.136 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS

And this is the my.OpenHAB starting sequence.

22:54:02.460 [DEBUG] [.m.i.MyOpenHABServiceActivator:27   ] - MyOpenHAB service has been started.
22:54:02.521 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:299  ] - setEventPublisher
22:54:02.532 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:134  ] - my.openHAB service activated
22:54:02.546 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:117  ] - config is null
22:54:02.585 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:175  ] - UUID file found at '/opt/openhab/webapps/static/uuid' with content 'XXXXXXXXXX'
22:54:02.608 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:227  ] - Secret file already exists at '/opt/openhab/webapps/static/secret' with content 'XXXXXXXXXXX'
22:54:02.622 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:119  ] - UUID = XXXXXXXXXX, secret = XXXXXXXXXX
22:54:02.696 [DEBUG] [.p.internal.PersistenceManager:146  ] - Initializing myopenhab persistence service.
22:54:02.833 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:175  ] - UUID file found at '/opt/openhab/webapps/static/uuid' with content 'XXXXXXXXXXXX'
22:54:02.847 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:227  ] - Secret file already exists at '/opt/openhab/webapps/static/secret' with content 'XXXXXXXXXXXX'
22:54:02.874 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:161  ] - Version file found at '/opt/openhab/webapps/static/version' with content '1.8.3'

Sorry, lots of debug…
Thanks

Yes, it’s there :sunglasses:
Right below the “General configuration” headline:

# configures the security options. The following values are valid:
# ON = security is switched on generally
# OFF = security is switched off generally
# EXTERNAL = security is switched on for external requests
#            (e.g. originating from the Internet) only
# (optional, defaults to 'OFF')
#security:option=

# the Netmask to define a range of internal IP-Addresses which doesn't require
# authorization (optional, defaults to '192.168.1.0/24')
#security:netmask=

And make sure you have at least java version 101 installed.

…and you should delete security related informations from your log before you paste it here (weather API key, UUID and secret for my.openhab).

Of course, I have masked the pertinent items.
Duh!!!

Thanks

Hello,

I have set my security to EXTERNAL and my netmask to 192.168.0.0/50
My java version is: 1.8.0-65

When I try the openhab app on my phone I now get the following error message:

2016-08-29 10:37:03.799 [WARN ] [org.eclipse.jetty.io.nio      ] - javax.net.ssl.SSLException: Inbound closed before receiving peer's close_notify: possible truncation attack?
2016-08-29 10:37:04.374 [WARN ] [org.eclipse.jetty.io.nio      ] - javax.net.ssl.SSLException: Inbound closed before receiving peer's close_notify: possible truncation attack?

Different error.
Some progress made but no quite here yet.

Thanks

That’s normal: my son’s iphone produces the same error, our android devices don’t.
I would not worry about that …

If you want to have access outside your wifi, you need to upgrade to version 101, as said before!

Sorry, but it has been written here a hundred times: THIS is NOT the latest java version. You need at least .101 to get my.openhab working!

@jaydee73, our master of java version checking :grinning:

:sunglasses:

Thank you all
Good progress
I did an apt-get upgrade on the rpi but that did not update java to v101 hence my confusion
I have now update java manually an I connect to my.openHAB and I can see my items and events on the cloud website. Great!!

BUT…

I can still not connect from my phone on remote URL
It tries. and then comes up with “HTTP error: OK”

On openhab log I get:

[WARN ] [e.jetty.servlet.ServletHandler] - /openhab.app
org.openhab.ui.webapp.render.RenderException: Sitemap 'main/rest/bindings' could not be found
	at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(WebAppServlet.java:115) ~[na:na]
	at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61) ~[na:na]
	at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:128) ~[na:na]
	at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60) ~[na:na]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:848) ~[javax.servlet_3.0.0.v201112011016.jar:na]
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:598) ~[org.eclipse.jetty.servlet_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:486) [org.eclipse.jetty.servlet_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1065) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:413) [org.eclipse.jetty.servlet_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:999) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.Server.handle(Server.java:350) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:630) [org.eclipse.jetty.http_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230) [org.eclipse.jetty.http_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:77) [org.eclipse.jetty.server_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:606) [org.eclipse.jetty.io_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:46) [org.eclipse.jetty.io_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603) [org.eclipse.jetty.util_8.1.3.v20120522.jar:8.1.3.v20120522]
	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538) [org.eclipse.jetty.util_8.1.3.v20120522.jar:8.1.3.v20120522]
	at java.lang.Thread.run(Thread.java:745) [na:1.8.0_101]

Any ideas?

Thanks

Do I still need to set my security as EXTERNAL?
And my subnet mask?

Because these are the only things I changed in the cfg file

Thanks

[SOLVED]
I set the remote url to https://my.openhab.org
and not https://my.openhab.org/openhab.app?sitemap=main
and I worked!!

I also reverted the default security settings and subnet as before

Thank you all for your invaluable help

Vincent

Hey @vzorglub, great you got your configuration working.

I would be interested to look into jpython rules and maybe switch over. Are they available somewhere or would you send them to me via PM?

Hi Thom,

I’ll be glad to send them over to you.
They are highly personalised to my needs, for example retrieve data from a csv file to create Muslim prayer schedules so I can play the call to prayer in the house at the right times. The Astro binding was not good enough… :slight_smile:

Rules heating is now deprecated, I used to use a server script to get Nest values as the Nest binding annoyed me with updates on the log every minutes but I have now reverted to the binding. I am only using the rule to store the previous day usage of the Nest Thermostat because that’s not available in the binding.

Sorry but what is PM?

Regards

Private Message, only viewable for the recipient.
Klick on the name you wish to send a private message to and klick “Message”.

1 Like

Hello all,

I have been trying to get my.openhab working for a few days without success applying all above.
I have updated java to V8 101. Secret and uuid were created ok at first run of the binding.
but my account keeps saying “your OpenHab is not online”.

In the Log, I see the following:
11:07:14.206 [DEBUG] [.m.i.MyOpenHABServiceActivator:27 ] - MyOpenHAB service has been started.
11:07:14.215 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:299 ] - setEventPublisher
11:07:14.218 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:134 ] - my.openHAB service activated
11:07:14.222 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:117 ] - config is null
11:07:14.226 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:175 ] - UUID file found at ‘/usr/share/openhab/webapps/static/uuid’ with content XXX
11:07:14.228 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:227 ] - Secret file already exists at ‘/usr/share/openhab/webapps/static/secret’ with content XXX
11:07:14.229 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:119 ] - UUID = XXX, secret = XXX
11:07:14.233 [DEBUG] [.p.internal.PersistenceManager:146 ] - Initializing myopenhab persistence service.
11:07:14.253 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:175 ] - UUID file found at ‘/usr/share/openhab/webapps/static/uuid’ with content 'XXX’
11:07:14.254 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:227 ] - Secret file already exists at ‘/usr/share/openhab/webapps/static/secret’ with content XXX’
11:07:14.256 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:161 ] - Version file found at ‘/usr/share/openhab/webapps/static/version’ with content '1.8.3’
11:07:14.389 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:20.277 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:20.283 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:22.269 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:22.273 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:26.271 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:26.274 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:31.422 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:31.783 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:36.970 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:36.972 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:42.179 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:42.184 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:47.360 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:47.363 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:52.589 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:52.591 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:07:57.740 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:07:57.743 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:08:02.898 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:08:02.907 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:08:08.060 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:08:08.062 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS
11:08:13.198 [DEBUG] [.myopenhab.internal.MyOHClient:137 ] - Manager.EVENT_TRANSPORT
11:08:13.200 [DEBUG] [.myopenhab.internal.MyOHClient:142 ] - Transport.EVENT_REQUEST_HEADERS

Please note that my hardware configuration is special as I am running a headless raspberry pi 3.0 behind a 3G router - does this make myopenhab unavailable or is there something else I can check.

Thanks a lot for any help you can provide.

Yves

Please note that the my.openhab service was shut down a couple of weeks ago.

The new openhab cloud connector is available instead:

for openHAB1: https://github.com/openhab/openhab1-addons/wiki/openHAB-Cloud-Connector
for openHAB2: http://docs.openhab.org/addons/io/openhabcloud/readme.html

Thank you so much for the prompt answer. This is a typo, I meant myopenhab.org.
BTW, my java version is
pi@raspberrypi:~ $ java -version
java version "1.8.0_121"
Java™ SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot™ Client VM (build 25.121-b13, mixed mode)

and I have installed both openhab 1 and the binding through apt-get.

Yves

Update - installed the Cloud Connector binding you suggested, regenerated uuid and secret, updated the account.
and it WORKED !!!

thanks a lot.

Yves

1 Like