[SOLVED] Newbie - IFTTT setup

Tags: #<Tag:0x00007f616e37d3c8>
  • Platform information:
    • Hardware: RaspberryPi 1, Model B
    • OS: openhabian v1.4.1
    • Java Runtime Environment: OpenJDK Runtime Environment (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 1.8.0_152-b76)
    • openHAB version: v2.3.0.1
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

So, newbie to OpenHAB here :slight_smile:

  • I’ve installed Openhabian on my RaspberryPI.

  • I’m able to connect to http://192.168.1.107:8080/start/index and access PaperUI ok.

  • I’ve installed Service “openHAB Cloud” successfully, and have it connected successfully to my myopenhab.org - it shows as “online”.

  • I’ve created two dummy Switch Items in PaperUI. In the OpenHAB Cloud configuration, I have ticked the two dummy items to “expose” them.

I then logged into IFTTT, and have connected that to openHAB:
But trying to setup an action, it just doesn’t find those Items I’ve exposed:
image

So, can anyone explain what I’m missing here? No doubt it’s something very simple, that I’ve completely missed or misunderstood :slight_smile:
Thanks

You need to change the state of these two items at least once before they are actually exposed to myopenHAB
Switch your two items ON and OFF an few times and then try again after a minute or so

Ah ha!! Thanks Vincent!
That worked :slight_smile:
Hmmm, would be nice if ticking the “expose” option did whatever the initial toggling is doing.

Brilliant, have now got it working anyway, and can turn on my SmartThings gear via IFTTT :slight_smile: