[SOLVED] Nortek USB combo zigbee controller not working

I just started a new OH install on a RP 3b+ with openhabian and a Nortek combo zwave and zigbee USB controller. The zwave controller works fine on /dev/ttyUSB0 The zigbee portion of the controller is on /dev/ttyUSB1 and I have confirmed this in the OS. However when I add the zigbee controller (ember type) in OH, it shows “offline - communication_error”. The debug log shows “serial port: port /dev/ttyUSB1 does not exist” However I know that it does and is assigned to the zigbee portion of the device in the OS. I have made the change to the line in the file regarding Java and also made sure that the OH user is in the tty and dialout groups.

At another user’s suggestion I changed the folowing zigbee controller options in OH: PAN ID =auto, External PAN ID = auto, Network Security Key = auto, Link Security Key = zigbee alliance. I then rebooted the RP 3b+ and still have the same errors. OH also changed all the settings and none of them are set to “auto” anymore.

  • Platform information:
    • Hardware: Raspberry Pi 3b+
    • OS: Openhabian
    • Java Runtime Environment: uknown
    • openHAB version: 2.5, current milestone as of 11/23/2019

You did not read the documentation closely and forgot to set the EXTRA_JAVA_OPTS.

I DID make that change. That is what I meant in my post that I made the change to the file regarding java… This line was added to the file /etc/default/openhab2:


Sorry. A few people have missed that lately and got the same error.

Ok I have that stick on my test system but have not tested with Milestone 5. I assume you are not running an unstable snapshot version. My test system is a Pi 3B+.

Are you running any other bindings that use a serial port? Some people seem to be battling some conflicts.

A user on another forum suggested that the order of steps strangely somehow makes a difference. They suggested adding the Java Option line to the file and installing the Zigbee binding before plugging in the Nortek USB combo controller. Then start with Zigbee and add the controller for it first. Then once Zigbee works, add the Zwave binding and controller.

I’ve reinstalled a fresh openhabian and am trying that to see if it will work.

1 Like

This solved the issue. Zigbee and Zwave are now both working.

that is a new one… very interesting
I actually own one of these things…I install zigbee first all those months ago

That is my test stick but I mainly use Z-Wave I do not recall what order I used when testing ZigBee.