[SOLVED] OH 4.1.0 textual configs are not reloaded after a change (files are on a mounted SAN storage)

  • Platform information:
    • Hardware: x86_64 / 8GB RAM / SSD and mounted NAS storeage
    • OS: CentOS Stream release 8
    • Java Runtime Environment: OpenJDK 64-Bit Server VM Zulu17.46+19-CA (build 17.0.9+8-LTS, mixed mode, sharing)
    • openHAB version: 4.1.0

I just migrated from OH3.4.5 to OH4.1.0. Mostly, it went well, just a few minor things to fix.
But since OH4, the update of the textual configuration files does no longer trigger in OH.
Means changes on items, rules or sitemaps require now a restart of the obenhab service.

My items/things/rules/sitemaps are stored on a mounted SAN storage.


//     /nas/openhab           cifs    _netdev,credentials=/root/nas,uid=openhab,gid=openhab,file_mode=0770,dir_mode=0770,vers=2.0  0 0

and the openhab directory (/etc/openhab) has a softlink to the mounted fs

# ls -al /etc | grep openhab
lrwxrwxrwx.   1 openhab openhab     13 Jul 27 15:34 openhab -> /nas/openhab/

On OH3, updates on the textual config files triggered an event in openhab.log file and the changes were working without a restart of the OH service.

I found here a hint to a similar issue (Textual configuration files are not reloading):

I have not yet tested, if it is working when not using the mounted NAS share, but I think there must be something changed, because in OH3 this was working fine.

Known issue with symbolic links in a library OH relies on.

1 Like

@Lolodomo thanks for spotting the thread, and sorry to ask already discussed topics

Probably I have to change the way I store my textual configs. Actually I’m migrating all my jython rules, and without this feature It’s a pain to test the migrated rules …

I post here the link to the reported issue in the “external” library:

Just a small update. I solved it by mounting the NAS FS in /etc/openhab instead /nas/openhab (and removed the simlink from /etc/openhab to /nas/openhab).