[SOLVED] OH2.5 -> OH3: Homekit Switchable does NOT work anymore?


so after migration and enourmous homekit problems, I began with a clean install of the latest unstable snapshot 3.1 on openhabian. Before my homekit and OH installation was running on 2.5 without any issues, almost all my usage goes down on switchable switches with homekit coming from OH.

Now, after 6 hours of ongoing troubleshooting I find that the “switchable” is sometimes not working?

Accidently I found this post, otherwise I have had written another post in the forums already:

Can someone confirm this behaviour?

WORKS: Switch leaksensor "Leak Sensor" (gLeakSensor) {homekit="Lighting"}

DOES NOT WORK: Switch ComingLeavingHome "Coming-Leaving Home" ["Switchable"] but was working before in OH2.5

This then results in the error of only the openhab bridge being an accessory with is completely unsupported in the home app as long as there are 0 Created items for Homekit. See here my post:

OH3 HOMEKIT BUG?: openhab Bridge only discoverable as accessory and 0 items created for HomeKit? - #8 by Skaick

1 Like

So in this case this does work: Switch ComingHome "Coming Home" {homekit="Switchable"}

Read the docs. Legacy tag support was already deprecated in 2.5.x and has been removed in OH3.

Thank you, I have read left right and center but did not get this. But does that mean that a normal switch is not supported anymore in homekit from openhab? Thank you for your notice

You have to use homekit="…" tags.

1 Like

Thank you, it finally worked :slight_smile:

1 Like