[Solved] OH3 Missing Blinds badge on location page

Hello,
I’ve switched my prod environment to OH3 with a clean install via apt on a raspberry 4.

I’ve started configuring my rollershutters (shellies switch 2.5 via shelly binding) in the model creating equipment from thing.

The equipment has the semantic tag “blinds”, the underneath point (roller control) has “control” as semantic tag.

Nearly every room has one rollershutter but none of them are showing the “Open blinds” badge.
Temperature and humidity badges are working fine.

Am I missing something? Maybe the point must have a specifi semantic property?

Thank you!

Equipment screenshot:

Point screenshot

Hello! I was wondering about the same thing. Hard to know which classes to choose to activate all the different badges that exist. So far this is what i use and found to be working. I guess the Semantic Class of the Equipment Group is also important for the symbol to show up. Below is just the Item classes.

The thing that I can’t solve is how to show the correct state of Open and Close. Right now both my Lock and my Blinds are showing OPEN when they are actually closed and vise versa. I’m guessing the Metadata tag State Description is the thing that could fix this but I don’t know how to configure that.

Open Blinds:
Semantic Class: OpenState
Semantic Property: None

Lights On:
Semantic Class: Switch
Semantic Property: Light

Lock:
Semantic Class: OpenState
Semantic Property: None

Screens Powered On:
Semantic Class: Switch
Semantic Property: Power

Speakers Powered On:
Semantic Class: Switch
Semantic Property: Power

Presence:
Semantic Class: Status
Semantic Property: Presence

Temperature:
Semantic Class: Measurement
Semantic Property: Temperature

Humidity:
Semantic Class: Measurement
Semantic Property: Humidity

1 Like

These are defined in [Design/Spec] Location semantic cards: header · Issue #556 · openhab/openhab-webui · GitHub which should be mostly correct (and should make its way to the docs). Otherwise please file an issue.

1 Like

Thank you both!
Solved!

Anyone managed to get the warning symbol showing? I Can’t. I’ve tagged a water sensor as Point Alarm but all though the sensor turns ON no symbol pops up in the UI.

warnings

Oh fantastic. I will start looking at that page!

/Erik

Thank you this was very helpful!

Just a suggestion, could you guys somehow link the specs for all those advanced config options somewhere prominent either in the model config or when you press the edit button (top right corner) of the ui?

Edit: also I would love to have a solution for my power outlets. I don’t want to handle them as lights, so at the moment I just wrongly labeled them as HVAC so that I get a different icon.

I don’t get this to work with my items:

Group                      gBalconyBlinds       "Rolladen Balkon"                                    (gBalcony)                                                                ["Blinds"]
Rollershutter              Z_RollerSh           "Rollladen [%s %%]"                                  (G_Num,Group_HabPanel_Dashboard,gBalconyBlinds)                           ["Control", "Level"] 

Which result in Equipment (which is in location Outside/Balcony:

image

Controlling the rollershutter works perfectly

Using OpenState instead of Control, Level does not change anything.
The badge won’t show up

I am struggling with this as well.
By the way:
Does is make a difference, if I use .map files in my items file and transform ON to an (German)?

I have blinds working with Equipment Blinds and OpenState, it displays the badge when the it has value 0 (Open).

Thanks, Michael.
That’s what I tried.
Are you running OH 3.0 stable or SNAPSHOT 3.1?

Latest Snapshot

Group                       geEliasRoom_Rollershutter                "Elias Rullgardin"                           <blinds>         (glEliasRoom)                                                                                                             ["Blinds"]
Rollershutter               EliasRoom_Rollershutter_Control          "Elias Rullgardin"                           <blinds>         (geEliasRoom_Rollershutter, gsBlinds, gfSimulation, gpC)                                                                  ["OpenState"]                     {channel="zwave:device:e8581bab06:node2:blinds_control", ga="Blinds" [ name="Rullgardin", roomHint="Elias Rum" ]}

image

Thank you - that’s the exact same config I use (even the zwave protocol :wink:
I guess I need to upgrade then…

Is not this inverted

image Locks

Point_Status or Point_Control* isPointOf Equipment_Lock hasLocation (the location)
If no matching item found:
Equipment_Lock hasLocation (the location)

If all results have the state CLOSED or OFF: display image

If any result has the state ON or OPEN: single result, display the icon image; multiple results, display the icon and the count.

Both Verisure and VolvoOnCall binding ON is locked?

I am not sure what you mean (typos?)

If my XC60 is locked, the switch is ON

So, you mean you use a Lock (equipment) within your Car (equipment as well).
Does this even work (equipment in equipment instead of equipment in location)?

By the way: the Blinds Badge is working after a restart.
They are shown, when not 0 - which is fine for me, because the badge icon looks like a lowered rollershutter anyway :slight_smile:

Biggest issue for me is that when frondoor (verisure) is locked (ON) the badge shows unlocked.
But i have some cases with Equipment in Eguipment like Pool / Poolpump and it will be Car / Lock

And for me i also want to have blinds inverted, for me it is more interesting when blinds is down.

Alright, will try this as well.

That’s the case right? At least in my case:
The badge is shown when rollershutters are down (not fully up = 0) and disappear when fully up.

I have setup my blinds as 0 Up and 100 Down should i revert my numbers?