[SOLVED] PaperUI missing


(Tim Roberts) #1

I’ve tried to reinstall my IDE and selected the openHAB dev & openHAB addons. Resolved the issues and the system now starts up. However - it’s missing all the UIs (especially paperui) - what needs to be included to get that to run?


Eclipse IDE PaperUI missing
(Tim Roberts) #2

Little closer (had to go through rebasing and a few errors on my part) - I now have the paperui, basic, classic UIs on the dashboard. The basic/classic work fine but when I click on paperui I get a 404 - can’t access /paperui/index.html. In the log I see 2019-02-13 15:00:53.775 [INFO ] [o.ui.paper.internal.PaperUIApp:47 ] - Started Paper UI at /paperui but that’s it for any paperui log messages. Not sure what I’m missing here…


(David Graeff) #3

The OH buildsystem is in the process of being changed. Paper UI usage was fixed just today. But it could be that you need to run maven on the command line for Paper UI to actually build. Or head to the paper UI directory and use npm install and npm run build (I think) to build it manually.


(Tim Roberts) #4

Thanks - I was thinking along the same lines (noticed there was an index.html.template rather than an index.html) - just wasn’t sure how to properly build it. I’ll try that and see what happens…


(Tim Roberts) #5

Actually just used mvn install and it built the ‘web’ directory correctly. All good now…


(Bob Raker) #6

I was able to install PaperUI from within eclipse. From the menu select Run > Run Configurations. The in that dialog select Maven Build > PaperUI Setup. It takes a while to install.