[SOLVED] Persistence not working at all (persistence bundle/service not started?)

  • Platform information:
    • Hardware: virtual Machine on ESX Server
    • OS: Suse Linux Enterprise Server 15
    • Java Runtime Environment: zulu8.33.0.1-jdk8.0.192
    • openHAB version: 2.3.0
  • Issue of the topic: Persistence is not working, I can’t even see a persistence bundle/service started in logs
  • Please post configurations (if applicable):
    • Items configuration related to the issue
      Switch Debug_Persistence "Debug Persistence"
    • Services configuration related to the issue
persistence = mapdb

Persistence is listed in PaperUI as installed, logs didn’t show any error during install

Strategies {
	default = everyChange

Items {
	Debug_Persistence : strategy = everyChange

  • If logs where generated please post these here using code fences:

Persistence file get’s loaded (at start) or refreshed on change:

[INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'mapdb.persist'
[INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'mapdb.persist'

Debug item works too:

[ome.event.ItemCommandEvent] - Item 'Debug_Persistence' received command ON
[vent.ItemStateChangedEvent] - Debug_Persistence changed from OFF to ON
[ome.event.ItemCommandEvent] - Item 'Debug_Persistence' received command OFF
[vent.ItemStateChangedEvent] - Debug_Persistence changed from ON to OFF

My observation: In this topic I can see that log should contain “MapDB persistence bundle has been started.” and “store called for […]” which I don’t have.

What am I doing wrong? Maybe just a typo?

Thanks in advance

Got it: You have to enable DEBUG logging for persistence to see those entries:

openhab> log:set DEBUG org.openhab.persistence.mapdb

This were more errors at once…
I wanted to debug why OpenHAB doesn’t log to my InfluxDB, which I couldn’t figure out, so I tried an “easier” persistence to debug that.

Now I also found my error with not writing to InfluxDB: I tried Design Pattern: Group Based Persistence and used all groups - but in never declared the groups. OpenHAB doesn’t warn in that case, it just doesn’t work and you don’t know why.