[SOLVED] Possible database error resetting timeout to 0

Hello all

I have an open question:

And wonder if I have the same database problem as this question had:

Doesn’t matter what I do as soon as OH writes the data it sets the timeout to 0.

How do I fix this?

Can I fix this?


I don’t think it’s the same thing as the other thread - in the other thread the issue looks like it was that configuration wasn’t showing up in HABmin at all - you seem to have the configuration parameters?

Often this sort of thing is caused by the size of the parameter being set incorrectly - in this case, the database appears to be consistent with the manual, but it is a little strange that the manual states the maximum value is 255, but it’s 2 bytes, so there might be an error here…

What to do…

Can you provide a debug log. Delete the nodeX.xml file for this device, restart the binding, wake the device up a couple of times until HABmin shows the green light, then set the configuration… I’d be interested in this log…

Uploaded the existing XML file to the database.

When I get back tonight I’ll generate the log and post.



Steps taken:

  • Stop OH
  • Delete node3.xml
  • Restart OH
  • Open habmin and watch devices
  • wake up, trip sensor, wake up until it went green in habmin
  • change timeout to 10
  • rename sensor
  • rename location
  • wake up, trip until it wrote the timeout
  • when the timeout went white from yellow - the time went from 10 to 0

All zwave log entries are attached.
2016-02-03 ZWave Debug.json (276.2 KB)


Any thoughts on this?

The sensor still reverts to 0 when trying to set the timeout.


Sorry - it was a busy week and I missed this :frowning:

Process Message = 01 0B 00 04 00 03 05 70 06 01 01 00 80 
NODE 3: Sending REQUEST Message = 01 0D 00 13 03 06 70 04 01 02 00 0A 25 16 AA 
NODE 3: Sending REQUEST Message = 01 0A 00 13 03 03 70 05 01 25 17 A0 
Receive Message = 01 0B 00 04 00 03 05 70 06 01 01 00 80

The messages above are the relevant messages. The first one we’re sending the SET - and it’s incorrect, but I don’t know why… The problem is that the length is set to 2 bytes, where it should be 1 byte (as can be seen in the receive messages at the top and bottom :sunglasses:).

What I don’t know is why it’s 2 bytes! The database shows it should be 1 byte, and the init message that’s received at the top of the dump above is also showing 1 byte… Can you post the XML file for this device please.

No worries, truly appreciate everything that people pour into this project.

You want xml file for this node here? Or the database?

Here’s the file!

node3.xml (5.2 KB)

Here is good - I might add it to the database as well, but I want to actually have a look through it :slight_smile:

Thanks - ignore my last response - I didn’t see you’d sent this in the meantime…

Ok - that’s interesting… I uploaded your file to the database, and it told me it was a WAPIRZ.

Certainly the device IDs also point to this - I have no idea what these two devices are (@xsnrg any comment - I think you have the WAPIRZ?).

Now, the point here is that in the WAPIRZ, the size of parameter 1 is 2 bytes, so this would likely explain the issue…

Yes, it is the WAPIRZ, it’s from Home Depot.

Ah - ok, I thought it was the ZWN-BPC that you had (based in the info in the first message)… Ok, then that probably explains the problem then… I’ll let @xsnrg comment though before I think about changing anything… Jim - does this work on your device?

from the doc for the device:

Parameter 1: Re-trigger Wait TimeBy default, to conserve battery life, after the WAPIRZ-1 detects motion it cannot be re-triggered by motion again for 3 minutes. Each time motion is detected (even during this wait time) the 3 minute timer starts over. The length of the re-trigger wait time can be adjusted with this setting.• Parameter No: 1• Length: 2 Bytes• Valid Values = 1-255 (minutes). Default is 3

However, clearly 1-255 fits inside of size 1, so if the device is saying it is size 1, let’s change the size to 1 from 2 and assume the doc is wrong.

I won’t be able to check it until tomorrow, but have no problem trying this.

@chris Sorry about the confusion… In my original post I did list the device, but here I only referenced my post as well as the one that seemed like the same issue.

@xsnrg Thanks for the follow up.

I did just edit the parameter in the database and it’s waiting for approval.


It has been approved. @chris , when an approval happens, does the requester get a notification?

Haven’t received a notification, but I still had the page open and saw your comment.

Changing my setting now; thanks!

@p912s Well, the change is not immediate. @chris will have to include the DB change in the next release and then you will have to upgrade to it.

@xsnrg Thanks for the follow-up.