[SOLVED] Problem moving from Stable to Snapshot

Trying to move from stable to Snapshot, in order to ascertain whether Z-Wave binding has been updated for a specific device recently added into the Device Database:

First, obtained a clue as to the latest Snapshot from here which alludes to “3.00 Snapshot”:

Then flollowed this guide, although I note is more than a year old so prob out of date?

And rebooted. Then discovered I’m still on 2.5,1 and not a 3.00 snapshot?

[18:05:48] openhabian@openhab:~$ dpkg --list | grep openhab
ii  openhab2                       2.5.1~20200106043501-1              all          openhab2
[18:15:08] openhabian@openhab:~$

Clearly I’m doing something wrong, prey tell me please.
Could it be that I should be modifying apt-get sources ? only the openhabian-config tool was used and doesnt seem to have made any difference.

You may want to be careful and NOT use the latest snapshots as they are announced to not work: see: Development of openHAB 3.0.0 and 2.5.x where Kai announces that it will be a few weeks before snapshots are becoming usable.

As announced (see above post) add-on updates will become available soon too. Until then, you likely will need to know where to find and where to dop the jar files of any binding you want to update to the unstable version.

Good call. Appreciated. Although I’m not clear how to obtain that which I seek so will add a comment to one of my other posts, for help.

EDIT: Chris has replied and I have a clearer understanding of how to get the latest version and when. Thread Solved.