[SOLVED] Solved: Aeotec Multisensor temperature spikes

Tags: #<Tag:0x00007f616de03b68> #<Tag:0x00007f616de03a78>

I’m running openhabian with OH 2.4 and I have 3 aeotec multisensor 6 that report temperature. What I’ve noticed is that the sensors report a Celsius temperature once a day causing a spike in my chart. The odd thing is that it apears to happen at the exact same time every day for each sensor. The sensors are all set to report fahrenheit. My OH global setting is for imperial units. You can see what happens in the image. The outside temperature is reported by the WU binding. Any ideas would be greatly appreciated.

. As a workaround, I though I might just set them all to celsius and use a JS transformation to Fahrenheit, but if there is a real fix, I’d like to try that first.

Yes and then stick to celsius like the rest of the world… Just kidding
It looks like your way out

1 Like

On which side of the road are you driving??? :grinning::grinning:

The wrong side of course
But then it doesn’t really matter we are on a bloody island

What matters is units, like when American rocket scientist crash a probe because inches were used not metres… Don’t get me started on that one

1 Like

@lazloman sorry off topic but how do you like your Aeotec multisensor 6? How well does it work in openHAB? What channels get discovered? And most important, how does it do at reporting motion? fast, does it report no motion as soon as person leaves area or is there a cool down period where it doesn’t report. Are there any adjustments or configuration options and how does openHAB handle them?

I have seen spikes but the story was a bit different, see

That was long time ago, though. My persistence settings are currently such that it is highly unlikely to record the spikes…

Do you have the latest firmware?

Have you converted to use UoM for your Temperature items. For example

Number:Temperature TempItem "Temp [%.1f %unit%]"

If not, the MS6 will give you whatever units it feels like at the time it sends the temp update. At least that was my experience with the MS6.

Except for this issue which only occurred after the upgrade, they work pretty well. Those that are main powered report accurately and regularly as values change. Those on battery only report every 10 minutes as I have them set for that. For motion, they report as soon as a room is entered. They continue to track motion until no motion is detected for 10 minutes. This value is adjustable.

I love mine (have 7 of them, 2 on main and the rest on battery). I use them for Temp, Humidity and Luminance. I don’t use them for motion; they are not quick enough for me. I use the HUE Motion sensors instead.

Rules:

  • Tied to Luminance and the Hue Motion sensor to turn on inside and outside lights
  • Tied to Humidity to turn on fans and dehumidifiers
  • Tied to Aeotec motion ONLY to trigger some sort of presence in the house to set the Nest status (home/away)

Items:

Group 	 BasementMotion <motion>
Switch   BasementSensor_Motion_Alarm	        "Motion [%s]" 										(BasementMotion)				{ channel="zwave:device:ffffffd1ffffffb2ffffffdbffffffad:node7:alarm_motion" }
Number 	 BasementSensor_Temp 			"Temperature  [%.2f]" 								(BasementMotion, Temperatures)	{ channel="zwave:device:ffffffd1ffffffb2ffffffdbffffffad:node7:sensor_temperature" }
Number 	 BasementSensor_Humidity 		"Humidity     [%.0f %%]" 							(BasementMotion)				{ channel="zwave:device:ffffffd1ffffffb2ffffffdbffffffad:node7:sensor_relhumidity" }
Number 	 BasementSensor_Luminance 		"Luminance    [%.0f Lux]" 							(BasementMotion)				{ channel="zwave:device:ffffffd1ffffffb2ffffffdbffffffad:node7:sensor_luminance" }
Number   BasementSensor_Battery 		"AC     	[%s %%]" 								(BasementMotion)				{ channel="zwave:device:ffffffd1ffffffb2ffffffdbffffffad:node7:battery-level" }
DateTime BasementSensor_Update			"[%1$tm.%1$td.%1$tY %1$tH:%1$tM]"   <clock>			

Best, Jay

The binding defines this type for the temperature now, Number:Temperature. I don’t believe this was the case before. I’m pretty sure it was just Number. The docs say this type will convert the value returned from the binding to the UoM as set under System. I changed my sensors temperature items to this type and have not had a spike yet, but I’ll give it a day or so to see what happens. It also seems that the UoM of the sensor is not set in the binding anymore, just threshold values are set. @mhilbush @ssalonen @vzorglub

So, no more spikes since Monday evening after I changed the item type. I’m going to consider this resolved now.

2 Likes

Hi, every now and then (like once per 48h maybe), I get measurements that are completely out of bounds, e.g. 0 or 20,000 degF. See example history charts attached. Does anybody have an idea what causes them or how they can be prevented?
9Apps Showbox