[SOLVED] Starting openHABian configuration tool

Tags: #<Tag:0x00007f6171b94d10>

I’m trying to start the openHABian configuration tool on my plainvanilla openhHAB 2.3.0 installation.
After accessing the console via ssh and putting in the command “sudo openhab-config” the system asks for the password.

I’m using the password mentioned in the documentary but the login fails.

Does anyone has an idea what I’m doing wrong?

If you’ve SSH to the console and you get the welcome to Openhabian screen then the password you used to get this far should be the same to access the config tool.

Oh wait, try sudo openhabian-config not sudo openhab-config

1 Like

Unfortunately is doesn’t work using the command “sudo openhabian-config”.
Any other ideas?

What do you get displayed when entering “sudo openhabian-config”?

After typing the “sudo…” command I’ll be asked for the password and after typing it in I’ll get the following line in the console: “Error executing command: login failed”

As mentioned before, the installation is plain vanilla and I’m using the standard sudo password like written in the documentary.

Here is a screen shot when SSH to pi. The first attempt I used the wrong password, see the output “Sorry, try again”
Second attempt I typed in the wrong thing, see the out put “command not found”
Screenshot%20at%202018-08-21%2012-15-09

From where you are entering sudo openhabian-config, does your terminal look the same as the above? Just asking to make sure were on the same page.

This is my starting screen after logging in. Looks like a little bit different.

This screen shows when you are on Karaff! You should use “sudo openhabain-config” before entering “ssh -p 8101 openhab@localhost” !!

OK, maybe that’s the issue…
I’m not working directly on the pi, instead I’m using putty to get remote access and this screen appears after logging in. What do I have to do to get to your starting point?

Just the connection via putty!

Is this the right place?

No, after connecting with putty. You should get a window with “login in:” followed by the question for the password. After that is completed you can enter the above!

I used to do this a few times. But after executing sudo with the default password I’ll get an access denied.
Am I doing the same process like you mentioned?AccessDenied

If you are getting this display ( which is the Karaf console) directly from putty you are doing (somehow) two steps in one move.
In there I would use “logout” to leave the console(not sure if the whole window would close in your case).
When I’m at home I’ll check on my pc.

1 Like

Have you tried to access the terminal without proxy, just a normal session? Here’s an example where you enter your IP or host name (of openhab server) with port 22 and select SSH.

@H102 it works and now I’ve got access to the openHABian Configuration Tool!.
Thanks for your support and also thanks to @opus for your support!