[Solved] Stopped openhab2.service, also stop mosquitto broker and influxdb

My main system runs on Rpi3B+ with openhabian 2.5.6.
I have originally installed Influxdb and Mosquitto from openhabian-config. And just now I discovered, when I stopped the openhab2.service, it also both mqtt broker as well as influxdb…
How can I start these two services manually or prevent them for stopping ?


sudo systemctl start mosquitto.service

restart your mosquitto when openHAB is stopped?

Not sure about Influxdb, as I’m not using it, but see with

systemctl list-units
1 Like

I tried that. It doesnt seem to start… Or. I cant access the broker from another system (same LAN).

Sorry my mistake… The above suggestion do work. MQTT now running… I simply forgot the .service part. :frowning:

Oh good :slight_smile:

As Influxdb is an openHAB persistence I suppose it is tied to openHAB itself running though ?!?

Naah Influxdb is a seperate database service…

What I´m trying to do is:
Having influxdb running on my old Rpi3b+ which untill a few minutes ago ran my main openhab system.
Thats IP

Now I have ported (rebuild) everything to my new openhab system, running on a Odroid C2, and ofcouse a new IP
On this system I have NOT installed influxdb (yet), cause I wanted to continue using the dababase on my old Rpi3B+.
I do have installed the influxdb persistense in the new openhab system. And I have the influxdb.cfg which points to the old IP… (username/pw and database is still the same)…

I really wonder howcome this isnt working. It should…

So is Influxdb a System service as well? Does

systemctl list-units | grep influxdb

come up with anything? If so, you can (re)start it just the same as Mosquitto above.

Yep, its running just fine:

 influxdb.service           loaded active running   InfluxDB is an open-source, distributed, time series database

Then someone with Influxdb experience might know why the new system’s Influxdb persistence doesn’t seem to connect to the remotetly assigned Influxdb service.

Only thing I could think of here now is that you might have set firewall rules preventing the new system to connect.

Cant be firewall, cause Grafana (which is running on my Windows server) has been accessing influxdb database without any issues for at least one year…
Its a bit odd.
Hopfully someone knows, or I have to spend some time copying the database to a new local install of influxdb. (My plan was to wait with this, untill I have the new system all up running).

I got everything to work… I made a stupid mistake (again) where I forgot to copy the persistens file from my original setup to the new setup…
So, I guess the solution to the orignal question is posted by Hans in post #2
Thanks for your help Hans!.


Glad you got everything working again :slight_smile: