[SOLVED] Things lost from PaperUi

Hi All,

I have a huge issue:

I deleted the cache this morning as described here:
https://community.openhab.org/t/clear-the-cache/36424 with the openhab-cli clean-cache command.

Afterwards all things created via PaperUI were gone (i.e. Homematic, Harmony, etc.)

I already tried to clean cache manually -> same result.

I also follow the instruction from [SOLVED] All Things lost from openHab and copied the files from json backup -> same result.

I receive the following event at Startup - but only once after cleaning the cache:

    10:21:07.986 [ERROR] [.core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-http1, openhab-binding-hue, openhab-persistence-mapdb, openhab-misc-market, openhab-misc-openhabcloud, openhab-transformation-javascript, openhab-binding-network, openhab-binding-amazonechocontrol, openhab-ui-habpanel, openhab-transformation-jsonpath, openhab-binding-harmonyhub, openhab-binding-mqtt, openhab-persistence-rrd4j, openhab-ui-basic, openhab-transformation-map, openhab-binding-ntp, openhab-binding-yeelight, openhab-binding-fritzboxtr0641, openhab-binding-astro, openhab-binding-homematic, openhab-binding-expire1, openhab-ui-paper': Error restarting bundles:
            Could not resolve module: org.openhab.binding.amazonechocontrol [220]
      Another singleton bundle selected: osgi.identity; osgi.identity="org.openhab.binding.amazonechocontrol"; type="osgi.bundle"; version:Version="2.5.0.Beta_03"; singleton:="true"

All the things I created manually (i.e. Mqtt) are only and active.

No idea what happend - any inspiring ideas to solve this problem are appreciated.

Are you using a Raspberry Pi?
I had something like this once a d my SD card was getting corrupt.

1 Like

Yes, I am using Raspberry, but it should be extended to external HDD.

Yes sounds like something else happening. These are the times I suggest a backup and redo.

I agree with @Marijn_Oudijk this smells of corrupt filesystem.

Do I need to do a full restore or only partial?

But when corrupted filesystem, why only PaperUI things and not the rest as well?

That’s a question above my knowhow, but in my situation all things were gone. When adding them again the items were back also.

But I can not add them - they do not appear at the discovery page.

It seems that the bindings do not connect correctly.

Usually only individual files become corrupted. If your Things JSONDB file became corrupted then it would only impact Things.

When ever something doesn’t work, the first place to look should always be the logs. Do you see errors in the logs?

If you are willing to run the risk you should have automatically created backups of your JSONDB files that you can try to restore and see if it’s just a problem with your one file or a wider issue. The logs would be informative.

The automatically created backups are in /var/lib/openhab2/jsondb/backups.

1 Like

I recovered the jsondb folder from backup and since then it is working.
I could not see any errors in the log - any other indication for corrupted file system, which I could look for?

But I take your concern about corrupted file system seriously and will update my backup strategy. I noticed that my existing backup only backup openhab (amrecover) but not the entire system. Any advises on backup solutions for Raspberry in combination with Openhab?

openHABian comes with Amanda. Others just unplug the SD card periodically and take an image.

1 Like