[SOLVED] Trouble removing (deleting, excluding) previous ZWave devices that I paired to Nortec HUSBZB-1 USB controller

openhab2
zwave
Tags: #<Tag:0x00007f014908a6f0> #<Tag:0x00007f014908a498>

(Todd Mathewson) #1

So I have been a Vera user for years and have grown dissatisfied with the VeraPlus no matter how I try to utilize it. Vera is quirky and their firmware updates usually break more things than improve them. I was looking forward to migrating as many have to here, OpenHAB, however I almost heartbroken and crushed that IMO the most basic of functions do not work WHAT SO EVER and by basic I mean removing a previously discovered Zwave device from the Paper UI Inbox or the HABmin list. Please Please Please tell me I am doing something completely wrong. Do I really have to use a terminal app to connect to the Raspberry PI and locate and manually edit a file to prevent these devices from appearing and the platform from thinking they are there??

Thanks in advance, I promise I want to fall in Love with OpenHAB.

Todd


(Kris K) #2

Hi Todd,

What version of OH2? I find removing items works just fine using PaperUI and ZWave devices.

From what I know, if you defined them in item files you need to also remove them from there or unlink them in paperUI before removing them in the same ui.


(Vincent Regaud) #3

Hi @Todd_Mathewson
I am sorry you feel that way. OpenHAB has it’s many quirks.
In order for us to be able to help we will need a bit more detailed information.
Please follow the guidelines in: How to ask a good question


(Rich Koshak) #4

So, the devices that OH discovers and puts in the inbox come from the controller. As long as the controller has that node, it will show up in the inbox until you choose to ignore it (the eye icon with the line through it) or add it.

If you delete it (trash can icon), the Thing will come back into the Inbox the next time you search for Zwave Things because that node is still on the controller. You would need to delete that node from the controller to keep it from showing back up again. You can do this through Habmin.

Even this won’t work because the problem is the node is still on the controller. You must do this through Habmin or through some third party zwave software.

One thing to keep in mind as you set your expectations is that PaperUI and pretty much the rest of OH needs to generically support orders of magnitude more protocols, technologies, and APIs (350+) than Vera does (6? or so). There will be little things like this that will pop up for various technologies.

It has been a long time since I’ve done this but I believe you need to do the following to remove the node from the controller.

  1. Accept the Thing from the Inbox.
  2. In Habmin browse to Configuration -> Things -> the Thing representing that Node
  3. Click on the Tools button in the upper right and select “Show Advanced Tools” (or something like that)
  4. Click the Tools button again and now you will have a “Remove device from controller” option. Choose that.

IIRC this will remove the Thing and remove the node from the controller. If it doesn’t remove the Thing you can delete that by clicking on the trashcan button at the top.

That node will no longer show up in the inbox unless you pair another device with the controller in which case it may reuse that node number.

And for what it’s worth, asking for help is not complaining. But to help others who might have this same problem find this thread, it would be helpful if you change the subject of the topic to something more descriptive and add the zwave tag.


[SOLVED] Z-Wave: cannot remove "phantom" devices
(scott dee) #5

i just had to remove a couple failed zwave items and the suggestion above works (thing has to be added->habmin->delete)


(First Last) #6

I have the same issue (described in this thread), however these steps didn’t help, HABmin reports a failure and the nodes keep appearing in my inbox after discovery:


(Todd Mathewson) #7

Rich,

Thank you, that makes perfect sense. I had wondered if the Zwave controller was actually going into exclude mode. I almost tried changing over to an Aeon Z-stick that I’m more familiar with but got sidetracked SSH’ing into the Pi.

When I return home tonight (I’m out of town working today), I will follow your lead. I will also change my post title an subject to be more fitting and helpful.

Thank you again. Hope you have a great day.

Todd


(Todd Mathewson) #8

Well thank you all for the prompt suggestions. I am running release 2.3 with the Nortek HUSBZB-1 Zwave / Zigbee USB dongle on a Raspberry Pi3. Turns out, just as Rich explained, the Paper UI did not put the controller into what I would call “Exclude” mode. Following the remove device procedure steps listed in Rich’s post, the devices have been banished!!! YAY!!! I was so distressed as I have reached the limits of the Vera System I which I’ve invested so much time in. Overanxious for the quick fix before putting in the time and patience to learn a new system was the true core of this problem.

Thank you all for your suggestions and guidance.

Todd