[SOLVED] Unknown Device - Neo Coolcam Motion Sensor(PIR)

Tags: #<Tag:0x00007f432f9449f8>

Yep didn´t have problems with that one:
This is my BasicUI for Coolcam PIR.

In my setup I have used thing and items configuration in Paper UI. Did you setup items in Paper UI or configuration files? I suspect that there is something wrong with PaperUI because switch linked to sensor_binary channel shows only label in control section (no switch on the right side of the label). In the same time this item works properly in Basic UI.

I´ll have to look later tonight, cause I´m in the middel of converting all my PaperUI items to configurations files. And I don´t remember if I have done this Neo Coolcam yet.
But… I did start with PaperUI items, so I know it works for sure, from PaperUI.

Just checked. My Neo Coolcam is setup from PaperUI only.

Thanks for confirmation. Unfortunatelly in my case this looks like that:

image

Switch is visible and works in basic UI. In Paper UI it is visible only for short amount of time after item creation.

Thats odd… I have no idea. Perhaps @chris can help, but you´ll have to enable debug.
Maybe something wrong with the binding.

Have you tried exclude and include again?

I suspect that there might be something wrong with the device itself. I tried one more time to wake it and then battery level 100 % and constant 0 in luminance appeared. But in the same time log stopped showing movement detection from binary sensor. Then I have excluded and included device into network and now switch works correctly in PaperUI and Basic UI but rest of the data is not shown. I am not sure if it is worth to debug this further… Thanks for your support.

I had to wake up my Coolcam quite a few times, before it got fully included. Also, make sure you´re close to your zwave controller when doing so. This is a highly important part specially the first times when you add a battery driven device to your network.

Also you could try using the “refresh” option from Habmin. Pick the device, and below the general, This tend to update the values when there are problems.

If this wont work, I tend to agree with you, something wrong with the device or it´s not fully working with your controller.

+1 on the response above from Kim_Andersen.

I had issues getting a couple of these sensors added completely. The first one added with no problems, so at least I knew what to expect when it was done. Another did not, but I found that re-entering include mode multiple times in succession near the controller resulted in it finishing discovery relatively quickly. To watch it happen I ran ‘tail’ against the event.log and watched for logs for the device status change while hitting the button to enter inclusion mode. For me, simply waking up the device multiple times didn’t seem to work, but re-entering inclusion mode on the device was the trick.

Hello everyone,

I really want to order and test one of these motion sensors. I think they are really balanced between cost and functionalities (including temperature, luminance, etc.). Who is using them could you please tell me if you are using the Z-Wave Motion Sensor(PIR) or the Z-Wave Motion Sensor(PIR)2? Any more difficulties encountered besides the ones stated above? Where did you buy them from?

Thank you very much in advanced for your feedback.

I’m not sure which is which, but I have both models of neo coolcam pir sensors connected with Z-wave. Both works good except temperature. I’ve never seen this value properly received.

Good evening,

Thanks a lot for the info.

Thanks, this helped and made OpenHAB to include the device !

Apologies to bump and old thread, but I’ve been attempting to add one of these for an hour or two.

I think mine may be a slightly newer model, though it looks the same as here: Z wave DB

The manufacturer is the same 0258, DevType and ID 0003:608d which I don’t see in the DB. Is it a matter of adding it? or am I misinterpreting what is in there?

I have the XML here: Dropbox

Been doing a bit of reading but unsure of the next steps.

Are you aware of any other changes between your device and what is in the database (e.g., configuration options, association groups, etc.)? The XML does not always show that there is a difference. If there is nothing different, then the type:id just needs to be added to this device type. If there is a difference, then a new entry needs to be created.

The one I have is just Light Sensor and PIR.

So matches the description in the DB: “Motion Sensor with illuminance and sometimes a temperature feature”

Do you have a manual for your device that can be compared to the one in the db?

Thanks Scott, good call!

Word for word the parameters and numbers are the same in the tiny manual as the DB.

I have added 0003:608d to the db. You could do a build of the binding with this change, modify the latest jar with it, or there should be a new build within a week that you could manually install. You could also wait for 2.5.4, which should be out within 30 days from 2.5.3.

Thanks Scott, for the how-to’s.

I’d found some time to spend on this today.

Manually updating the JAR, in which I added the modded JAR to addons in a whole new 2.5.4 SNAPSHOT build so I wouldn’t compromise my current configuration, I just couldn’t get it to play…

The new binding shows the same

NODE 17: Device discovery could not resolve to a thingType! 0258:0003:608D::3.80

Yet when I dig into the JAR archive, as it stits in that instances \openhab254\addons\org.openhab.binding.zwave-2.5.4-SNAPSHOT.jar\ESH-INF\thing\shenzhen\

open up this entry

<!-- DEVICE PROPERTY DEFINITIONS -->
<properties>
  <property name="vendor">Shenzhen Neo Electronics Co., Ltd</property>
  <property name="modelId">Motion Sensor</property>
  <property name="manufacturerId">0258</property>
  <property name="manufacturerRef">0003:0083,0003:008D,0003:1083,0003:2083,0003:608D</property>
  <property name="dbReference">401</property>
  <property name="defaultAssociations">1</property>
</properties>

The 2.5.4 build also had the controller disconnecting and reconnecting over and over, lots of verbose Java exceptions I scarcly understand, so I might just wait out the next 2.5.4 stable and dedicate some time to a full upgrade. There’s always syntax and config changes to be made each update.

Thanks though, I did learn quite a few things!

1 Like