[SOLVED] Website not working

Having installed openhab with the instructions from here:


I fail to connect to the server using url http://openhab:8080/ above
I get the error message;

HTTP ERROR 404

Problem accessing /start/index. Reason:

Not Found

I must be overlooking something simple but I don’t understand what it is.
On the rasberry pi where I have all running I get this when I check for the service itself

pi@OpenHab:~ $ sudo systemctl status openhab2.service
● openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor pre
Active: active (running) since Tue 2019-12-24 23:18:58 CET; 1h 27min ago

Main PID: 365 (java)
Tasks: 96 (limit: 2200)
Memory: 187.5M
CGroup: /system.slice/openhab2.service
└─365 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf

Dec 24 23:18:58 OpenHab systemd[1]: Started openHAB 2 - empowering the smart hom
lines 1-12/12 (END)

Any thoughts on what part I have forgotten?
The installation guide is referring to a config file but whatever I try…I never have access to these folders. I’m logging in to the server itself with my pi (admin) user.

Any hints are appreciated. Linux is not my cup-of-tea (yet) but I’m learning by doing this.

Try replacing “openhab” with the actual ip address or hostname. The service is running allright but is there something in the logs? /var/log/openhab2/…

thanks but I tried that as well: http://192.168.178.23:8080 but it returns the same error message

Did you check that your router/computer firewal are not blocking the port 8080?

1 Like

Even if I do this on the server itself…I get the error message.
What is clear is that the linux machine is returning with the answer…accept that it does not find anything. Is there something I have missed in the setup?

What about the logs?

Have you tried the old “reboot everything” gimmick?

I was also going to say that it takes a good long while for openHAB to boot all the way up to the point of presenting any UIs (tons of Java stuff) (as opposed to just the service being started in Linux) but from your quote it looks like you waited like an hour and a half already.

Not sure what else to look into without more info. So yeah, like Miguel said, logs…

Somebody that installed the addons package had a similar issue.

I have rebooted the server multiple times. Even start and stopped the service.
The openhab log, however, is remarkable emtpy…this is all it has.

2019-12-24 21:05:06.075 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at http://192.168.178.23:8080
2019-12-24 21:05:06.311 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at https://192.168.178.23:8443
2019-12-24 21:05:09.128 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2019-12-24 21:06:14.278 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard
2019-12-24 22:52:09.244 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2019-12-24 23:21:33.164 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

Would be nice to get this going on Xmas day :slight_smile:

I would give two tips just to make sure you are getting the response from openHAB.

  1. Connect to your web browser on port 8080 not the response.
    2 shutdown openHAB service and try to connect again see if response changes.

My reason for this would be to verify that openHAB is what’s responding on port 8080. We want to make sure another service is not responding. If it were then telling you that start/index does not exist would be true.

Let’s see if we can get you what you want for Christmas. :smiley:

Why does it start 2 dashboards on 2 different ports, and then stop one of them? Is this normal behavior?

I think this is normal,:thinking: as one port is for http and the other is https.

@nc1264 Make sure you are not trying to connect using IPv6, I’ve read else where it can cause issues.

Can you point me to these discussions? I use IPv6 as much as possible and haven’t encountered any problems beside misconfigurations. From wan side my system is only accessible with IPv6.

I didn’t bookmark them, just remembered reading that changing to IPv4 solved the issue. Honestly can’t remember if the issue was website related or not just thought I would throw it out there as somthing OP could consider/try if nothing else is working.

I will try and remember to send you a link when/if I run across a post related to IPv6 and issues.

1 Like

Hello,
I’m brand new to OpenHAB but I am an experienced Linux admin.

I did an installation of OpenHAB 2.5.0 on an Ubuntu server 18.04.3 today using the following procedures:

  1. Installed zulu-8 x64 using apt repository as described here https://docs.azul.com/zulu/zuludocs/ZuluUserGuide/InstallingZulu/InstallOnLinuxUsingAPTRepository.htm
  2. Installed OpenHAB through the stable apt repository as described here: https://www.openhab.org/docs/installation/linux.html

Result: I have exactly the same issue as described in this thread:
HTTP ERROR 404
Problem accessing /start/index. Reason:
Not Found

with a very limited log similar to that of nc1264 with the info line
[INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard

I’ve spend 3 hours looking around the internet and tried everything already (restart service, machine, cleared cache, …).
Nothing works. And this should be a non-complicated install. I’m not migrating any data here: it’s a clean first-time install.

Because I’m on a VM and took a snapshot before installing :-), I rolled-back anc installed exactly the same setup but with OpenHAB 2.4.0-1
–> worked like a charm out of the box !!!

I’ve upgraded it to 2.5.0 and exactly the same as before.

Does anybody have a working (clean) OpenHAB 2.5 with zulu-8 on Ubuntu server 18.04.3? I’m starting to think this particular combination has an issue.

Thanks in advance for your help,
Actually looking forward to working with OpenHAB.

1 Like

Helluva first post. :smiley: Welcome!

Yeah, maybe something is going on with that combination.

And yeah, you are going to love it. Hang in there through the learning curve though. You get your head around the relationships between items, channels, things, etc.?

The other thing is that there are multiple different ways to do things, multiple interfaces, and they are not all exactly the same (feature parity).

Those were probably my two biggest stumbling blocks, especially the latter. But maybe you are smarter than me. :smiley:

Well worth the payoff though.

@nc1264,

OK, it seems that a potential workaround has been discovered in the following posts in a related thread:


Can you also test and confirm that fixes it for you as well?

2 Likes

Apparently some people have installed the bindings package causing issues. It is normally not needed. IT is only for systems unable to access the public Internet to update.

TRS-80,

I ran the commands you mentioned and low and behold…the website is up and running!
Thank you very much for your help. I would not have found this myself.

I haven’t installed the addons yet…but I will certainly try it. At least now I know how to resolve this.

Regards,

Ron

You do not really need the addons package. Just install whatever addons you need and they will get downloaded and installed.